Last Comment Bug 705874 - Binary XML file line #6: Error inflating class org.mozilla.gecko.BrowserToolbar (Startup crash on Android 2.1)
: Binary XML file line #6: Error inflating class org.mozilla.gecko.BrowserToolb...
Status: VERIFIED FIXED
[native-crash][eclair] [blacklist], s...
: crash, relnote
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
P5 critical (vote)
: Firefox 13
Assigned To: Sriram Ramasubramanian [:sriram]
:
: Sebastian Kaspari (:sebastian)
Mentors:
http://pastebin.mozilla.org/1388756
: 713095 (view as bug list)
Depends on:
Blocks: 719373
  Show dependency treegraph
 
Reported: 2011-11-28 13:58 PST by Nicolas B. Pierron [:nbp]
Modified: 2012-02-10 01:25 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified
verified
11+


Attachments
Logcat. (8.99 KB, text/plain)
2012-01-19 15:51 PST, Patrick Walton (:pcwalton)
no flags Details
patch to use fill_parent instead of match_parent (12.83 KB, patch)
2012-01-30 22:29 PST, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description User image Nicolas B. Pierron [:nbp] 2011-11-28 13:58:21 PST
version: Nightly -- fennec-11.0a1.en-US.android-arm-1.apk (13.70 M) downloaded the 11-28 13:10

The logcat is available at http://pastebin.mozilla.org/1388756

About the phone:
Type: Samsung Galaxy S 1
Model: GT-I9000
Firmware: 2.1-update1
Baseband: I9000XXJF3
Kernel: 2.6.29 umts_scm@S1-BUILD05 #2
Build: ECLAIR
Comment 1 User image Julien Vermet | JulienDev 2011-12-01 16:02:36 PST
The logcat is not available anymore. Can you upload it again and change the "How long should your post be retained?" setting to forever?
Comment 2 User image Tony Chung [:tchung] 2011-12-05 09:11:55 PST
sounds like a 2.1 crasher.  will start adding [eclair] to the whiteboard to track these bugs
Comment 3 User image Doug Turner (:dougt) 2011-12-08 09:38:53 PST
ram - can you list the devices that have this problem - we probably want to just mark these devices as unsupported.
Comment 4 User image Sriram Ramasubramanian [:sriram] 2011-12-08 10:01:47 PST
This is usually caused in 2.1 devices. I'm not sure if it's a problem with AT&T locked phones though.
http://stackoverflow.com/questions/7619945/android-resources-not-found-on-some-devices -- this specifies the exact problem observed.
Also, most of the APIs we use are targeted for level 8 and not 5. This could cause even more crashes.

(The best way to see if we are API level 5 complaint is by using Romaxa's scripts and loading our project in eclipse. Eclipse will check every line against the specified SDK and will show as where we are not using API level 5 methods).
Comment 5 User image Mark Finkle (:mfinkle) (use needinfo?) 2011-12-12 14:14:02 PST
We should blocklist the bad phones or just drop eclair support
Comment 6 User image Mark Finkle (:mfinkle) (use needinfo?) 2011-12-29 11:53:09 PST
*** Bug 713095 has been marked as a duplicate of this bug. ***
Comment 7 User image Nicolas B. Pierron [:nbp] 2012-01-11 14:37:26 PST
(In reply to Sriram Ramasubramanian [:sriram] from comment #4)
> This is usually caused in 2.1 devices. I'm not sure if it's a problem with
> AT&T locked phones though.

My phone was unlocked when I bought it in France. (mid September 2010)
About the logcat, I can ask someone to dump one again because I no longer have it.
Comment 8 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-01-17 19:16:36 PST
dropping priority. we could be dropping 2.1 support too.
Comment 9 User image Patrick Walton (:pcwalton) 2012-01-19 15:51:43 PST
Created attachment 590027 [details]
Logcat.

Logcat attached.
Comment 10 User image Sriram Ramasubramanian [:sriram] 2012-01-25 09:53:53 PST
We are using both "match_parent" and "fill_parent" on XML layout files (and some parts of code).
http://developer.android.com/reference/android/view/ViewGroup.LayoutParams.html#MATCH_PARENT -- is introduced only in API Level 8. This could be a reason for the crash.
Comment 11 User image Brad Lassey [:blassey] (use needinfo?) 2012-01-30 22:29:15 PST
Created attachment 592997 [details] [diff] [review]
patch to use fill_parent instead of match_parent
Comment 12 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-01-30 23:00:35 PST
Comment on attachment 592997 [details] [diff] [review]
patch to use fill_parent instead of match_parent

Brad mentioned that only the XML is a problem. The Java constants are the same value. Let's see if this works.
Comment 13 User image Cristian Nicolae (:xti) 2012-02-01 06:56:50 PST
This issue occurs on the latest Nightly build for Samsung Galaxy S (2.1).

Log: http://pastebin.mozilla.org/1471130

--
Mozilla/5.0 (Android;Linux armv7l;rv:13.0a1)Gecko/20120201
Firefox/13.0a1 Fennec/13.0a1
Device: Samsung Galaxy S
OS: Android 2.1-update1
Comment 14 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-02-01 07:27:42 PST
From the log:

E/AndroidRuntime( 3862): Caused by: android.content.res.Resources$NotFoundException: File 
...
E/AndroidRuntime( 3862): Caused by: org.xmlpull.v1.XmlPullParserException: Binary XML file line #5: <bitmap> requires a valid src attribute

Which is:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/resources/drawable/address_bar_bg.xml#6

Is something about that "src" value not legal?
Comment 15 User image Brad Lassey [:blassey] (use needinfo?) 2012-02-01 08:49:38 PST
(In reply to Cristian Nicolae (:xti) from comment #13)
> This issue occurs on the latest Nightly build for Samsung Galaxy S (2.1).
> 
> Log: http://pastebin.mozilla.org/1471130
What's in that log is a different bug. Can you file a new bug to track it separately?


(In reply to Mark Finkle (:mfinkle) from comment #14)
> From the log:
> 
> E/AndroidRuntime( 3862): Caused by:
> android.content.res.Resources$NotFoundException: File 
> ...
> E/AndroidRuntime( 3862): Caused by: org.xmlpull.v1.XmlPullParserException:
> Binary XML file line #5: <bitmap> requires a valid src attribute
> 
> Which is:
> http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/resources/
> drawable/address_bar_bg.xml#6
> 
> Is something about that "src" value not legal?
Yea, it doesn't exist on eclair. In fact, none of our drawables do.
Comment 16 User image Brad Lassey [:blassey] (use needinfo?) 2012-02-01 09:18:23 PST
btw... landed this on inbound, changeset ab671e01a7da
Comment 17 User image Brad Lassey [:blassey] (use needinfo?) 2012-02-01 09:31:11 PST
(In reply to Brad Lassey [:blassey] from comment #15)
> (In reply to Cristian Nicolae (:xti) from comment #13)
> > This issue occurs on the latest Nightly build for Samsung Galaxy S (2.1).
> > 
> > Log: http://pastebin.mozilla.org/1471130
> What's in that log is a different bug. Can you file a new bug to track it
> separately?

I file bug 723151 for it
Comment 18 User image Ed Morley [:emorley] 2012-02-01 11:24:50 PST
https://hg.mozilla.org/mozilla-central/rev/ab671e01a7da
Comment 19 User image Brad Lassey [:blassey] (use needinfo?) 2012-02-02 14:22:22 PST
Comment on attachment 592997 [details] [diff] [review]
patch to use fill_parent instead of match_parent

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
crash on startup on eclair
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Comment 20 User image Cristian Nicolae (:xti) 2012-02-03 09:16:29 PST
Verified fixed on:

Mozilla/5.0 (Android;Linux armv7l;rv:13.0a1)Gecko/20120203
Firefox/13.0a1 Fennec/13.0a1
Device: Samsung Galaxy S
OS: Android 2.1-update1
Comment 21 User image Cristian Nicolae (:xti) 2012-02-03 09:24:26 PST
Reopening bug for aurora nom
Comment 22 User image Alex Keybl [:akeybl] 2012-02-05 13:36:54 PST
Comment on attachment 592997 [details] [diff] [review]
patch to use fill_parent instead of match_parent

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Comment 23 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-02-06 09:22:53 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/06e1d3d61dda
Comment 24 User image Brad Lassey [:blassey] (use needinfo?) 2012-02-06 18:43:02 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/f757c1020dec
Comment 25 User image Andreea Pod 2012-02-10 01:25:38 PST
Crash no longer reproducible.

Verified fixed on:
Firefox 11 (tinderbox build): 1328844077/09-Feb-2012 20:42 
20120209192117	
Firefox 12: Firefox 12.0a2 (2012-02-09)
Firefox 13: Firefox 13.0a1 (2012-02-09)

Device: Samsung Galaxy S Captivate 
OS: Android 2.1-update1

Note You need to log in before you can comment on or make changes to this bug.