Closed Bug 707277 Opened 12 years ago Closed 12 years ago

No indication of where an app is installed after clicking install

Categories

(Marketplace Graveyard :: Consumer Pages, defect)

defect
Not set
normal

Tracking

(blocking-kilimanjaro:+)

RESOLVED DUPLICATE of bug 747283
blocking-kilimanjaro +

People

(Reporter: mdabbagh.mozilla, Unassigned)

References

Details

When the user installs a native app, it is unclear to them as to where the app was installed on their machine. It would be helpful if another door-hanger notification or a pop-up appeared stating the locations of the native apps on the different supported operating systems.

Steps to Reproduce:
1. Launch Firefox - make sure to use FF9 or greater
2. Install the Apps extension - Can be found at http://people.mozilla.com/~dclarke/openwebapps/Extension/ and look for openwebapps-78d3014fe4-12_01_2011.xpi
3. Go to apps.mozillalabs.com/appdir 
4. Install an app - Make sure to choose 'Install (with Native app)' from the door-hanger notification

Actual Result:
No indication of where the native app was installed is given.

Expected Results:
A notification of some sort stating where native apps are installed on the supported platforms would be good.
Whiteboard: devPreviewNonBlocker
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/24808715
Definitely mozilla-central worthy. This is noted on the requirements for the web apps integration into desktop feature.
Blocks: 731054
Component: Extension → General
Product: Web Apps → Firefox
QA Contact: extension → general
Target Milestone: --- → Firefox 14
Component: General → Web Apps
QA Contact: general → webapps
Whiteboard: devPreviewNonBlocker → devPreviewNonBlocker [marketplace-beta?]
Blocks: 697006
No longer blocks: 731054
Summary: No indication of where a native app is installed on the user's machine → No indication of where an app is installed on the user's machine
generalizing this, since it's not clear to the user what happens post install
Summary: No indication of where an app is installed on the user's machine → No indication of where an app is installed after clicking install
Target Milestone: Firefox 14 → ---
This needs to be a part of the doorhanger notification process Fabrice implemented. Assigning to Fabrice.
Assignee: nobody → fabrice
Please don't assign me desktop specific bugs without asking. Thanks.
Assignee: fabrice → nobody
Blocks: 731054
Whiteboard: devPreviewNonBlocker [marketplace-beta?]
Blocks: 731543
No longer blocks: 731054
blocking-kilimanjaro: --- → ?
Blocks: 731054
Hardware: x86_64 → All
Whiteboard: [marketplace-beta-]
Whiteboard: [marketplace-beta-] → [marketplace-beta=]
Not going to block on this but it would be a nice k9o addition.
blocking-kilimanjaro: ? → -
Sorry - this should be a blocker for k9o. If not, users will have no way of finding where their apps went after installation.
(In reply to Ragavan S [:rags] from comment #7)
> Sorry - this should be a blocker for k9o. If not, users will have no way of
> finding where their apps went after installation.

Agreed. Initial testing from contributors and internal employees has already shown this to a significant UX problem.
Me three.  And I suspect Diane would concur, given discussions we had yesterday about the current and her soon-to-be-proposed UX for installing apps in Firefox 15 Desktop.
blocking-kilimanjaro: - → ?
We are seeing feedback on our internal release already about this. The current implementation in Desktop is just at alpha quality and so the full flows were not implemented in time for this release.
blocking-kilimanjaro: ? → +
Version: unspecified → 15 Branch
Based on the recent UX discussion, one partial proposal in the air to solve this could be indicating where the application was installed on the user's machine. This includes saying things such as:

- Created a desktop shortcut on your machine
- Added to your start menu
Blocks: k9o-webrt
Changing the dependency around since this bug depends on bug 731543 being fixed.
No longer blocks: 731543
Depends on: 731543
(In reply to Jennifer Arguello :ticachica from comment #12)
> Changing the dependency around since this bug depends on bug 731543 being
> fixed.

I wonder if we should call this bug a dup of bug 731543, as they both relate to the same underlying problem.
Priority: -- → P1
Whiteboard: [marketplace-beta=] → [marketplace-beta=], [blocking-webrtdesktop1+]
(In reply to Jason Smith [:jsmith] from comment #13)
> (In reply to Jennifer Arguello :ticachica from comment #12)
> > Changing the dependency around since this bug depends on bug 731543 being
> > fixed.
> 
> I wonder if we should call this bug a dup of bug 731543, as they both relate
> to the same underlying problem.

It'd be great to have a meta bug with both the desktop and the fennec post install attached to it. This would be helpful for K9o tracking.
Target Milestone: --- → Firefox 15
Whiteboard: [marketplace-beta=], [blocking-webrtdesktop1+] → [blocking-webrtdesktop1+]
No longer blocks: 731054
FYI - Marketplace has put in a UI in the short-term to partially mitigate the issue identified in this bug. We should resolve this on our end though (this is a problem on our end of the code). When we fix this, we should sync up with the marketplace team to see if there post-install UI is still needed or not.
For Fx15 UX has recommended using what marketplace has established for now for post-install notifications. Migrating to Marketplace and marking as resovlved fixed. Krupa - What bug should this be duped against? Or should this remain resolved fixed? Feel free to change it to your needs.
Component: Web Apps → Consumer Pages
Keywords: uiwanted
Product: Firefox → Marketplace
QA Contact: webapps → consumer-pages
Target Milestone: Firefox 15 → ---
Version: 15 Branch → 1.0
Status: NEW → RESOLVED
Closed: 12 years ago
Priority: P1 → --
Resolution: --- → DUPLICATE
Whiteboard: [blocking-webrtdesktop1+]
Component: Consumer Pages → General
Product: Marketplace → Firefox
QA Contact: consumer-pages → general
Version: 1.0 → unspecified
Component: General → Consumer Pages
Product: Firefox → Marketplace
QA Contact: general → consumer-pages
Version: unspecified → 1.0
You need to log in before you can comment on or make changes to this bug.