Refactor and improve reconciling and storing of records

RESOLVED FIXED

Status

Android Background Services
Android Sync
P1
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: ally, Assigned: rnewman)

Tracking

unspecified
ARM
Android
Dependency tree / graph

Firefox Tracking Flags

(firefox11 fixed, firefox12 fixed, fennec+)

Details

Comment hidden (empty)
(Assignee)

Updated

6 years ago
OS: Mac OS X → Android
Hardware: x86 → All
(Assignee)

Comment 1

6 years ago
Gonna need to address this ASAP.
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Hardware: All → ARM
(Assignee)

Updated

6 years ago
Blocks: 709341
No longer blocks: 709339
(Assignee)

Updated

6 years ago
Blocks: 718493

Updated

6 years ago
tracking-fennec: --- → ?

Updated

6 years ago
tracking-fennec: ? → +
(Assignee)

Updated

6 years ago
Depends on: 715796
(Assignee)

Updated

6 years ago
Blocks: 722514
(Assignee)

Comment 2

6 years ago
Slimming this down to land in two parts.
No longer depends on: 715796
Summary: Transactional behavior for store (don't return stored records in subsequent fetch) → Refactor and improve reconciling and storing of records
(Assignee)

Updated

6 years ago
Blocks: 722945
(Assignee)

Updated

6 years ago
Blocks: 720934
(Assignee)

Comment 3

6 years ago
All merged:

https://github.com/mozilla-services/android-sync/commit/23bdfc8f25d6708c7254377e0a0b36098de3d61f
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

6 years ago
https://hg.mozilla.org/mozilla-central/rev/dab232f3a4f3
(Assignee)

Comment 5

6 years ago
Aurora: http://hg.mozilla.org/releases/mozilla-aurora/rev/4f769f1fcf82
Beta:   http://hg.mozilla.org/releases/mozilla-beta/rev/506cdabe8b0c
Blocks: 724102
status-firefox11: --- → fixed
status-firefox12: --- → fixed
Please provide STR's for verification.
Duplicate of this bug: 724102
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services
You need to log in before you can comment on or make changes to this bug.