Favicon is not stored if a new bookmark is added with history disabled




Bookmarks & History
6 years ago
27 days ago


(Reporter: sworddragon2, Unassigned)


Firefox Tracking Flags

(Not tracked)


(Whiteboard: [fxsearch])



6 years ago
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120102174738

Steps to reproduce:

I opened any site which has a favicon (for example this bugreport) and added it to my bookmarks.

Actual results:

The new bookmark entry has the default favicon (a dashed square).

Expected results:

The new bookmark entry should have the favicon from the site (for example the green bug on this site)

Comment 1

6 years ago
The safe mode doesn't change the behaviour. There is a workaround to fix the new entry: If the bookmark is clicked the favicon of the site will be downloaded and stored.

Comment 2

6 years ago
WFM with Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20120104 Firefox/12.0a1 ID:20120104031035

IIRC there was/is a bug that has since been fixed.
Component: Bookmarks & History → Untriaged
QA Contact: bookmarks → untriaged
there was a bug hitting Mac native menubar and should be fixed in 10. Not sure if something similar may apply to linux.  Where did you add the bookmark, toolbar, menu? Do you have a linux distro with a native menubar?

the alternative was an add-on... safe mode didn't make a difference though.

Comment 4

6 years ago
>Where did you add the bookmark, toolbar, menu?

From the toolbar: Bookmarks -> Bookmark This Page -> Done

>the alternative was an add-on... safe mode didn't make a difference though.

The addons were disabled in the safe mode.

I have tested this now in the prerelease of Firefox 12 with a new profile and the bug appears there too. But I have found now the reason why this bug appears. In "Edit -> Preferences -> Privacy" must "Use custom settings for history" be activated and "Remember my browsing history" be disabled. If I enable this option all is working fine on the Beta of Firefox 10.
ah, this happens because the icon is not saved without history, when you store the bookmark the page is just pinned but we don't try to store the icon again.


6 years ago
Component: Untriaged → Bookmarks & History
Ever confirmed: true
QA Contact: untriaged → bookmarks

Comment 6

6 years ago
openSUSE 12.1, KDE 4.7.2, 32 bits system, Mozilla/5.0 (X11; Linux i686; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1, upgraded yesterday 18.02.2012, i was not able to reproduce this, i have opened several sites (including Bugzilla) that have a favicon and after i added them as bookmarks their icon appears.

Comment 7

6 years ago
The bug still exists in the latest nightly. Have you disabled the history as explained above?

Comment 8

6 years ago
Retested the situation with history disabled and indeed its still there. Dragon i might overlooked that one when i did the first test.


5 years ago
Summary: Favicon is not stored if a new bookmark is added → Favicon is not stored if a new bookmark is added with history disabled

Comment 9

4 years ago
I have also noticed an additional related issue (tested with Firefox 32) if "Remember my browsing and download history" is disabled. After importing some bookmarks and visiting their sites to get the favicons downloaded only a few of them got successfully downloaded. Here are some details:

- On reproducing this a few times always the same bookmarks were affected.
- Even with several bookmarks on the same domain (for example different Sourceforge projects) some bookmarks are affected and some others not.
- On making a look into places.sqlite I have figured out that the affected bookmarks haven't got a value in the table moz_places in the row favicon_id on visiting the site.

But enabling "Remember my browsing and download history" and visiting the sites again works here as a workaround.
Duplicate of this bug: 1353779
OS: Linux → All
Priority: -- → P3
Hardware: x86_64 → All
Whiteboard: [fxsearch]
Version: 10 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.