Bug 715347 (download-manager)

Add basic Download Manager support

VERIFIED FIXED in Firefox 11

Status

()

P2
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: mfinkle, Assigned: mfinkle)

Tracking

unspecified
Firefox 12
ARM
Android
Points:
---
Dependency tree / graph
Bug Flags:
in-litmus +

Firefox Tracking Flags

(firefox11 verified, firefox12 verified, fennec11+)

Details

(Whiteboard: [QA-])

Attachments

(3 attachments)

Created attachment 585896 [details] [diff] [review]
patch

Android has a Download Manager. Since SDK 12, the Download Manager has supported a simple way to add external downloads to the service:
http://developer.android.com/reference/android/app/DownloadManager.html#addCompletedDownload%28java.lang.String,%20java.lang.String,%20boolean,%20java.lang.String,%20java.lang.String,%20long,%20boolean%29

This patch adds simple support using this API:
* Show "Downloads" menu (if Honeycomb or greater) that opens the Android Download Manager activity.
* When a Gecko download completes, we send a message to Java and use the Download Manager API to add the file.

It's my hope that we could use raw SQLite access for older versions of Android, at least back to Gingerbread. That's as far back as the system Download Manager seems to be supported.
Created attachment 585899 [details]
menu

"Downloads" in menu
Assignee: nobody → mark.finkle
Created attachment 585900 [details]
download manager

Gecko download in the system Download Manager
(Assignee)

Updated

7 years ago
OS: Linux → Android
Hardware: x86 → ARM
Looks good to me. This is all we really need, especially if we can get it on Gingerbread as well.
Comment on attachment 585896 [details] [diff] [review]
patch

Let's see if we can get this moving ahead and do the raw sqlite investigation in bug 695178
Attachment #585896 - Flags: review?(mbrubeck)
tracking-fennec: --- → 11+
Priority: -- → P2
Attachment #585896 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/8522883040c0
status-firefox11: --- → affected
status-firefox12: --- → affected

Comment 6

7 years ago
https://hg.mozilla.org/mozilla-central/rev/8522883040c0
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12

Updated

7 years ago
Blocks: 695178
Aurora nom?

Updated

7 years ago
Depends on: 716420
Comment on attachment 585896 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): none
User impact if declined: no ability to see downloads at all
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): low risk
Attachment #585896 - Flags: approval-mozilla-aurora?

Comment 9

7 years ago
Comment on attachment 585896 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Attachment #585896 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/ddca2bf272dc
status-firefox11: affected → fixed
status-firefox12: affected → fixed

Updated

7 years ago
Depends on: 717071

Updated

7 years ago
Depends on: 717231

Updated

7 years ago
Alias: download-manager

Updated

7 years ago
Depends on: 717257
Samsung Nexus S (Android 4.0.3)/Samsung Galaxy Tab 10.1 (Android 3.1)
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120119 Firefox/12.0a1 Fennec/12.0a1
Mozilla/5.0 (Android; Linux armv7l; rv:11.0a2) Gecko/20120119 Firefox/11.0a2 Fennec/11.0a2

https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=45163
https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=45164
https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=45165
https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=45166
Status: RESOLVED → VERIFIED
status-firefox11: fixed → verified
status-firefox12: fixed → verified
Flags: in-litmus+
Whiteboard: [QA-]
Depends on: 721802
You need to log in before you can comment on or make changes to this bug.