Last Comment Bug 716621 - Folder label/caption/name with new messages are misaligned in folder pane (is nearer to or overlaps the folder icon)
: Folder label/caption/name with new messages are misaligned in folder pane (is...
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: Thunderbird 13.0
Assigned To: Andreas Nilsson (:andreasn)
:
Mentors:
: 718447 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-09 11:50 PST by Andreas Nilsson (:andreasn)
Modified: 2012-10-23 05:37 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot of odd alignment (9.72 KB, image/png)
2012-01-09 11:50 PST, Andreas Nilsson (:andreasn)
no flags Details
Quick fix (637 bytes, patch)
2012-01-09 12:43 PST, Andreas Nilsson (:andreasn)
bwinton: review+
bwinton: ui‑review+
Details | Diff | Splinter Review
Screen shot with padding-left:31px in Tb 9 and Tb trunk (51.96 KB, image/png)
2012-02-03 23:15 PST, WADA
no flags Details
Patch in action (4.43 KB, image/png)
2012-02-14 15:43 PST, Andreas Nilsson (:andreasn)
no flags Details
Another screenshot, TB14 (18.76 KB, image/png)
2012-08-30 12:01 PDT, Yaron Sheffer
no flags Details
Picture shows folder text on top of icon (112.31 KB, image/png)
2012-10-22 11:00 PDT, Iestyn Guest
no flags Details

Description Andreas Nilsson (:andreasn) 2012-01-09 11:50:37 PST
Created attachment 587064 [details]
screenshot of odd alignment

It looks like labels for folders with new messages gets slighly misaligned with the rest of the labels.
Comment 1 Blake Winton (:bwinton) (:☕️) 2012-01-09 11:55:20 PST
Just as a note, it seems like the text is pushed over, so it's likely not a problem with the icon.  My wild guess is that some image element has a space after it (or not), and that's what's causing the mis-alignment.
Comment 2 Andreas Nilsson (:andreasn) 2012-01-09 12:43:52 PST
Created attachment 587086 [details] [diff] [review]
Quick fix

Changes the padding-left of the text from 16 to 21px.
Comment 3 Andreas Nilsson (:andreasn) 2012-01-16 09:35:25 PST
*** Bug 718447 has been marked as a duplicate of this bug. ***
Comment 4 :aceman 2012-01-25 08:31:21 PST
I have never seen this on linux. Is this something recent?
Comment 5 Ben Hearsum (:bhearsum) 2012-01-25 08:33:47 PST
I hit this for the first on the beta channel a few weeks ago, perhaps when I got my first 10.0 beta
Comment 6 Micah Gersten 2012-01-25 09:18:48 PST
Yes, I also hit this on 10.0 beta 2.
Comment 7 WADA 2012-02-03 23:15:40 PST
Created attachment 594398 [details]
Screen shot with padding-left:31px in Tb 9 and Tb trunk

Checked with padding-left:31px in userChrome.css.
cancel.png is 16px*16px "white X on red background" icon, so it's convenient to know center of the icon. Text color is canged to Read for ease of test result checking.

userChrome.css content. 
> @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
>
> treechildren::-moz-tree-cell-text(folderNameCol, newMessages-true),
> treechildren::-moz-tree-cell-text(folderNameCol, newMessages-true, selected),
> treechildren::-moz-tree-cell-text(folderNameCol, newMessages-true, focus),
> treechildren::-moz-tree-cell-text(folderNameCol, newMessages-true, selected, focus),
> treechildren::-moz-tree-cell-text(folderNameCol, specialFolder-Inbox, newMessages-true),
> treechildren::-moz-tree-cell-text(folderNameCol, specialFolder-Inbox, newMessages-true, selected),
> treechildren::-moz-tree-cell-text(folderNameCol, specialFolder-Inbox, newMessages-true, focus),
> treechildren::-moz-tree-cell-text(folderNameCol, specialFolder-Inbox, newMessages-true, selected, focus)
> {
>    color: #FF0000 !important;
>    background-color: #dddddd !important;
>    font-weight: bold !important;
>    margin-left: -16px !important;
>    padding-left: 31px !important;
>    background-image: url("file:///C:/wada/@@@/Data/Omni/Omni/chrome/classic/skin/classic/messenger/icons/cancel.png") !important;
>    background-repeat: no-repeat !important;
>    background-position: left !important;
> }

Upper  screen shot : Tb 9.0.1 on Win-XP.
  In Tb 9, space between cancel icon and red Inbox is wider than
  ordinal folder, because padding-left:31px is used by userChrome.css.
Bottom screen shot : Tb trunk daily build on Win-XP.
> Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20120129 Thunderbird/12.0a1
  In Tb 12.0a1, space between cancel icon and red Inbox is same as
  space between folder icon and folder name of ordinal folder,
  because same padding-left:31px is appropriate.

Space between account icon/folder icon(list-style-image) and account name/folder name(text box for list item) is different between Tb 9 and Tb 12.0a1(in Tb 12.0a1, perhaps 5px wider than Tb 9).
This is reason why larger padding-left: than Tb 9 is needed in Tb 10 or later.

Cause is tricky overlay of star icon on folder icon.
(1) Put a starmark image at left of text box by background-image.
(2) Shift string in text box(text of list item) to right by padding-left: AApx.
(3) Shift whole text box of list item to left by margin-left: -BBpx,
    in order to place starmark image upon folder icon(list-style-image).
Comment 8 WADA 2012-02-04 18:42:46 PST
In Tb on Win, icons for newMessages-true is added in second row of folder.png,
> http://mxr.mozilla.org/comm-central/source/mail/themes/qute/mail/icons/folder.png
and "star mark on folder icon" is controlled by image clip position only in folderpPane.css.
Inbox example in folderPane.css.
> treechildren::-moz-tree-image(folderNameCol, specialFolder-Inbox)
> { -moz-image-region: rect(0 48px 16px 32px); }
> treechildren::-moz-tree-image(folderNameCol, specialFolder-Inbox, newMessages-true)
> { -moz-image-region: rect(16px 48px 32px 32px); }
Many code changes and new folder.png is needed in this way than current slightly tricky way. But I think simplest way is best.
Comment 9 :aceman 2012-02-07 07:54:34 PST
I can now see this too on Linux with TB10. It was not there in TB9.
Comment 10 :aceman 2012-02-09 05:02:20 PST
*** Bug 725124 has been marked as a duplicate of this bug. ***
Comment 11 :aceman 2012-02-09 05:03:56 PST
There are also cases where the text is offset more that some pixels and even overlaps the icon. Is it the same problem? See bug 725124.
Comment 12 Blake Winton (:bwinton) (:☕️) 2012-02-13 13:50:31 PST
Comment on attachment 587086 [details] [diff] [review]
Quick fix

Okay, finally back on my request queue.

Since I don't have a linux box handy here, I'm going to pass this ui-r over to Andreas.

But I will say that if the UI is fine, the code seems reasonable.

Thanks,
Blake.
Comment 13 Andreas Nilsson (:andreasn) 2012-02-14 15:43:29 PST
Created attachment 597214 [details]
Patch in action

I can't take this ui-review from bwinton, as I did the patch.
This screenshot should make the review possible without a linux build though.
Comment 14 Andreas Nilsson (:andreasn) 2012-02-14 15:44:55 PST
Comment on attachment 587086 [details] [diff] [review]
Quick fix

Reassigning this ui-review back to Blake. Hopefully the screenshot should do as evidence that this fix works.
Comment 15 Blake Winton (:bwinton) (:☕️) 2012-02-14 15:51:01 PST
Comment on attachment 587086 [details] [diff] [review]
Quick fix

Looks good, based on the screenshot.  ui-r=me!  ;)

Thanks,
Blake.
Comment 16 :aceman 2012-02-20 01:18:30 PST
*** Bug 728732 has been marked as a duplicate of this bug. ***
Comment 17 :aceman 2012-02-20 01:44:27 PST
These bugs start to crop up because TB10 was released with the problem. And I still haven't got reply to comment 11. How should I proceed with duping the bugs?
Comment 18 Mark Banner (:standard8) 2012-02-21 05:34:17 PST
Checked in: http://hg.mozilla.org/comm-central/rev/6ecb91c6405a
Comment 19 :aceman 2012-04-25 07:45:08 PDT
Still no answer and the reports continue, as this is only in TB13.
Comment 20 :aceman 2012-04-25 07:45:14 PDT
*** Bug 748700 has been marked as a duplicate of this bug. ***
Comment 21 Sulev-Madis Silber 2012-06-19 10:48:31 PDT
This issue is not fixed, I want the original behaviour back, not the large empty space between icon and text.
Comment 22 Yaron Sheffer 2012-08-30 11:59:56 PDT
I haven't seen this bug before, but now I see it constantly in TB14 (Ubuntu 12.04 64-bit, Gnome). Sorry.
Comment 23 Yaron Sheffer 2012-08-30 12:01:16 PDT
Created attachment 656975 [details]
Another screenshot, TB14
Comment 24 Iestyn Guest 2012-10-22 10:56:57 PDT
This doesn't appear to be fixed/resolved in Thunderbird 15.0.1 Linux (Ubuntu 12.04 32-bit), yet the status of this ticket is marked RESOLVED FIXED.
Comment 25 Iestyn Guest 2012-10-22 11:00:48 PDT
Created attachment 673928 [details]
Picture shows folder text on top of icon

Folder text overlays icon image when receiving new email.
Comment 26 Yaron Sheffer 2012-10-22 11:04:19 PDT
Problem still appears in TB 16.0.1, Ubuntu 12.04 64-bit.
Comment 27 Ludovic Hirlimann [:Usul] 2012-10-23 05:31:02 PDT
(In reply to Yaron Sheffer from comment #26)
> Problem still appears in TB 16.0.1, Ubuntu 12.04 64-bit.

file anew bug please.
Comment 28 :aceman 2012-10-23 05:37:54 PDT
Or we should undupe bug 728732, bug 748700 and bug 725124 that have the same problem on the screenshot. So that no new bug needs to be filed.

Note You need to log in before you can comment on or make changes to this bug.