Clobber builds from mozilla-central crash at startup

RESOLVED FIXED

Status

()

Firefox for Android
General
P1
blocker
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dougt, Assigned: Ms2ger)

Tracking

(Blocks: 1 bug, {crash, regression})

12 Branch
All
Android
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash])

Comment hidden (empty)
This hasn't affected builds on Tinderbox yet, but I think we're also not sure whether any clobber builds have happened there that could have been affected by this.  So, I used the clobberer tool to force clobbers on our Android builders, which should take effect in this cset:
  https://tbpl.mozilla.org/?rev=8ffdb4c7404a
Target Milestone: Firefox 11 → ---
Version: unspecified → Trunk
According to various folks testing tinderbox and local builds, this seems to affect debug builds only.  Maybe related to bug 683127?
Version: Trunk → Firefox 12
Target Milestone: --- → Firefox 11
Version: Firefox 12 → unspecified
Target Milestone: Firefox 11 → ---
Version: unspecified → Firefox 12
(In reply to Matt Brubeck (:mbrubeck) from comment #2)
> Maybe related to bug 683127?

I doubt it. The parts that landed only affect the zip reading (not even the decompression part, just parsing zip headers and getting the compressed stream), not the linker itself.
(Reporter)

Comment 4

6 years ago
the crash I saw we were reading in an invalid length.  Mike, can you locally back out your change and do a debug build?
I get a lot of different crashes on debug builds, depending on what i do, and even just quitting triggers a crash. I tested on d85920b5691b, and then backed out bug 683127 completely (still crashed) and for good measure, I also backed out bug 712579 (still crashed)

Updated

6 years ago
Keywords: crash
Whiteboard: [native-crash]
I believe this is the same as bug 717336 that I filed yesterday. Will dupe that to here. I isolated it to somewhere between 011e3cef6068 and c42d08fdec34.
Duplicate of this bug: 717336
From bug 717336:

(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #6)
> I have an updated range:
> 
> e79ef0ffcb09 is good
> 2f310f456107 is bad

Comment 9

6 years ago
In another form:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e79ef0ffcb09&tochange=2f310f456107
Keywords: regression
(Assignee)

Comment 10

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/88acaad9c766

This should fix it
Assignee: nobody → Ms2ger
Blocks: 715093
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/88acaad9c766

Comment 12

6 years ago
Is it fixed?
Works for me now.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 716797
I''m still crashing with my own debug build shortly after startup, I've filed bug 719985 for it.
You need to log in before you can comment on or make changes to this bug.