Closed Bug 719230 Opened 8 years ago Closed 8 years ago

Main window closes by pressing Ctrl-W but should be only by Alt-F4 (in Windows)

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: abcdenis, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.25) Gecko/20111212 Firefox/3.6.16 YB/3.5.1
Build ID: 20111212142243

Steps to reproduce:

Press Ctrl-W in main window.


Actual results:

Main window closed.


Expected results:

Main window must remain opened and closed by pressing Alt-F4 only.
Ctrl-W is shortcut for closing child window.
Summary: Main window closes after pressing Ctrl-W but should be only after Alt-F4 (windows) → Main window closes by pressing Ctrl-W but should be only by Alt-F4 (in Windows)
(In reply to abcdenis from comment #0)
I think this was intentionally done by the developers; last Ctrl-w closes the main window.
(In reply to Hashem Masoud from comment #1)
> (In reply to abcdenis from comment #0)
> I think this was intentionally done by the developers; last Ctrl-w closes
> the main window.

indeed.  and this intentionally mimics firefox behavior.
I didn't see a duplicate of this, so closing invalid.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
(In reply to Wayne Mery (:wsmwk) from comment #2)
> (In reply to Hashem Masoud from comment #1)
> > (In reply to abcdenis from comment #0)
> > I think this was intentionally done by the developers; last Ctrl-w closes
> > the main window.
> 
> indeed.  and this intentionally mimics firefox behavior.
> I didn't see a duplicate of this, so closing invalid.

This is not true.

Right now I reproduced the experiment:
1. start TB
2. double click message so it was opened in separate window
3. focus main TB window and press Ctrl-W
4. main window disappeared but message window remains, looks like orphan and does not get a way to restore main window so I had to launch it from taskbar again.

Unfotunately I cant change status of this ticket.
Status: RESOLVED → VERIFIED
the behavior is still intentional - closing the last "tab" closes the window, not necessarily the application. 

there are other bugs which cover the last situation you describe.  Another way to bring back the main menu from a message window is tools | mail & newsgroups
Duplicate of this bug: 1349592
You need to log in before you can comment on or make changes to this bug.