Last Comment Bug 720154 - Checkbox for restore_on_demand should always be accessible
: Checkbox for restore_on_demand should always be accessible
Status: RESOLVED FIXED
[good first bug][mentor=zpao][lang=js]
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: All All
: -- enhancement with 1 vote (vote)
: Firefox 15
Assigned To: Andrew Hurle [:ahurle]
:
Mentors:
: 727106 732260 (view as bug list)
Depends on: 792210 851775 911427
Blocks: 648683
  Show dependency treegraph
 
Reported: 2012-01-21 12:11 PST by Siddhartha Dugar [:sdrocking]
Modified: 2013-09-20 15:17 PDT (History)
16 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 - Move checkbox to Tabs page (14.40 KB, patch)
2012-05-15 16:49 PDT, Andrew Hurle [:ahurle]
no flags Details | Diff | Splinter Review
v2 - restoreOnDemand.* renamed to restoreTabsOnDemand.* (14.43 KB, patch)
2012-05-16 10:27 PDT, Andrew Hurle [:ahurle]
paul: review+
Details | Diff | Splinter Review
screenshot (93.73 KB, image/png)
2012-05-16 13:15 PDT, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
jboriss: ui‑review+
Details

Description Siddhartha Dugar [:sdrocking] 2012-01-21 12:11:10 PST
Bug 648683 allows users to enable restore_on_demand when they choose "Show my windows and tabs from last time" for Firefox startup. This should always be accessible irrespective of the users selection in the other menu. A user may need to restart Firefox for an update or an addon installation and may not want to restore all tabs.
Comment 1 Ioana (away) 2012-01-30 05:42:11 PST
Dugar, this issue seems to be an enhancement request rather than a bug. Please mark it correspondingly.
Comment 2 Ioana (away) 2012-01-30 06:30:32 PST
Sorry, the version got changed accidentally.
Comment 3 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-01-30 10:49:45 PST
Yea, that's probably a good idea. It sort of made sense when I first did it but now I'm less sure. Let's see what UX says - Limi, can you comment?
Comment 4 Siddhartha Dugar [:sdrocking] 2012-01-30 19:36:55 PST
Changing importance to "enhancement" as requested.
Comment 5 Alex Limi (:limi) — Firefox UX Team 2012-02-03 13:48:28 PST
(In reply to Paul O'Shannessy [:zpao] from comment #3)
> Yea, that's probably a good idea. It sort of made sense when I first did it
> but now I'm less sure. Let's see what UX says - Limi, can you comment?

Sounds good, and it should probably be relocated to the Tabs page in that case. 

(I wonder if people will expect us to not load tabs opened in the background if we do that, but it seems like something that wouldn't make a lot of sense, maybe I'm overthinking it :)
Comment 6 MrX1980 2012-02-14 09:26:56 PST
*** Bug 727106 has been marked as a duplicate of this bug. ***
Comment 7 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-03-01 16:24:07 PST
*** Bug 732260 has been marked as a duplicate of this bug. ***
Comment 8 Danial Horton 2012-03-03 22:17:47 PST
was about to create this exact artifact.

This setting as it is, us slightly ineffective for several reasons.

1. A user might not choose to have firefox configured to load the last session when starting a new session, but will use an extension or the add=on manager to restart the browser either for a fresh start or extension updates, which will generally reload with the same tabs as prior to the restart.

In this case, the user may expect all tabs to reload.

2. Session managers:  a user would probably expect all tabs to reload in the case of loading a saved session, not all of them have a setting in their options to disable reload on demand (Session Manager does)
Comment 9 Matthew N. [:MattN] 2012-05-15 13:50:04 PDT
We'll move the checkbox to the tabs page then.  Note that the same change needs to be made in two places since we are porting to in-content preferences:

browser/components/preferences and
browser/components/preferences/in-content (for when browser.preferences.inContent = true)
Comment 10 Andrew Hurle [:ahurle] 2012-05-15 16:49:23 PDT
Created attachment 624238 [details] [diff] [review]
v1 - Move checkbox to Tabs page
Comment 11 Dão Gottwald [:dao] 2012-05-15 21:54:49 PDT
Comment on attachment 624238 [details] [diff] [review]
v1 - Move checkbox to Tabs page

Please rename restoreOnDemand.* to restoreTabsOnDemand.*
Comment 12 Andrew Hurle [:ahurle] 2012-05-16 10:27:57 PDT
Created attachment 624438 [details] [diff] [review]
v2 - restoreOnDemand.* renamed to restoreTabsOnDemand.*
Comment 13 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-16 13:13:52 PDT
Comment on attachment 624438 [details] [diff] [review]
v2 - restoreOnDemand.* renamed to restoreTabsOnDemand.*

I know Limi said we should do this and on the surface it all looks good. But I'd like to get somebody from UX to chime in and see if we should reword the string now that it doesn't have the same context.
Comment 14 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-16 13:15:10 PDT
Created attachment 624505 [details]
screenshot

Poking Boriss for ui-review since she ui-r'ed the original string.
Comment 15 Ryan VanderMeulen [:RyanVM] 2012-05-26 06:38:57 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2a027b72537a
Comment 16 Ryan VanderMeulen [:RyanVM] 2012-05-26 15:26:55 PDT
https://hg.mozilla.org/mozilla-central/rev/2a027b72537a
Comment 17 Mardeg 2013-09-20 15:17:49 PDT
(In reply to Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) from comment #13)
> I'd like to get somebody from UX to chime in and see if we should reword the
> string now that it doesn't have the same context.
Because bug 792210 has yet to be fixed, users expect this option in its new "Tabs" location to prevent loading of background tabs opened via 'Open All in Tabs' bookmarks subfolder context menu (bug 851775) and when just middle-clicking/Apple-clicking many links to open them in background tabs (bug 911427).

Note You need to log in before you can comment on or make changes to this bug.