Closed Bug 720886 Opened 10 years ago Closed 8 years ago

Request for BetterPrivacy for SeaMonkey Redirects to Incompatible Version for Firefox

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: david, Unassigned)

Details

Request <https://addons.mozilla.org/en-US/seamonkey/addon/betterprivacy/>.  This is redirected to <https://addons.mozilla.org/en-US/firefox/addon/betterprivacy/>.  The latter presents BetterPrivacy 1.68, for which compatibility with any version of SeaMonkey has been blocked in its install.rdf file.  A request to AMO for a SeaMonkey extension for should never redirect to a Web page for an incompatible Firefox extension.   

In this particular situation, a request to <https://addons.mozilla.org/en-US/seamonkey/addon/betterprivacy/> should present BetterPrivacy 1.67, which is inherently compatible with SeaMonkey 2.3 and which can be made compatible with SeaMonkey 2.6.1 by tweaking its install.rdf file and might be compatible via AMO with SeaMonkey 2.6.1.
According to the forums at NetCat (the BetterPrivacy developer), all support for SeaMonkey has been eliminated.  See <http://nc.ddns.us/forum/viewtopic.php?id=548>.  

In this case, a request to <https://addons.mozilla.org/en-US/seamonkey/addon/betterprivacy/> should definitely not redirect to <https://addons.mozilla.org/en-US/firefox/addon/betterprivacy/>.  Fixing that one instance, however, does not address a more general problem of redirection.
This problem might be a consequence of any of bugs #666303, #671085, or #728641.
We no longer support SeaMonkey, hence the redirect. The version problem is bug 705578.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
addons.mozilla.org does indeed still support SeaMonkey.  The problem reported here is NOT that Better Privacy does not work with SeaMonkey.  

The problem is that a visitor to addons.mozilla.org in search of Better Privacy for SeaMonkey -- to <https://addons.mozilla.org/en-US/seamonkey/addon/betterprivacy/> -- should either find an old version that can be tweaked to work with the current version of SeaMonkey or else not find the extension at all.  Such a visitor should not be redirected to a Firefox extension at <https://addons.mozilla.org/en-US/firefox/addon/betterprivacy/> that cannot be used with SeaMonkey.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
As I mentioned in comment #4, bug 705578 is the main bug about compatible versions not being shown. However, I don't expect that to be fixed for SeaMonkey because we no longer support it actively (and I would know that).
(In reply to Jorge Villalobos [:jorgev] from comment #6)
> I don't expect that to be fixed for
> SeaMonkey because we no longer support it actively (and I would know that).  

"We" who?  Better Privacy or addons.mozilla.org?
addons.mozilla.org
closing in favor of bug 705578 and comment 4
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.