Panning problems with iframes

VERIFIED FIXED in Firefox 14

Status

()

Firefox for Android
General
P2
normal
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: Martijn Wargers (zombie), Assigned: kats)

Tracking

({testcase})

Trunk
Firefox 15
ARM
Android
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 verified, firefox15 verified, blocking-fennec1.0 +, fennec+)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 593040 [details]
testcase

Tested on the LG Optimus Black, Android 2.2.2 in portrait mode.

Steps to reproduce:
- Do a fling action upwards to scroll down in the iframe

Expected result:
- Content inside iframe scrolls downward in reasonable speed

Actual result:
- Content inside iframe scrolls down much slower than expected

Also, I noticed that swiping over the iframes doesn't really scroll the iframe content much, scrolling goes quite slow.
(Reporter)

Comment 1

7 years ago
I made a video of it here: http://www.youtube.com/watch?v=6P1p6z7BcKU

Updated

7 years ago
tracking-fennec: --- → +
Priority: -- → P2
Duplicate of this bug: 718144
(Reporter)

Updated

7 years ago
Blocks: 723945

Updated

7 years ago
Duplicate of this bug: 723945

Updated

6 years ago
Blocks: 725965
Issue can be seen on reader.google.com
Duplicate of this bug: 730252
Duplicate of this bug: 725965
blocking-fennec1.0: --- → ?
tracking-fennec: + → 15+
blocking-fennec1.0: ? → -
tracking-fennec: 15+ → +
Duplicate of this bug: 735760
Seeing the same issue with standard frameset on, for example, http://www.cougarfan.com/article.asp?ArtID=75914&URL=http://www.sltrib.com/sltrib/blogsbyusports/53873304-65/byu-martineau-rose-coach.html.csp

This page behaves almost exactly like http://di.se - (from bug 723945 - which was marked as a duplicate of this one)
While investigating some subdocument scrolling issues, I found a rather glaring bug that causes this issue. Will upload a patch shortly, it's an easy fix. Re-noming because I think this should block 1.0 - it happens on a range of websites and our subdocument scrolling behaviour really is quite atrocious.
Assignee: nobody → bugmail.mozilla
Blocks: 732364
No longer blocks: 723945, 725965
blocking-fennec1.0: - → ?
Created attachment 620314 [details] [diff] [review]
Save the pending displacement if we can't send it right away
Attachment #620314 - Flags: review?(chrislord.net)
Comment on attachment 620314 [details] [diff] [review]
Save the pending displacement if we can't send it right away

Review of attachment 620314 [details] [diff] [review]:
-----------------------------------------------------------------

heh, well caught :) Looks good to me.

::: mobile/android/base/ui/SubdocumentScrollHelper.java
@@ +60,5 @@
>  
>      private boolean mOverridePanning;
>      private boolean mOverrideScrollAck;
>      private boolean mOverrideScrollPending;
>      private boolean mScrollSucceeded;

I had a hard time reading this patch, I think it'd be good to add some documentation for these variables while you're changing code here.
Attachment #620314 - Flags: review?(chrislord.net) → review+
https://hg.mozilla.org/mozilla-central/rev/6483b38af5c0

Fixed, but leaving open so it doesn't fall off the fennec-1.0 triage list; I still want the blocking nom to be resolved.
status-firefox14: --- → affected
status-firefox15: --- → fixed
Target Milestone: --- → Firefox 15
(In reply to Kartikaya Gupta (:kats) from comment #12)
> Fixed, but leaving open so it doesn't fall off the fennec-1.0 triage list; I
> still want the blocking nom to be resolved.

Actually, I'll just request aurora on the patch, seems simpler.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Blocks: 746681
Blocks: 747277
Comment on attachment 620314 [details] [diff] [review]
Save the pending displacement if we can't send it right away

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: scrolling on pages with frames is barely possible
Testing completed (on m-c, etc.): locally, on m-c for a couple of days now and i haven't heard any complaints
Risk to taking this patch (and alternatives if risky): mobile-only, low risk
String changes made by this patch: none
Attachment #620314 - Flags: approval-mozilla-aurora?

Comment 15

6 years ago
Kats, I've noticed with the iframes is that even while scrolling down it is very easy to cause unintentional horizontal scrolling. This creates jerkiness. This is a problem when scrolling within the iframe and just scrolling the entire page.
(In reply to Demetrius Schwab from comment #15)
> Kats, I've noticed with the iframes is that even while scrolling down it is
> very easy to cause unintentional horizontal scrolling. This creates
> jerkiness. This is a problem when scrolling within the iframe and just
> scrolling the entire page.

Yes, the patches on bug 732364 should fix this behaviour by applying axis-locking to the scrolling in iframes. Do you still see the issue on the latest nightly?

Comment 17

6 years ago
No the issue appears to have been solved
Attachment #620314 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
blocking-fennec1.0: ? → +
This issue is not reproducible anymore on page with iframes.

Closing bug as verified fixed on:

Firefox 15.0a1 (2012-05-16)
Firefox 14.0b3

Device: Galaxy Nexus
OS: Android 4.0.2
Status: RESOLVED → VERIFIED
status-firefox14: fixed → verified
status-firefox15: fixed → verified
You need to log in before you can comment on or make changes to this bug.