Last Comment Bug 730211 - Drop Windows 2000 support in comm-central
: Drop Windows 2000 support in comm-central
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: OS Integration (show other bugs)
: Trunk
: All Windows Vista
: -- normal (vote)
: Thunderbird 13.0
Assigned To: Makoto Kato [:m_kato]
:
Mentors:
: 730218 730220 (view as bug list)
Depends on: 699247 730212
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-23 23:21 PST by Makoto Kato [:m_kato]
Modified: 2012-02-27 00:40 PST (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
fix (14.06 KB, patch)
2012-02-23 23:21 PST, Makoto Kato [:m_kato]
mozilla: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2012-02-23 23:21:57 PST
Created attachment 600319 [details] [diff] [review]
fix

Gecko drop Windows 2000 support...
Comment 1 Makoto Kato [:m_kato] 2012-02-24 04:03:41 PST
*** Bug 730220 has been marked as a duplicate of this bug. ***
Comment 2 Makoto Kato [:m_kato] 2012-02-24 04:05:03 PST
*** Bug 730218 has been marked as a duplicate of this bug. ***
Comment 3 David :Bienvenu 2012-02-24 09:15:55 PST
Comment on attachment 600319 [details] [diff] [review]
fix

Thx for the patch...
Is this patch removing support for the mail unread notifications that work in XP? We're still supporting XP, AFAICT, just not Win 2K. I'm referring specifically to the SHSetUnreadMailCounts removal.
Comment 4 David :Bienvenu 2012-02-24 13:26:21 PST
the patch builds and runs fine; I'd just like to make sure about the xp/win2k issue.
Comment 5 Serge Gautherie (:sgautherie) 2012-02-24 23:25:41 PST
Comment on attachment 600319 [details] [diff] [review]
fix

Review of attachment 600319 [details] [diff] [review]:
-----------------------------------------------------------------

::: mailnews/base/src/nsMessengerWinIntegration.cpp
@@ +357,5 @@
>  nsMessengerWinIntegration::Init()
>  {
>    nsresult rv;
>  
> +  // load shell dll. If no such dll found, return

Update the comment too or leave the return in.

::: mailnews/base/src/nsMessengerWinIntegration.h
@@ +63,5 @@
>      QUNS_ACCEPTS_NOTIFICATIONS = 5,
>      QUNS_QUIET_TIME = 6
>  } MOZ_QUERY_USER_NOTIFICATION_STATE;
>  
>  // this function is exported by shell32.dll version 5.60 or later (Windows XP or greater)

Nit: Update this comment too.
Comment 6 Serge Gautherie (:sgautherie) 2012-02-24 23:30:38 PST
(In reply to David :Bienvenu from comment #3)
> Is this patch removing support for the mail unread notifications that work
> in XP? We're still supporting XP, AFAICT, just not Win 2K. I'm referring
> specifically to the SHSetUnreadMailCounts removal.

They are not removed: they are just used unconditionally now, aren't they?
Comment 7 David :Bienvenu 2012-02-25 06:54:14 PST
(In reply to Serge Gautherie (:sgautherie) from comment #6)
> 
> They are not removed: they are just used unconditionally now, aren't they?

ah, thx, Serge, I think you're right.
Comment 8 David :Bienvenu 2012-02-25 09:07:58 PST
Comment on attachment 600319 [details] [diff] [review]
fix

thx for the patch!
Comment 9 Makoto Kato [:m_kato] 2012-02-26 23:43:11 PST
http://hg.mozilla.org/comm-central/rev/96a18db9f160

Note You need to log in before you can comment on or make changes to this bug.