Closed Bug 731653 Opened 10 years ago Closed 10 years ago

Bugs for some signatures are not showing up in Socorro

Categories

(Socorro :: General, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: marcia, Assigned: lonnen)

References

Details

I mentioned this to KaiRo today, and filing today because I am seeing this more regularly. I notice when looking at https://crash-stats.mozilla.com/topcrasher/byversion/Firefox/11.0b4/7 that several of the signatures in the list are not associated with a bug despite the fact they are already filed. Examples:

Bug 727624
Bug 729507

There are a few more, but I would have to hunt them down.
Bug 720390 is another one I just encountered.
Summary: Some signatures are not showing up in Socorro → Bugs for some signatures are not showing up in Socorro
I think Lonnen knows the signature<->bug connection code best, CCing him.
https://crash-stats.mozilla.com/report/list?signature=_chkstk%20|%20nsCacheService%3A%3AUnlock%28%29 fails to be connected to bug 725945 now, and https://crash-stats.mozilla.com/report/list?signature=CrashInJS%20|%20JS_AbortIfWrongThread fails to be connected to bug 715757.

Those signatures are pretty new, as they did only appear due to yesterday's skiplist additions.
OS: Mac OS X → All
Hardware: x86 → All
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 731828
unduping. This is more likely a problem with the cron.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Sorry, I should have read more closely!
Assignee: nobody → chris.lonnen
Target Milestone: --- → 2.5.1
If you can't fix it before 2.5.1, you should run the cron manually each day, because there's a risk to have several bugs for one crash signature. Indeed, the matching bug doesn't appear in crash queries AND in crash reports.
The cron that handles these associations is run hourly. It appears that it hasn't been able to complete a run for a few days.

On 02-29-2012 at 17:11 we stopped getting results from the buglist.cgi? query that powers the bug association cron. There is no explicit error logged, but from what is in the logs it looks like an error is being silently caught, because the code cleanup `finally` block executes right after the query is supposed to execute.

This repeats every hours until 03-01 at 00:11, when instead of the anticipated csv, the query returns an HTML page. The same page can be loaded by manually checking: 

https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced;bugidtype=include;chfieldfrom=2012-03-01;chfieldto=Now;chfield=[Bug%20creation];chfield=resolution;chfield=bug_status;chfield=short_desc;chfield=cf_crash_signature;order=Importance;columnlist=bug_id%2Cbug_status%2Cresolution%2Cshort_desc%2Ccf_crash_signature;ctype=csv;list_id=2512000

This causes a more explicit error. I'm not sure why the behavior changed, but will dig more in the morning.
(In reply to Chris Lonnen :lonnen from comment #8)
> On 02-29-2012 at 17:11 we stopped getting results

Was that when we pushed the 2.4.4 release or is that a coincidence?

> This repeats every hours until 03-01 at 00:11, when instead of the
> anticipated csv, the query returns an HTML page. The same page can be loaded
> by manually checking: 
> 
> https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced;
> bugidtype=include;chfieldfrom=2012-03-01;chfieldto=Now;
> chfield=[Bug%20creation];chfield=resolution;chfield=bug_status;
> chfield=short_desc;chfield=cf_crash_signature;order=Importance;
> columnlist=bug_id%2Cbug_status%2Cresolution%2Cshort_desc%2Ccf_crash_signature
> ;ctype=csv;list_id=2512000

This complains about missing search parameters, but I thought that changed fields were search parameters, did we always send this query?
Glob, did Bugzilla change in the recent few days to suddenly return an error here?
i'd say bug 731664 would be the most likely culprit here.
weird thing is when i point the same query to my dev system, it works :|

i've investigate further.
Depends on: 732409
i've been able to replicate this issue, i've raised bug 732409, and should attach a fix there soon.  sorry about this :(
(In reply to Marcia Knous [:marcia] from comment #0)
> Bug 727624

Works now.

> Bug 729507

Works now.

(In reply to Marcia Knous [:marcia] from comment #1)
> Bug 720390 is another one I just encountered.

That one has [] in its name, this is a separate (and difficult) case handled by bug 703102.

(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #3)
> https://crash-stats.mozilla.com/report/
> list?signature=_chkstk%20|%20nsCacheService%3A%3AUnlock%28%29 fails to be
> connected to bug 725945 now, and
> https://crash-stats.mozilla.com/report/
> list?signature=CrashInJS%20|%20JS_AbortIfWrongThread fails to be connected
> to bug 715757.

Those work now.


Due to that assessment, I'm closing this bug as FIXED by bug 732409.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Target Milestone: 2.5.1 → ---
It looks like the Bugzilla cron began completing successfully again last night. Putting back in the milestone for QA to verify.
Target Milestone: --- → 2.5.1
The cron continues to appear to be working correctly. Closing this out as qa verified. Please let us know if this issue crops up again.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.