Bug 714489 (msgreader-jumble)

[Meta] Wrong message/mail/attachment is shown in message preview/pane/tab/window. Message reader wrongly showing data/header/body/attachments of another msg, or partial/corrupted mail data; message pane/attachment pane is not refreshed/updated correctly

NEW
Unassigned

Status

defect
8 years ago
2 days ago

People

(Reporter: World, Unassigned)

Tracking

(Depends on 25 bugs, {meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [datalossy], )

This is meta bug(tracking bug), never for specific problem.

There are many bugs for "Wrong message/mail is displayed", but problem is clear in only a few of them, and some of them seems for same problem, and it looks that they can be categorized like next;
  different mail's data is used,
  a part of the mail data is used,
  corrupted mail data is used,
  message pane is not refreshed,
  other
This bug is for duping some such bugs to bug for clear case.
No longer depends on: 509000
In almost all bug reports at B.M.O from general users for problem of "wrong message was shown", information about following is usually never provided by bug opener nor additional problem reporters in a bug.
(i) Which mail should be shown
    - offset of the correct mail if local mail folder(POP3, Local Folders)
    - UID of the correct mail if IMAP folder
(ii) Detail of the Wrongness which bug opener says "wrong".
    If other valid mail.
    - offset of the wrongly shown mail if local mail folder(POP3, Local Folders)
    - UID of the correct mail if IMAP folder
    If corrupted mail data is used.
    - What kind of corruption, pattern of corruption
(iii) Detail of the Wrongness which bug opener says "wrong".
    If other valid mail.
    - offset of the wrongly shown mail if local mail folder(POP3, Local Folders)
    - UID of the correct mail if IMAP folder
(iv) Mail data, meta data of mail
    - Expected mail's data
    - Mal data used in display which is different from expectation
(v) Mail data
    - Expected mail's data
    - Mail data used in display which is different from expectation
(vi) Meta data of mails
    - .msf file just after problem occurred
    - .msf file just before problem occurred, if problem is persistent
(vii) Mail folder file content
    - Fmile for local mail folder if POP3 or Local Folders
    - Offline-store file if IMAP and offline-use=on folder
So, developers can't analyze this kind of bug reports, unless developers fortunately see problem in his daily use or in his test for development or bug fixing.
Depends on: 533499
Depends on: 587528
Depends on: 472000
Depends on: 717238
Depends on: 671802
Whiteboard: [datalossy]
Depends on: 764662
Wada, thanks for the great work that you are doing here and elsewhere.

Is it OK for you if we extend the summary of this bug to include display of wrong attachments with the body of another message?

[Meta] Wrong message/mail or attachments are shown at message pane/tab/window. Wrong: different mail's data is used, a part of the mail is used, corrupted mail data is used, message or attachment pane is not refreshed,...

So we could just add the word "attachments" to the summary and then include bugs like

bug 533499, bug 538803, bug 612279, bug 649580, bug 755176, bug 709337,
bug 612279, bug 719751

I think those bugs might fit in here well, but I'd like to confirm with you.

Alternatively, if you think "wrong attachments of another message shown" is likely a different problem from the issues currently covered in this meta bug, we could open a new Meta bug for the "wrong attachments" problem.
more "wrong attachments": bug 817557
(In reply to Thomas D. from comment #2)
> Is it OK for you if we extend the summary of this bug to include display of
> wrong attachments with the body of another message?

Because header pane, message pane, attachment pane is shown independently, asynchronously, mismatch among them can occur.
I slighyly changed bug summary to include such cases. Please change to appropriate one.
Summary: [Meta] Wrong message/mail is shown at message pane/tab/window. Wrong: different mail's data is used, a part of the mail is used, corrupted mail data is used, message pane is not refreshed, ... → [Meta] Wrong message/mail/attachment is shown at message pane/tab/window. Wrong: different mail's data is used, a part of the mail is used, corrupted mail data is used, message pane/attachment pane is not refreshed/updated correctly
(In reply to WADA from comment #4)
> (In reply to Thomas D. from comment #2)
> > Is it OK for you if we extend the summary of this bug to include display of
> > wrong attachments with the body of another message?
> 
> Because header pane, message pane, attachment pane is shown independently,
> asynchronously, mismatch among them can occur.
> I slighyly changed bug summary to include such cases.

Thanks Wada, very helpful as usual. So cases of showing the wrong attachments from another message etc. are now included.

> Please change to appropriate one.

I tried ;) I'm starting to sympathize with WADA-style summaries because they are more precise and cover a lot of keywords for efficient search :)

I also added a bug alias which will make it easier to add this bug to the "blocks:" field of dependent bugs, and to spot it there.
I think the new alias (msgreader-jumble) says it all... ;)
Alias: msgreader-jumble
Summary: [Meta] Wrong message/mail/attachment is shown at message pane/tab/window. Wrong: different mail's data is used, a part of the mail is used, corrupted mail data is used, message pane/attachment pane is not refreshed/updated correctly → [Meta] Wrong message/mail/attachment is shown in message preview/pane/tab/window. Message reader wrongly showing data/header/body/attachments of another msg, or partial/corrupted mail data; message pane/attachment pane is not refreshed/updated correctly
Per comment 2, confirmed in comment 4, adding "wrong-attachment" bugs.
Depends on: 751451
Depends on: 818525
Depends on: 820088
Depends on: 823838
Depends on: 823895
My observation is this happens after executing Compact Folder option.
Depends on: 830784
Depends on: 807045
Depends on: 826426
Depends on: 650267
Severity: normal → major
Depends on: 826189, 857062, 810721, 812763
(In reply to Sunil from comment #7)
> My observation is this happens after executing Compact Folder option.

From bug 826189 from comment #1:
> Sunil, does right+click folder, repair  help?
Wayne Mery, Since update has taken place to 17.0.5, This corruption is not observed. Any way thnx for attending... b/r - Sunil

I wonder if other users' problems are gone?

On the other hand, I don't see fixes in version 17 release notes:
https://bugzilla.mozilla.org/buglist.cgi?quicksearch=ALL tracking_thunderbird_esr17%3A"20%2B"  status_thunderbird_esr17%3Afixed&list_id=6868827
https://bugzilla.mozilla.org/buglist.cgi?quicksearch=ALL tracking_thunderbird_esr17%3A"19%2B"  status_thunderbird_esr17%3Afixed&list_id=6868827
https://bugzilla.mozilla.org/buglist.cgi?quicksearch=ALL tracking_thunderbird_esr17%3A"17%2B"  status_thunderbird_esr17%3Afixed&list_id=6868827
etc
Depends on: 597348
I too have seen this problem (twice now) where the subject does not match the body and when reviewing the body (if it exists as sometimes it is blank!) it contains text from other messages.

I am currently running 17.0.7 (under Windows 7) and just had this problem again.

I can appreciate the difficulty of tracking down this problem. However I am not sure what information to provide. I use POP3 to download the mail from two mail servers. 

In this latest case I have two messages that are "corrupted" in my Inbox. BTW it has only happened in the Inbox and surprisingly it clears itself. ie new messages will arrive OK.

What was interesting this time is that the first message that is now showing corrupted was originally OK. And I had received a number of messages after that OK but had moved them out of the Inbox (either to another folder or deleted).

It is possible that this occurred just after a compact folder request (but I cannot be certain).
So what information can I provide that will help aid in the diagnosis?
Depends on: 409322
Depends on: 346434
Bug 31052 (currently 20 duplicates) adds another interesting variant of messing up the message reader display with stuff from the wrong parts (albeit from the same message): When attachments are displayed inline, all sorts of formatting leaks back and forth between the main part and the inline preview of attached HTML parts, which can cause visual havoc depending on the formatting used, from wrong invisible text on wrong background colors to text displayed in wrong direction. I know it's technically different from most other cases collected here, but I think it's worthwhile to complete the picture.
Depends on: 31052
Depends on: 576235
I have the same kind of issue with Thunderbird 24.3 on Linux/Debian with OpenBox window manager.

Folder view displayed OK but when I click on a message to show it in the message pane, several things can happen :
- no message data displayed at all
- previously displayed message data are not overwritten by the one I've selected
- scrolling the message pane up/down sometimes help to actually display the message I want
- clicking on a message in the folder view when 1 is already slected leads to have both messages selected (although I didn't hit CTRL when clicking)

While testing, I noticed that "Loading message..." is displayed at the bottom of the screen. Then if I wait long enough the message get displayed. So it may be a problem with my ISP that is super slow to answer (say 20 seconds at least to get the mail)... It's a POP server... The folder view with message headlines works correctly though.

Don't know if this helps but since I was first looking for this kind of bug and then, after, figured out the possible POP issue, then I told myself it could help other to better locate the bug.



stF
(In reply to Stefan Champailler from comment #11)
> Don't know if this helps but since I was first looking for this kind of bug
> and then, after, figured out the possible POP issue, then I told myself it
> could help other to better locate the bug.

Thank you, Stefan, we appreciate such information.
Unfortunately, due to the voluntary nature of TB development, it's not easy to get such bugs fixed.
Depends on: 1000589
Depends on: 770888
Depends on: 574664
Depends on: 819034
For partial or corrupted mail data in offline-store file of IMAP.

This kind of problems is perhaps caused by change for bug 92111.
By change for bug 92111, mail data saved in offline-store file is not marked as INVALID when saved mail data size != RFC822.SIZE. So, when RFC822.SIZE returned from IMAP server is correct, "timinig whole" which produces condition of  "saved data is marked VALID even though entire mail data is not successfully fetched yet". This "timing hole" seems not-so-smaller than we expect, although frequency of this kind of problem seems declined in recent releases of Tb. 

I believe "change for bug 92111" should be optional and be "per server option". 
"Change for bug 92111" should have been applied to "IMAP server who lies on RFC822.SIZE such as MS Exchange" only.
Depends on: 831932
Depends on: 741696
Depends on: 781146, 520115
See Also: → 543708
I find this problem very often, so it may help tracking down better.
I my case it happens very frequently when moving one mail from one IMAP folder to another IMAP folder but on a different server (a different provider).
It happens even more often if the moved mail is large and with attachments.

Normally on the destination folder, the new entry appears soon, but when show in the preview pane, I see normally the content of another previous mail of the same folder.

In my understanding when moving between IMAP fonders on different servers, the content must be downloaded from one server and uploaded to the other. This takes time, but the new mail entry apperars probably before the end on this process leading to some missed information.

Finally I can confirm that "repairing" the destination folder fixes the problem, until the next move.

Regrads, and good job.
Depends on: 563278
Depends on: 386888
Depends on: 1426950
Depends on: 1428277
Depends on: 1416685
Depends on: 1430480
Depends on: 1483940
Depends on: 1518047
Depends on: 777718, 1175121, 1530449, 1524834
See Also: → 1534153
Severity: major → normal
You need to log in before you can comment on or make changes to this bug.