Last Comment Bug 746215 - Invert tcheckerboard (and tcheckerboard2) output and make it cumulative instead of average
: Invert tcheckerboard (and tcheckerboard2) output and make it cumulative inste...
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: -- normal (vote)
: Firefox 15
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
: 748174 748817 (view as bug list)
Depends on:
Blocks: 748736
  Show dependency treegraph
 
Reported: 2012-04-17 10:24 PDT by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2012-04-27 07:04 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
-


Attachments
Patch (1.27 KB, patch)
2012-04-20 09:47 PDT, Kartikaya Gupta (email:kats@mozilla.com)
jmaher: review+
Details | Diff | Splinter Review
Patch (v2) (1.26 KB, patch)
2012-04-25 10:47 PDT, Kartikaya Gupta (email:kats@mozilla.com)
jmaher: review+
Details | Diff | Splinter Review

Description Kartikaya Gupta (email:kats@mozilla.com) 2012-04-17 10:24:08 PDT
Right now the output means 1.0 is no checkerboarding and 0.0 is all checkerboarding. We should flip this so that when viewing the graphs on the graph server the y-axis scale will get more detailed as we drive down checkerboarding and we can better see smaller regressions.

Also it just seems more reasonable for a test called "checkerboarding" to measure checkerboarding as opposed to not-checkerboarding.
Comment 1 Joel Maher ( :jmaher) 2012-04-17 10:39:42 PDT
good call.  We should be able to change the test cases themselves and ignore the rest of the automation and buildbot scripts for this.
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-19 15:02:27 PDT
We might also want to change the scale from [0,1] to [0,100] instead. Right now when I click on a data point on the graph server it always reports the score as "0", which I assume is because it doesn't like fractional values. Scaling the values up would avoid this.
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-20 09:47:52 PDT
Created attachment 617007 [details] [diff] [review]
Patch
Comment 4 Joel Maher ( :jmaher) 2012-04-20 10:17:57 PDT
Comment on attachment 617007 [details] [diff] [review]
Patch

Review of attachment 617007 [details] [diff] [review]:
-----------------------------------------------------------------

this looks fine!  I assume this will work for both tcheckerboard tests?
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-20 12:06:13 PDT
Yeah I pushed it to try at https://tbpl.mozilla.org/?tree=Try&rev=2050322f4a9a and it looked fine.
Comment 6 :Ehsan Akhgari 2012-04-23 18:50:28 PDT
*** Bug 748174 has been marked as a duplicate of this bug. ***
Comment 7 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-25 10:43:08 PDT
*** Bug 748817 has been marked as a duplicate of this bug. ***
Comment 8 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-25 10:47:41 PDT
Created attachment 618351 [details] [diff] [review]
Patch (v2)

New patch that also reports the sum instead of average. The "inversion" still applies, so that lower numbers are better.
Comment 9 Joel Maher ( :jmaher) 2012-04-25 11:05:01 PDT
Comment on attachment 618351 [details] [diff] [review]
Patch (v2)

Review of attachment 618351 [details] [diff] [review]:
-----------------------------------------------------------------

looks good, thanks for pushing these patches through.
Comment 10 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-26 11:27:38 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/c978a9f2d1d8
Comment 11 Ed Morley [:emorley] 2012-04-27 07:04:58 PDT
https://hg.mozilla.org/mozilla-central/rev/c978a9f2d1d8

Note You need to log in before you can comment on or make changes to this bug.