HTMLMeterElement should not be form controls

RESOLVED FIXED in mozilla16

Status

()

Core
DOM: Core & HTML
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mounir, Assigned: mounir)

Tracking

(Blocks: 1 bug, {dev-doc-needed})

Trunk
mozilla16
dev-doc-needed
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
See http://www.w3.org/Bugs/Public/show_bug.cgi?id=12254
(Assignee)

Updated

5 years ago
Blocks: 555985
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 686913
(Assignee)

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 2

5 years ago
Kyle, bug 686913 is about to be fixed and will take into account progress elements only so this is the meter part of it.
Status: REOPENED → NEW
(Assignee)

Updated

5 years ago
Keywords: dev-doc-needed
(Assignee)

Updated

5 years ago
Blocks: 657941
(Assignee)

Comment 3

5 years ago
Created attachment 630559 [details] [diff] [review]
Patch
Assignee: nobody → mounir
Status: NEW → ASSIGNED
Attachment #630559 - Flags: review?(bzbarsky)
(Assignee)

Updated

5 years ago
Blocks: 762044
Comment on attachment 630559 [details] [diff] [review]
Patch

Doesn't this make the meter non-labelable?  Is that desired?
(Assignee)

Comment 5

5 years ago
Oh... The specs tricked me. Before (and that's how our code behave) only form controls were able to be labeled but since <progress> and <meter> are not form controls, Hixie changed the specs to allow any element to be labeled... I was assuming that given those elements were no longer form controls they were not labelable.

Patches will come.
(Assignee)

Updated

5 years ago
Attachment #630559 - Flags: review?(bzbarsky)
(Assignee)

Updated

5 years ago
Depends on: 762434
(Assignee)

Updated

5 years ago
Depends on: 762435
(Assignee)

Comment 6

5 years ago
Created attachment 630921 [details] [diff] [review]
Patch v2

That should fix it, using bug 762434.

BTW, I could have IsLabelable() defined in each element that is labelable with simply |return true;|. I just kept the nsIFormControl logic here so I did the same kind of thing for meter and progress. If you think having IsLabelable defined for each element would be better, I can do that.
Attachment #630559 - Attachment is obsolete: true
Attachment #630921 - Flags: review?(bzbarsky)
Comment on attachment 630921 [details] [diff] [review]
Patch v2

r=me
Attachment #630921 - Flags: review?(bzbarsky) → review+
(Assignee)

Updated

5 years ago
Flags: in-testsuite+
Target Milestone: --- → mozilla16
(Assignee)

Updated

5 years ago
Attachment #630921 - Flags: checkin+

Comment 8

5 years ago
https://hg.mozilla.org/mozilla-central/rev/525a0b959ef0
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.