The default bug view has changed. See this FAQ.

Make progress labelable again

RESOLVED FIXED in Firefox 15

Status

()

Core
DOM: Core & HTML
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mounir, Assigned: mounir)

Tracking

({regression})

Trunk
mozilla16
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox13 unaffected, firefox14 affected, firefox15+ verified, firefox16 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 630920 [details] [diff] [review]
Patch

That was broken in bug 686913.

Tests will come with bug 762047.
Attachment #630920 - Flags: review?(bzbarsky)
(Assignee)

Updated

5 years ago
Blocks: 748238
Depends on: 762434
(Assignee)

Updated

5 years ago
Blocks: 762047
Comment on attachment 630920 [details] [diff] [review]
Patch

r=me
Attachment #630920 - Flags: review?(bzbarsky) → review+
(Assignee)

Updated

5 years ago
status-firefox14: --- → affected
status-firefox15: --- → affected
status-firefox16: --- → affected
Keywords: regression
(Assignee)

Updated

5 years ago
status-firefox13: --- → unaffected
(Assignee)

Updated

5 years ago
Flags: in-testsuite+
Target Milestone: --- → mozilla16
(Assignee)

Updated

5 years ago
Attachment #630920 - Flags: checkin+
https://hg.mozilla.org/mozilla-central/rev/0f7995b75365
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
status-firefox16: affected → fixed
tracking-firefox15: --- → ?
(Assignee)

Comment 3

5 years ago
Comment on attachment 630920 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 686913
User impact if declined: <label><progress></progress></label> will not work
Risk to taking this patch (and alternatives if risky): low, labelling might not work as expected.
String or UUID changes made by this patch: none with that one, but some with bug 762434 like Element UUID update.
Attachment #630920 - Flags: approval-mozilla-aurora?

Comment 4

5 years ago
(In reply to Mounir Lamouri (:volkmar) (:mounir) from comment #3)
> String or UUID changes made by this patch: none with that one, but some with
> bug 762434 like Element UUID update.

Is this fix dependent on bug 762434? Will it be nominated for Aurora approval as well?
(Assignee)

Comment 5

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #4)
> (In reply to Mounir Lamouri (:volkmar) (:mounir) from comment #3)
> > String or UUID changes made by this patch: none with that one, but some with
> > bug 762434 like Element UUID update.
> 
> Is this fix dependent on bug 762434? Will it be nominated for Aurora
> approval as well?

Indeed. I forgot about that. It is now done.
Comment on attachment 630920 [details] [diff] [review]
Patch

[Triage Comment]
Approved along with bug 762434, we should have sufficient bake time on this to catch regressions.
Attachment #630920 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
tracking-firefox15: ? → +
(Assignee)

Comment 7

5 years ago
Pushed in Aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/bde27ed49c7c
status-firefox15: affected → fixed
Target Milestone: mozilla16 → mozilla15

Comment 8

5 years ago
Target Milestone is for m-c.
Target Milestone: mozilla15 → mozilla16

Comment 9

5 years ago
Verified as fixed on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0

Progress is labelable again.
status-firefox15: fixed → verified
You need to log in before you can comment on or make changes to this bug.