Open Thunderbird in favourite view offers no access to read messages

RESOLVED DUPLICATE of bug 746095

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 746095
6 years ago
4 years ago

People

(Reporter: Anje, Unassigned)

Tracking

11 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Using Vista OS and TB v. 12.0.1 

Opened Thunderbird and selected to view 'Favorite' folder.
View > Folders > Favorite

Closed Thunderbird.
Opened Thunderbird to see favorite folder.


Actual results:

Thunderbird opens.
The tab shows a folder icon; nothing else
The Folder Pane is empty.
I can see:
Email header
options to 'Read Messages', Write a new message', 'Junk Mail Settings' and more.
I click on 'Read Messages'
Nothing happens.

So I change the View > Folders to 'All'
I can now see all folders in Folder Pane.
The tab still only shows a folder icon.
I click on 'Read Messages' and nothing happens.
I select Inbox and I can view everything ok.




Expected results:

I expected Thunderbird to open on my Favorite folder.
Failing this, when I selected to 'Read Messages', I expected Thunderbird to display the favourite folder contents.
Failing this, when I selected to 'View > folders > All', and then clicked on 'Read Messages', I expected to see the contents in the Inbox view.

I would like to file this as a bug.

Comment 1

6 years ago
(In reply to Anje from comment #0)
See bug 742379.
I don't think folder pane should ever be empty. Folder pane is the pane on the left. Anje, can you attach some screenshots to illustrate your problems?

Comment 3

6 years ago
It can be empty when he does View > Folders > Favorite (if no folders are marked as favourite).
(Reporter)

Comment 4

6 years ago
(In reply to :aceman from comment #3)
> It can be empty when he does View > Folders > Favorite (if no folders are
> marked as favourite).

I did not mark any folder as favourite. 
As you do not need to mark any folder for any of the other options in the View > Folders list, it was not expected that I should perform something different. I assumed that Thunderbird would automatically calculate that the Favourite folder would be the most used, just as Thunderbird auto works out which folders were 'recent'.

When I initially selected View > Folders > Favorite, the folder pane went blank, but all my Inbox emails were still displayed and I could freely choose to read any of them. So I assumed that the Inbox had been selected (correctly) as a favourite folder and there was a bug because it was not displayed in the Folder Pane. Then after opening and closing to discover the Read Messages did not work, I thought there was more to this 'bug'.
So from a user point of view, it is not intuitive and if someone does as I did, they could be confused as to why one item in the list requires a different process, why emails can still be accessed and read; they would aslo wonder why the 'Read Messages' did not work.
So I'm suggesting this:
View > Folders > Favourite > choose folder.
Under the current system ,I think that if no favouite folder is actually chosen then the Folder Pane should not go blank, instead an alert message needs to popup stating what to do and there is no change in the folder pane.

Comment 5

6 years ago
You must mark which folders are your Favourite by right-clicking on them and choosing "Favorite Folder". Then you can choose the Favorite View.

I think the rest of your commnent 4 is fixed by bug 713277 (in TB14) in the way that if you have nothing visible in the folder pane, the Account central page (what you describe as "Email header
options to 'Read Messages', Write a new message', 'Junk Mail Settings' and more.") will operate on you default account (the name will be shown in the header of the page).

To lessen then confusion of the user why there are some informational messages planned in bug 746095.

Comment 6

6 years ago
can this be closed?
Flags: needinfo?

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?
Resolution: --- → DUPLICATE
Duplicate of bug: 746095
You need to log in before you can comment on or make changes to this bug.