Allow "Segmented Downloading" for large files (mutiple download segments per file)

RESOLVED DUPLICATE of bug 40106

Status

enhancement
RESOLVED DUPLICATE of bug 40106
19 years ago
15 years ago

People

(Reporter: Peter, Assigned: law)

Tracking

({helpwanted})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

19 years ago
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.8.1) Gecko/20010323

Allow "Segmented Downloading" for large files (mutiple download segments per file)

This is part of the meta bug to track all *Download Manager* requests (bug 25995)
Reporter

Updated

19 years ago
Blocks: 25995
Reporter

Updated

19 years ago
Blocks: 75364
Reporter

Updated

19 years ago
No longer blocks: 25995
Question.  Do other tools currently provide this?  Especially any open-source ones?
Reporter

Comment 2

19 years ago
I only know that GetRight does it (not open source though).
a rfe cannot be mozilla1.0
Keywords: mozilla1.0

Comment 4

18 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Allow "Segmented Downloading" for large files (mutiple download segments per file) → [RFE] Allow "Segmented Downloading" for large files (mutiple download segments per file)

Comment 5

18 years ago
updating component, adding a couple of folks.
Assignee: asa → pchen
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh
spam: over to File Handling. i have not changed the assigned developer [or the
other fields for that matter], so if anyone realizes that a bug should have a
more appropriate owner, go ahead and change it. :)
Component: XP Apps → File Handling
->law
Assignee: pchen → law
Assignee

Comment 8

18 years ago
->future

We don't have time.
Target Milestone: --- → Future

Comment 9

18 years ago
Downloader for X: http://www.krasu.ru/soft/chuchelo/ implements this feature I
think. Not tested though.

Comment 10

18 years ago
I believe lftp http://lftp.yar.ru/ does this with its pget command.  It should
be a good open source reference you can use, if I understand correctly what this
bug is.

Comment 11

17 years ago
*** Bug 141760 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
I'm just being picky but does this RFE really have to to be in File Handling, it
would be easier to find and avoid dups if it was in Download Manager, I would
also suggest that people wouldn't want to use multiple connection/file part
downloading outside of download manager anyway. Any pointers as to where to
start hacking, if I felt so inclined?

Comment 13

17 years ago
-> Download manager (this bug is 'blocking' bug 75360 Download Manager Features)
Component: File Handling → Download Manager

Comment 14

17 years ago
Please note that Download Expert http://www.yanew.com (freeware, not open
source) does segmented downloads. Very cool feature: I always use it for
downloading Mozilla binaries since one download connection alone never saturates
my isdn / lan connections.

Comment 15

17 years ago
Auto Segmenting is a great feature, but there must be a way for the user to flag
certain sites that do not work with auto-segmenting.  The bigest one that comes
to mind is fileplanet.com.

Comment 16

17 years ago
Kevin, excellent point.  Perhaps that should be a enhancement request depending
on this bug?  My gut tells me the best way to implement it would be to pop up a
dialog to add the offending site to a "blacklist" when a resume fails. 
Obviously, the list would need to be "forgiving" somehow...

Comment 17

17 years ago
Some inspiration can perhaps be found from mget (haven't checked it out myself
though)

http://www.cse.iitk.ac.in/users/dbera/mget.php

Comment 18

17 years ago
More info:

Since internet standards limit simultaneous downloads from each server to a
certain number of connections, we could do like GetRight and support mirrored
files. That would be another RFE depending on this bug, though.

I personally don't find this feature very useful with either modem or LAN, since
on LAN it's so fast anyway and on 56K your bandwidth is killed by this sort of
thing. It would be tedious to manually ask the browser to split each download,
but having this behavior always-on guarantees a muddy connection as soon as you
start downloading anything.
Reporter

Comment 19

17 years ago
The limitation is often not YOUR bandwidth.
I tried downloading Getright from Mozilla (sounds funny?), and attempted to save
the installer file from 3 different mirrors onto the same location in my disk. I
think what happened is that the Download Manager was attempting to download the
three files separately, even though the Download list only showed one entry. The
Download status kept switching between what I think must have been the status of
the 3 different files.
Since segmented file download is not supported, I would expect Mozilla to prompt
me that a file was already being saved at that location in my hard-disk.
I guess I should point out that I'm using Build:2002052308

I'm just downloading the 1.0 installer (and after tha the 1.1 alpha installer),
and will check the behaviour on both. Should I be logging a new bug for this?

Comment 21

17 years ago
You should.

Comment 22

17 years ago
Another open-source segemented downloader is AXEL, from
http://www.lintux.cx/axel.html - It's GPL'd and it seperates the downloading
part and the frontend.
*** Bug 141472 has been marked as a duplicate of this bug. ***
QA Contact: sairuh → petersen

Updated

17 years ago
Summary: [RFE] Allow "Segmented Downloading" for large files (mutiple download segments per file) → Allow "Segmented Downloading" for large files (mutiple download segments per file)

Comment 24

15 years ago
Would adding the functionality from "Download Manager Tweak" extension help
solve this at all? What about adding in "Bit torrent" ability?

Comment 25

15 years ago
I was looking for the comments I got and made on this years ago and didn't see
them.  I then searched bugzilla and discovered that this is a dupe of bug 40106.
 I'm not going to mark it that way, because that is wontfix.  

Read through it to see why the mozilla.org staff was against it at the time.

*** This bug has been marked as a duplicate of 40106 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE

Comment 27

15 years ago
(In reply to comment #25)
> Read through it to see why the mozilla.org staff was against it at the time.

I didn't see anybody of mozilla.org staff comment there, and the reporter closed
the bug as WONTFIX.

Now with Boris' duping, it means all reports about this topic are marked FIXED,
i.e. noone will care of this anytime again. Probably bug 40106 should be
reopened - that is, if anyone writing code in that part of Mozilla thinks it's
worth to have this report around...
Reopening the other bug is fine, but there is no reason to have two identical
bugs on the same topic; it just hides relevant discussion.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.