Closed Bug 759445 Opened 8 years ago Closed 8 years ago

Please disable tablet updates prior to FN14b4 release

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(blocking-fennec1.0 betaN+)

RESOLVED DUPLICATE of bug 760740
Tracking Status
blocking-fennec1.0 --- betaN+

People

(Reporter: akeybl, Assigned: aki)

References

Details

(Whiteboard: [no code])

Attachments

(3 files)

We'd like to disable tablet updates prior to FN14b4 release. If this is very difficult to undo, we can discuss pushing out testing the blocking capability till after XF14's release on the beta product.

Aki - can you help us understand the experience for blocking a specific device? Are we required to search for each device individually or can we search for a full list?

We can crowdsource disabling tablets if it's a tedious process, I'd be happy to help.
Nominating for blocking-fennec1.0:betaN+. If we don't test this in the next beta, we'll have to wait until after 6/12 to test (which may run up against our release date).
Assignee: nobody → aki
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → betaN+
Whiteboard: [no code]
(In reply to Alex Keybl [:akeybl] from comment #0)
> Aki - can you help us understand the experience for blocking a specific
> device? Are we required to search for each device individually or can we
> search for a full list?

We're required to search for each device individually.

> We can crowdsource disabling tablets if it's a tedious process, I'd be happy
> to help.

Sure.
https://intranet.mozilla.org/AndroidMarket#How_to_Access
https://bugzilla.mozilla.org/show_bug.cgi?id=699627    # gpg pubkey goes here
(In reply to Aki Sasaki [:aki] from comment #2)
> (In reply to Alex Keybl [:akeybl] from comment #0)
> > Aki - can you help us understand the experience for blocking a specific
> > device? Are we required to search for each device individually or can we
> > search for a full list?
> 
> We're required to search for each device individually.

How literally do the search strings need to match? Can we search for 'a' and go through each device with 'a' in the name, disabling if it's a tablet?

> > We can crowdsource disabling tablets if it's a tedious process, I'd be happy
> > to help.
> 
> Sure.
> https://intranet.mozilla.org/AndroidMarket#How_to_Access
> https://bugzilla.mozilla.org/show_bug.cgi?id=699627    # gpg pubkey goes here

I just added my pubkey to the bug.
(In reply to Alex Keybl [:akeybl] from comment #3)
> (In reply to Aki Sasaki [:aki] from comment #2)
> > We're required to search for each device individually.
> 
> How literally do the search strings need to match? Can we search for 'a' and
> go through each device with 'a' in the name, disabling if it's a tablet?

If you list everything, it shows the first handful of devices for each manufacturer, then a "show more" link at the bottom.

Looks like you can search for 'a'.  So this is more tedious than going through a list and checking boxes, less tedious than having to search for each device specifically.
CCing Hal.
Waiting for 'go' here, plus a list of tablet device names.
(In reply to Aki Sasaki [:aki] from comment #5)
> CCing Hal.
> Waiting for 'go' here, plus a list of tablet device names.

Including Irina for a full list of Android tablets. A separate list of 7" tablets with ICS available would also be very helpful.
(In reply to Alex Keybl [:akeybl] from comment #6)
> (In reply to Aki Sasaki [:aki] from comment #5)
> > CCing Hal.
> > Waiting for 'go' here, plus a list of tablet device names.
> 
> Including Irina for a full list of Android tablets. A separate list of 7"
> tablets with ICS available would also be very helpful.

If we don't already have this list, we can just use https://en.wikipedia.org/wiki/Comparison_of_Android_devices#Tablet_computers and a search for "tablet" in the device lists.
Let's move forward with the tablets on https://en.wikipedia.org/wiki/Comparison_of_Android_devices#Tablet_computers.

When you exclude each, please copy/paste the tablet name from Google Play into a text document. For any tablet you can't find in the store, please keep a second list.

We'll do a final pass with Irina's list if she has one, and also look for any other obvious tablets that weren't on the wikipedia page.
Irina suggests we use http://bit.ly/N10fpz and http://bit.ly/KheN45 for a fairly comprehensive list of tablets.
When creating the requested text documents in Comment 8, please keep the list of tablets from http://bit.ly/N10fpz (7-9 inches) separate from http://bit.ly/KheN45 (9 and up). Thanks!
(In reply to Aki Sasaki [:aki] from comment #12)
> Let's make that https://etherpad.mozilla.org/T4jcXYs1JU for 7-9 inches,

These are done.  Attached.
Still need to do the 9+ inches.
That was ugly.  So many Android devices and they seem to have different names, plus the market UI sucks.

Also blocked

Others unknown(Tablet)
Pegatron Android Tablet PC(TabletPC)
Philips Electronics T8 PI7000(Tablet_8)

after searching for 'tab'.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Reopening since Google Play discarded my changes D:
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
We had to do this again, but it was faster with the lists (thanks Aki). Full list of excluded devices at https://etherpad.mozilla.org/ydh6XyxFKW. We should see what the install experience for tablets is now, check for any holes with the tablets we have, and then make sure they don't receive updates to FN14b4 tomorrow.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Keywords: qawanted
Resolution: --- → FIXED
That etherpad also has some additions made by going through the wikipedia android page.
Duplicate of this bug: 759737
The Galaxy Note should not be blocked. It currently can not find Firefox Beta.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Unblocked Galaxy Note.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Also unblocked ARCHOS 70it2(A70it2), ZTE Light Tab 2(v9plus)
Blocked Samsung GT-P7510
Unblocked Galaxy Tab(SCH-I800) per mbrubeck
Blocked the Toshiba AT100 per nhirata
Please block the following list of Galaxy Tabs (all under Samsung)

GT-I9210(GT-I9210)
GT-P1010(GT-P1010)
GT-P1013(GT-P1013)
GT-P6200(GT-P6200)
GT-P6200L(GT-P6200L)
GT-P6201(GT-P6201)
GT-P6210(GT-P6210)
GT-P6800(GT-P6800)
GT-P6810(GT-P6810)
GT-P7300B(GT-P7300B)
GT-P7320(GT-P7320)
GT-P7500D(GT-P7500D)
GT-P7500M(GT-P7500M)
GT-P7500R(GT-P7500R)
GT-P7501(GT-P7501)
GT-P7511(GT-P7511)
SC-01D(SC-01D)
SC-02D(SC-02D)
SCH-I815(SCH-I815)
SCH-P739(SCH-P739)
SGH-I957D(SGH-I957D)
SGH-I957M(SGH-I957M)
SGH-T859(SGH-T859)
SGH-T869(SGH-T869)
SHV-E140K(SHV-E140K)
SHV-E140L(SHV-E140L)
SHV-E140S(SHV-E140S)
SHW-M305W(SHW-M305W)

Once we're done, let's copy the full list of devices we've excluded from Google Play for the next time we have to disable them.
Done.
This is the list of current blocked devices.
It includes all blocked devices, including any that were blocked before this bug was filed.
Depends on: 760740
If we build with the patch from bug 760740, then in the future we can exclude tablets just by disabling the XUL Fennec APK.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 760740
This work is complete, removing qawanted.
Keywords: qawanted
I just noticed that one Galaxy Tab 7.0 Plus is blocked, but not another:
https://people.mozilla.com/~bhearsum/sattap/e524d098.png

Is that intentional?
(In reply to Ben Hearsum [:bhearsum] from comment #31)
> I just noticed that one Galaxy Tab 7.0 Plus is blocked, but not another:
> https://people.mozilla.com/~bhearsum/sattap/e524d098.png
> 
> Is that intentional?

We've unblocked all 7" tablets on the release channel now. This wasn't caught yesterday, but will be added to QA test plans in the future.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.