Unresponsive Script in nsHandlerService.js during compose

RESOLVED INCOMPLETE

Status

--
major
RESOLVED INCOMPLETE
7 years ago
3 years ago

People

(Reporter: Ulf.Zibis, Unassigned)

Tracking

({perf, testcase})

12 Branch
x86
Windows XP
perf, testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 629471 [details]
20120602-Erinnerung - _Everdingsche_ _Zauberflöte_ zauberhaft im Odeon-Kino-246602583.eml

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Replied to attached E-Mail.


Actual results:

After a little while of typing, the message box about busy script appeared repeatedly.
I tried "Continue" --> Composer window was blocked, so continuing typing was not possible.
I tried "Stop" --> Composer window was blocked as same.
I tried a new composer window by again hitting reply on original mail. --> same problem after short time.

I had to kill TB by Taskmanager.



Expected results:

1. Composer window should stay responsible.
2. Script should stop, if requested.
(Reporter)

Updated

7 years ago
Severity: normal → major

Comment 1

7 years ago
> After a little while of typing, the message box about busy script appeared repeatedly.

you mean unresponsive script?
I could not reproduce with your attached message

> Severity: normal → major
hang=criticall
Severity: major → critical
Keywords: hang
(Reporter)

Comment 2

7 years ago
Created attachment 629507 [details]
screen shot

(In reply to Wayne Mery (:wsmwk) from comment #1)
> you mean unresponsive script?
Yes!

> I could not reproduce with your attached message
:-(
But you can see, that the mail source is ugly formatted?
(Reporter)

Comment 3

7 years ago
After typing some lines I had to wait ~5 minutes for to reproduce the bug.

Additionally all my tabs have been lost after killing TB. Is that another bug?

Comment 4

7 years ago
(In reply to Ulf Zibis from comment #3)
> After typing some lines I had to wait ~5 minutes for to reproduce the bug.

can it be reproduced in safe mode ? 
see http://support.mozillamessaging.com/en-US/kb/safe-mode


> Additionally all my tabs have been lost after killing TB. Is that another
> bug?

yes. iirc there's allready a bug report for that.
Severity: critical → major
Keywords: hang
Summary: Received mail caused TB to hang → Received mail caused unresponsive script in nsHandlerService.js
(Reporter)

Comment 5

7 years ago
(In reply to Wayne Mery (:wsmwk) from comment #4)
> can it be reproduced in safe mode ?

Yes!

> > Additionally all my tabs have been lost after killing TB. Is that another
> > bug?
> yes. iirc there's allready a bug report for that.

You mean this: Bug 621908 ?

Comment 6

6 years ago
Ulf, does this reproduce with Thunderbird 17 in safe mode?
Does it require a large number of tabs?
Flags: needinfo?(Ulf.Zibis)
Keywords: perf
Summary: Received mail caused unresponsive script in nsHandlerService.js → Unresponsive script in nsHandlerService.js during compose
Whiteboard: [closeme 2013-02-01]

Comment 7

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #6)
> Ulf, does this reproduce with Thunderbird 17 in safe mode?
> Does it require a large number of tabs?

please also test windows started in safe mode
- XP http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx
And how many contacts are in your address books?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2013-02-01]
(Reporter)

Comment 8

6 years ago
I still have this error with TB 17.
- 4 Tabs are open, 3 from ThunderBrowse addon
- personal contacts ~1100
- collected contacts ~2800

Trying again with Windows safe mode.
Flags: needinfo?(Ulf.Zibis)
(Reporter)

Comment 9

6 years ago
This time it was "... js:398" in the script message.
(Reporter)

Comment 10

6 years ago
This time, the tabs have been saved after killing TB in normal mode, but became again lost after TB save mode.

Now with Windows save mode:
--> same problem, in TB normal mode + save mode :-(
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 11

6 years ago
rob, 
how big is your Drafts folder?
what is your mail check interval - 5 minutes, 3 minutes?
what antivirus software do you use?
Component: General → Message Compose Window
Flags: needinfo?(Ulf.Zibis)
(Reporter)

Comment 12

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #11)
> rob, --> no, Ulf ;-)
> how big is your Drafts folder? --> 53 emails in ~5 MBytes, POP
> what is your mail check interval? -->
1 POP 3 minutes (the account, I used)
2 IMAP 3 minutes (1 with 25 folders with "check for new mails")
3 IMAP 10 minutes
> what antivirus software do you use? --> Avast FREE
Flags: needinfo?(Ulf.Zibis)
(Reporter)

Comment 13

6 years ago
To be clear: This is the only email I ever had, where I observed this problem. There must be something very special with this email.
Also when I open the email from external .eml file, I see the problem 2..5 minutes after I invoke Reply.
My machine is quite old: AMD 2800+

Comment 14

5 years ago
Ulf, do you still see this problem in version 24?
If yes, please try in a new profile with that folder, but none of the address books from the old profile in the new profile
Flags: needinfo?(Ulf.Zibis)
Keywords: testcase
Whiteboard: [closeme 2013-11-21]
(Reporter)

Comment 15

5 years ago
I do not see this error on Ubuntu and Windows 7 with TB 24.1.0. On Win XP I can check in 2 weeks. Please remember me.
Flags: needinfo?(Ulf.Zibis)
(Reporter)

Updated

5 years ago
Whiteboard: [closeme 2013-11-21] → [closeme 2013-11-30]
(Reporter)

Comment 16

5 years ago
I still see this error on my Windows XP machine, TB 24.1.1.
- Run TB
- Open attached email.
- Click on reply.
- Type some content, wait, type some content, wait few minutes, ...
- Focus on original email, try to scroll content by horiz. slider, wait ...
--> Message, this time:
    Skript: resource://gre/components/nsHandlerService.js:395
Whiteboard: [closeme 2013-11-30]

Comment 17

5 years ago
Does this happen on small messages?
Flags: needinfo?(Ulf.Zibis)
(Reporter)

Comment 18

5 years ago
What is a small message?
I used the message, attached to this bug.
Flags: needinfo?(Ulf.Zibis)

Comment 19

5 years ago
(In reply to Ulf Zibis from comment #15)
> I do not see this error on Ubuntu and Windows 7 with TB 24.1.0. On Win XP I
> can check in 2 weeks. 

Given this statement, we might assume the problem is with the profile or something else on your XP machine.  

Firstly, you say earlier it is an AMD 2800.  So it's a fine CPU, but announced 10 years ago so it's a fairly old machine. :)  

Secondly, opening this message takes 20MB memory, and reply window (HTML format) takes roughly another 20MB.  **How much memory is installed on this machine?

Next, this issue might be along the lines of bug 544596.

Lastly, does it happen with Thunderbird in safe mode with Windows also in safe mode. In other words
1. Start *Windows'* safe mode with networking enabled
- XP http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx
2. Still In Windows safe mode, start thunderbird in safe mode
- http://support.mozillamessaging.com/en-US/kb/safe-mode

Does problem go away?


> What is a small message?
What I mean is, you can't reproduce the problem with a small message correct? Small being some trivial few lines message that you compose yourself?    (the testcase message is some strange hack of a mess)
Flags: needinfo?(Ulf.Zibis)
(Reporter)

Comment 20

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #19)
> Given this statement, we might assume the problem is with the profile
I used this profile a few years on the XP 32-bit machine. 6 months ago I copied it to my new Win/Linux 64-bit machine. So if the caus of the problem is in my profile, it should reproduce on my new machine.

> something else on your XP machine.
Maybe it's about 32 vs. 64 bit OS.


> **How much memory is installed on this machine?
1 GB. As the message is about 1.5 MB, and I never had problems treating much bigger messages, even in parallel, over years, I don't think the problem is about memory, except, the messy test case message specially needs much memory to be processed, as om my 64-bit machine I have 4 GB.

> Next, this issue might be along the lines of bug 544596.
Little different, as my hang does not occur immediately, there is no sand clock, I can do other things with TB in parallel without problems.

> Lastly, does it happen with Thunderbird in safe mode with Windows also in
> safe mode?
See comment 10 ;-)

> > What is a small message?
> What I mean is, you can't reproduce the problem with a small message
> correct? Small being some trivial few lines message that you compose
> yourself?    (the testcase message is some strange hack of a mess)
I also can't reproduce the problem with any other much bigger message since years. There must be a special trap for TB in this particular hack of a mess.
Flags: needinfo?(Ulf.Zibis)
(Reporter)

Comment 21

5 years ago
(In reply to Ulf Zibis from comment #20)
> Maybe it's about 32 vs. 64 bit OS.
... or about 32 vs. 64 bit CPU.
... maybe it's about using special SSE2 instructions.
    (latest adobe flash player plugins do not work on this AMD CPU accordingly)

Comment 22

5 years ago
so in summary, you only see this on the old XP machine which has 1GB memory?

Please try with a new test profile with your imap accounts defined in the profile. See https://support.mozillamessaging.com/en-US/kb/using-multiple-profiles
Flags: needinfo?(Ulf.Zibis)

Updated

5 years ago
Whiteboard: [closeme 2013-12-20]
(Reporter)

Comment 23

5 years ago
I tried again with new empty profile + added 1 IMAP account.
--> This time after 5..6 min.:
    Skript: resource://gre/components/nsHandlerService.js:395
    Task-Manager: TB is using: 230.000 KB Memory, ~10 % CPU.
    After "stop script": 99 % CPU
    After < 1 min. same warning again, ~10 % CPU ...
    After "stop script" + "Don't show dialogue again": 99 % CPU
    After < 1 min. same warning again, ~10 % CPU ...
    "Don't show dialogue again" was ignored.
    After "continue executing": 99 % CPU
    After < 1 min. same warning again, ~10 % CPU ...
    After "continue executing" + "Don't show dialogue again": 99 % CPU
    No response ever. I again had to kill TB.
Flags: needinfo?(Ulf.Zibis)
Whiteboard: [closeme 2013-12-20]

Comment 24

5 years ago
Start *Windows'* safe mode with networking enabled
- XP http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx
Still In Windows safe mode, start thunderbird in safe mode
- http://support.mozillamessaging.com/en-US/kb/safe-mode

Does problem go away?
- If no, then problem is either: bug in Thunderbird, in your Thunderbird  profile, your mail provider. Please post into topic the contents of Help | Troubleshooting | copy text to clipboard
- If yes, (still in Windows safe mode) ... start Thunderbird normally
  ** If problem is still gone, then cause is a program loaded during windows startup.  Possibilities include: antivirus SW, virus/malware, background downloads such as program updates
   ** If problem is NOT gone, then cause is likely a Thunderbird addon - eliminate them by disabling each one at a time in Tools | addons | extensions and restarting
Flags: needinfo?(Ulf.Zibis)
Whiteboard: [closeme 2014-03-01]

Comment 25

5 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago5 years ago
Flags: needinfo?(Ulf.Zibis)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2014-03-01]
(Reporter)

Comment 26

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #24)
> Start *Windows'* safe mode with networking enabled
> - XP
> http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-
> us/boot_failsafe.mspx
> Still In Windows safe mode, start thunderbird in safe mode
> - http://support.mozillamessaging.com/en-US/kb/safe-mode

I tried this several times, see comment 10. Should I do this with any new version of TB? It's little boring.

> Does problem go away?
> - If no, then problem is either: bug in Thunderbird, in your Thunderbird 
> profile, your mail provider. Please post into topic the contents of Help |
> Troubleshooting | copy text to clipboard

In safe mode, now with TB 24.5.0, I only have: Extras | Error console | ... but no "copy text to clipboard"

With some work, here it is:
Could not read chrome manifest 'file:///C:/Programme/Mozilla%20Thunderbird/chrome.manifest'.

While creating services from category 'profile-after-change', could not create service for entry 'Disk Space Watcher Service', contract ID '@mozilla.org/toolkit/disk-space-watcher;1'

Zeitstempel: 06.05.2014 13:05:03
Warnung: Unbekannte Eigenschaft 'box-sizing'.  Deklaration ignoriert.
Quelldatei: https://www.mozilla.org/de/thunderbird/release/start/?uri=/thunderbird/start/&locale=de&version=24.5.0&os=WINNT&buildid=20140424091057
Zeile: 15, Spalte: 22
Quelltext:
            box-sizing: border-box;

Zeitstempel: 06.05.2014 13:05:03
Warnung: Unbekannte Eigenschaft '-moz-border-radius'.  Deklaration ignoriert.
Quelldatei: https://www.mozilla.org/de/thunderbird/release/start/?uri=/thunderbird/start/&locale=de&version=24.5.0&os=WINNT&buildid=20140424091057
Zeile: 136, Spalte: 25
Quelltext:
       -moz-border-radius: 5px;

Zeitstempel: 06.05.2014 13:05:03
Warnung: Unbekannte Eigenschaft '-moz-border-radius'.  Deklaration ignoriert.
Quelldatei: https://www.mozilla.org/de/thunderbird/release/start/?uri=/thunderbird/start/&locale=de&version=24.5.0&os=WINNT&buildid=20140424091057
Zeile: 169, Spalte: 25
Quelltext:
       -moz-border-radius: 5px 5px 0 0;
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 27

4 years ago
So, nothing interesting in error console.

WHat is size of panacea.dat?
Can you go through relevant parts of https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems
Flags: needinfo?(Ulf.Zibis)
See Also: → bug 958997
Summary: Unresponsive script in nsHandlerService.js during compose → Unresponsive Script in nsHandlerService.js during compose
Whiteboard: [closeme 2015-01-10]

Comment 28

4 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago4 years ago
Flags: needinfo?(Ulf.Zibis)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2015-01-10]
(Reporter)

Comment 29

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #27)
> WHat is size of panacea.dat?
8 kB

> Can you go through relevant parts of
> https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems
I have checked 1. ... 11. with TB 38 on Win XP.
With this version I did not see any warning about unresponsive script, but the machine freezes completely after ~4 min.
Maybe I check 12. ... if I have time.
(Reporter)

Comment 30

3 years ago
I now have put the same disk (with same WinXP-installation) onto another machine with Intel CPU which is aged to, but has SSE2 instruction set.
On this machine I can't reproduce the problem. Maybe the reason of the crash on the former machine is it's AMD-CPU which didn't have SSE2 instruction set.
You need to log in before you can comment on or make changes to this bug.