Closed Bug 760821 Opened 9 years ago Closed 8 years ago

[pt-BR] Localize Get Involved page + video + email responses

Categories

(www.mozilla.org :: L10N, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Future

People

(Reporter: davidwboswell, Assigned: mlcaraldi)

References

()

Details

(Whiteboard: [l10n])

Attachments

(1 file, 1 obsolete file)

Opening bug to track creating a pilot localization of the Get Involved page.  Additional background information available at bug 743746.

Having the Portuguese Get Involved page ready to go in time for FISL on July 25 could be a good deadline to aim for.
Whiteboard: [l10n]
Commits pushed to dev at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/d9475c6d7895a15cdcd8eda61ba7ee00a9af4adb
for bug 760821, make strings in contribute forms localizable

https://github.com/mozilla/bedrock/commit/470764bf604eb8616727f1dbf2c128640883ace7
Merge pull request #161 from pascalchevrel/l10n_forms.py

for bug 760821, make strings in contribute forms localizable
Adding Milos to bug.  He's offered to help get a PT version of the page on the dev site so we can work on it there and start testing.
Luciana just sent me this link where she's been gathering PT localized strings from the page.

https://docs.google.com/document/d/1UFjkkog8M6ozp6RFP6s3A-_5IAff70P7BiNlYh0ySJ4/edit?pli=1#heading=h.8up0nn46dtw4

Milos can give us advice about how to get this into the l10n workflow and how to move forward getting a PT version of the page up on the dev site with this content.
David, Milos,
please notice this document is not completely reviewed yet...
(In reply to Fernando Pereira Silveira from comment #4)
> David, Milos,
> please notice this document is not completely reviewed yet...

Thanks -- good to know.  If Milos does want to go ahead and use this to put up a page on dev it might be easier for everyone to review as a web page.
that's ok to me ;-)
Pascal has posted a pt-BR version of /contribute on the dev site at

https://www-dev.allizom.org/b/pt-BR/contribute/
great!
how can we review it and translate those untranslated strings?
(In reply to Fernando Pereira Silveira from comment #8)
> how can we review it and translate those untranslated strings?

Milos or Pascal, can you help Fernando with this question?  How can we get these strings into the regular l10n tools?  I believe Portuguese localizers have been capturing things in a Google Doc so far since it wasn't clear how to get these strings into the right workflow.
There is some documentation about localization on Bedrock at

http://bedrock.readthedocs.org/en/latest/l10n.html

This may or may not answer any technical questions people have, but hopefully it helps.
David, Fernando,

Do we want pt-BR or pt-*(unified Portuguese locale)? As per IRC chat with Giorgos, we can make sure that both pt-BR and pt-PT use the same email for sending inquiries to, in 2 ways:

1) Treat both as separate locale, and translate everything twice(not really translate it twice, but just once and then copy and paste for the other)
2) Treat them as one locale in our bedrock code

I'm against second and for first option, because if we translate it twice, for pt-PT and pt-BR, we can always use the same contact, but if we make pt-* locale in code, that means that we'll need to touch code once more should we want to have someone else as a contact for either of the pt versions.

What's your input on this?
Milos, Giorgos, any decision on pt-PT web pages should be taken by the the pt-PT localizer (now CCed), not the pt-BR localizer. We would certainly not copy-paste pt-BR content to pt-PT without Carlos approval.
There is a third option:

3. Manage email contacts directly from the code  (and not through the localization tools). Locales keep their different translations but we programmatically set the same email for all pt-* languages.

Personally I'm with the first option also, as long as we can easily set the same email for all pt-*, es-*, etc languages. 

Since we discussed that with Milos and he suggests that this is an easy fix I +1 the first option.
Pascal, agreed. We are not discussing about changing the translations, only about how we handle the emails. I believe option (2) as described by Milos was a miscommunication between the two of us. We are going merging locales.

So it's either (1) or (3)

Thanks
That's a good question and this would apply to how to handle the ES version as well.  

Option 1 sounds like it makes the most sense to me.  Option 3 would work, but I'm assuming we want to minimize the number of things we have to change in the code since it could take a week or so to get changes live.

This may also need to be something we try and see what works in practice.
First option makes more sense to me, as long as PT and BR contents are not copy-pasted. They should be translated twice because they are focused on two different communities.

In future both communities can merge their contents, but that requires an articulation we didn't get started yet.
I agree with Fernando.

Also, I would like to remind us that we still need to localize the "want to help?" and the footer copyright text.
Clarifying blockers for the PT localization.
Depends on: 756093, 769715, 770606, 774232
Target Milestone: --- → Future
I have an update on timing for the PT Get Involved page after going to the mozilla.org planning meeting today.  

There are still a number of issues with Bedrock that need to get sorted out before we can finish localizing the page (see bug 775269 for a list of l10n improvements).

This means that we won't be able to have the page ready in time for FISL, but we are looking at how to get this live soon after.

I'll share more information about a new proposed launch date as soon as I hear back from the webdev and l10n teams.
I wanted to post an update about where we are with the Portuguese Get Involved page.

A number of Bedrock l10n bugs were found when we started this project and those will soon be fixed in the next week or two.

I checked in with Pascal this morning and he said most of the localization is also ready, although at this point it's hard to test because of the bugs on the site.

I'll post again when we know specific dates, but we're getting close to being able to test and see if there are any additional changes to make before going live.
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
Component: General → L10N
I just heard from Pascal that the page is ready for testing at

http://www.mozilla.org/b/pt-BR/contribute/

Please take a look and let us know if you have any feedback.  Note that Pascal has noticed some small sections of the page that are still in English and he's looking into that (the drop down form and Terms of Use checkbox).

I also sent a test message through the form, so please let me know if that was received.  Right now, I believe it the emails from the form are set to go to  	Marcelo.
Locale: pt-BR / Portuguese (Brazilian)
Hi David!
If it's not too late, I think we should change "Envie uma nota para nós e poderemos começar imediatamente" (Send us a note so we can get you started) to "Deixe-nos uma mensagem para saber como" (Leave a message to know how).

This is a complement to the "Do you want to help?" question, I think the second expression makes more sense....
Marcelo, I'll let Pascal respond about how to get that change made.  I don't believe it's too late though since there are a couple more Bedrock issues to sort out before a full launch.
Contribute.lang is updated with the latest strings appearing on the page
http://l10n.mozilla-community.org/~pascalc/langchecker/?locale=pt-BR#mozorg/contribute.lang

Staging site: https://www-dev.allizom.org/pt-BR/contribute/

AFAIK, once these 7 strings are translated, we can activate the page on production
Fernando / Marcelo,

Just checking in to see the status of this.
OS: Mac OS X → All
Hardware: x86 → All
I want to push this live, but I still see some untranslated strings, e.g. at the end of:

http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/trunk/locales/pt-BR/mozorg/contribute.lang?view=markup

Let me know the current status and we'll make a plan to put this into production.
Hey guys, sorry for the delay on finishing it. Here's a fully translated version of the contribute.lang file.

I'll review it during the next few days and have a final version soon. As I don't have acess to the SVN yet, I'll attach it so, please, I'd appreciate if someone could upload it :)

Thank you!
Let's file a bug to get you svn access :) Brian I can do it this afternoon.
(In reply to Pascal Chevrel:pascalc from comment #30)
> Let's file a bug to get you svn access :) 

Marcelo, instructions are here for this:
https://wiki.mozilla.org/SVN#SVN_account_for_localizers

> Brian I can do it this afternoon.

Done, r112963.

Marcelo, you can check it on stage:
https://www-dev.allizom.org/pt-BR/contribute/
Assignee: nobody → mlcaraldi
Status: NEW → ASSIGNED
Attached file Minor fixes.
Ok, thank you Brain, my SVN account is almost ready... While we wait, I'm uploading the final version here....  Thank you!
Attachment #713846 - Attachment is obsolete: true
(In reply to Marcelo Araldi from comment #32)
> Created attachment 715109 [details]
> Minor fixes.
> 
> Ok, thank you Brain, my SVN account is almost ready... While we wait, I'm
> uploading the final version here....  Thank you!

Checked in, r113269.

Marcelo, let me know when you are ready and I will push this live.
Ok Brian, in my opinion we are ready!

Just a little question: the pages linked on the top of the Get Involved page are available to translation?

Thanks!
(In reply to Marcelo Araldi from comment #34)
> Ok Brian, in my opinion we are ready!

Excellent, I will push this live soon!
 
> Just a little question: the pages linked on the top of the Get Involved page
> are available to translation?

The pages or just the links? Localizing the links in the Tab is a separate issue, see bug 744271.
the pages, actually
Yes, unfortunately most of the pages on mozilla.org can't be localised currently. Pascal would be the best person to talk to about that.
Ok, thank you :)
And we are live!

https://www.mozilla.org/pt-BR/contribute/

Please test to ensure everything is working as expected.
Thank you Brian!

I didn't see anything wrong... This page is ok :)
I just tested the form and found 2 strings in English.

1. If you try and submit the form without checking the privacy checkbox, a small tooltip like bubble appear by the checkbox.

2. The auto-response when I chose Marketing. The subject line is English, but the rest of the email is in Portugese. I'm not sure if this is the case for all categories.
case 1/ is not a bug, the client side validation is done with HTML5 forms and the string you are seeing is provided by your browser and not by our webpage.

For 2/ I don't know, I'd have to investigate but I won't have time today.
I'm available to localize anything it's necessary, just let me know if there's something to do :)
Hi guys,
just checking... news on this?
(In reply to Marcelo Araldi from comment #44)
> Hi guys,
> just checking... news on this?

I filed bug 854992 for the subject line issue. I think that covers everything, so closing this off. If I am mistaken, feel free to reopen.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.