Last Comment Bug 766962 - Tracking: Localized B2G builds
: Tracking: Localized B2G builds
Status: RESOLVED FIXED
[b2g][l10n]
:
Product: Release Engineering
Classification: Other
Component: General Automation (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Ben Hearsum (:bhearsum)
: Chris AtLee [:catlee]
Mentors:
: 812371 (view as bug list)
Depends on: 812831 812833 812834 812835 812836 816633
Blocks: mobile-automation 812371
  Show dependency treegraph
 
Reported: 2012-06-21 07:28 PDT by Staś Małolepszy :stas
Modified: 2013-08-12 21:54 PDT (History)
30 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Staś Małolepszy :stas 2012-06-21 07:28:53 PDT
We'll need localized builds for b2g for testing and eventually, for shipping.  This is similar to bug 761868.

1) the initial list of locales is en-US, es, pt-BR, but we want to make sure it can be easily extended with more locales.  Scalability is very important to us and we will want to 

2) single locale or multilocale?  what are the requirements for Basecamp here?

3) Kaze, I recall you wrote a script that concatenates per-locale .properties into a single file.  We might need that, depending on the outcome of the discussion that's currently taking place in mozilla.dev.gaia. 

4) the repositories to pull localization from are TBD:  it might be hg, or git, depending on the exact approach that we choose (this is related to #3)

5) Should this block bug 763611 and bug 744008?

6) Should I file another bug for localized desktop builds?
Comment 1 Ben Hearsum (:bhearsum) 2012-06-21 08:27:28 PDT
Assigning to John for prioritization.
Comment 2 chris hofmann 2012-06-21 20:03:57 PDT
until there is wide availability of devices we will need desktop builds in an emulator to check out things like dialog sizes and screens fitting in the form factor.
Comment 3 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2012-06-26 07:34:51 PDT
grabbing while sorting out various B2G priorities in 
https://etherpad.mozilla.org/b2g-builds.
Comment 4 Chris Cooper [:coop] [away until Aug 29] 2012-11-13 09:44:44 PST
Just got out of a call with Staś and Axel. These are the details as I understand them:

* these will be repacks of desktop b2g builds because that is the easiest thing for localizers to test
* these will be single locale repacks and there will be up to 40 of them (40 localization teams currently)
* the gecko repack process is largely borrowed from mobile
** make targets (chrome-%?) already exist AIUI
* Gaia repack process is still TBD, although we don't expect to be repacking Gaia in the traditional sense. Likely dropping in bundles.
** there are experiments going on here to determine what the best path forward is because string substitution is slow on the client side. We probably can't include more than one Gaia locale bundle in a given repack. Even 3-4 locales is unreasonably slow at present.
** can we pass a local list to build/zip-webapps.js?
* localizers are working out of hg repos (for Gecko, I assume)
* l10n-changesets?
** probably same as for mobile/desktop: dashboard -> buildbot-configs
** "borrow" sign-offs from mobile
* likely won't need shipped_locales
** list of locales will be specified per-carrier
Comment 5 Staś Małolepszy :stas 2012-11-17 15:29:41 PST
*** Bug 812371 has been marked as a duplicate of this bug. ***
Comment 6 Andrew Overholt [:overholt] (back Aug 31) 2012-11-30 10:08:01 PST
Clearing blocker nom on tracking bug.  All deps are either +'d or -'d.
Comment 7 Ben Hearsum (:bhearsum) 2012-12-13 09:54:32 PST
All of the required localized builds are now ready. See dep bugs for details.

Note You need to log in before you can comment on or make changes to this bug.