Shutdown crash on Windows 7 when telemetry is enabled

RESOLVED DUPLICATE of bug 682444

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 682444
6 years ago
4 years ago

People

(Reporter: MarcoZ, Unassigned)

Tracking

({crash})

Trunk
x86_64
Windows 7
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Thunderbird reliably crashes forme on shutdown when Telemetry is enabled in Tools/Options/Advanced.

STR:
1. Start Thunderbird.
2. Go to Tools/Options, and select the Advanced tab, and then the General page.
3. Check the checkbox "Send performance data"., and click OK.
4. Shut down Thunderbird after working with it for a while.

Result: There will be a Windows dialog coming up after a few seconds saying that "Daily stopped working. Windows can search for a solution online...". There will be *no* Mozilla Crash Reporter dialog.

5. Start Daily again.
6. In the same dialog, uncheck the checkbox and click OK.
7. Shut down Thunderbird.

Result: Since Telemetry isn't properly shut down yet, the crash will occur again.

8. Restart Daily.
9. Work with it for a minute or so.
10. Shut it down again.

Result: No crash.

I can reliably reproduce this. As soon as Telemetry is on and Daily is shut down, the machine becomes slow until the Windows dialog comes up. Once you dismiss it, operation of the OS returns to normal speed.
If Telemetry is off, no such crash occurs, and Daily shuts down cleanly.

Comment 1

6 years ago
pretty sure this is a dup.
Whiteboard: dupeme

Comment 2

6 years ago
(In reply to David :Bienvenu from comment #1)
> pretty sure this is a dup.

I couldn't find anything  mentioning telemetry except bug 682444

Comment 3

6 years ago
that's the one I was thinking of.

Comment 4

6 years ago
Other Telemetry dependent bugs
bug 758826 and bug 758089
No crash reports generated on the symptoms described there.

Comment 5

6 years ago
fwiw, there is also bug 763361
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 682444

Updated

4 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.