Section editing removes TOC and all tags

RESOLVED FIXED

Status

developer.mozilla.org
Editing
P1
major
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Louis-Rémi BABE, Assigned: ubernostrum)

Tracking

Details

(Whiteboard: sp=3 worktype=bug)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/16.0 Firefox/16.0
Build ID: 20120703030538

Steps to reproduce:

I edited a specific section of a page.


Actual results:

After saving my changes and reloading the page, the TOC of the page was lost.


Expected results:

I want my TOC back!
Ha! That explains the vanishing TOCs that I was discovering!
Severity: normal → major
Whoa. I assumed this was just cosmetic, but it's not. Weeeird! This needs to be investigated before launch.
Duplicate of this bug: 775385
Janet provided some very good steps to repeat here:
https://bugzilla.mozilla.org/show_bug.cgi?id=775385#c0
Jean-Yves in bug 775385:
> Note that the TOC is removed, but also all the tags :-(

Editing the title accordingly.
Summary: Editing a section of a page removes the TOC → Section editing removes TOC and all tags
Blocks: 775601
This is a fairly serious problem; we're gradually messing up the site by doing this. We also need to figure out how to fix all the pages that have been messed up.
Planning to temporarily disable section editing (see bug 774449) before launch to avoid this and a bunch of other bugs related to section editing.

Also, I opened bug 775625 about fixing pages that have already been messed up.
Priority: -- → P2
Version: Kuma → unspecified
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
No longer blocks: 775601
Component: Landing pages → Editing
Whiteboard: p=2
Depends on: 823731
Depends on: 823733
Whiteboard: p=2 → sp=2 type=bug
Priority: P2 → P1
Depends on: 826438
Depends on: 826441
Depends on: 826444
Whiteboard: sp=2 type=bug → sp=3 type=bug
Whiteboard: sp=3 type=bug → sp=3 worktype=bug
(Assignee)

Comment 8

6 years ago
So, some quick notes on what's going on here.

The problem seems to stem from the fact that section editing doesn't submit all the metadata fields, but the form expects them; when it sees the submission, it thinks "no tags submitted, no ToC checkbox", and generates a new Revision accordingly.

Solution is going to be

1. Making the save code aware of section editing (not terribly hard because the form knows if it's editing a section or the full document), in bug 823733,

2. Reworking the section-editing unit tests to accommodate and exercise that (bug 826438),

3. For good measure, disabling the ability to do a "full-page" section edit, leaving only the inline version, since having both requires the code to be way more complicated (and may not even be possible since they'd be showing incompatible things for a single code path). That's bug 826444.
(Assignee)

Updated

6 years ago
Assignee: nobody → jbennett
(Assignee)

Comment 9

5 years ago
Section editing still has issues, but the ones in this specific bug have been cleared up AFAIK.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.