Unable to edit slug and title of non-English pages

RESOLVED FIXED

Status

Mozilla Developer Network
Localization
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: FredB, Assigned: groovecoder)

Tracking

Details

(Whiteboard: s=2012-08-22 p=2 s=2012-08-29)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Tried to edit with this url: https://developer-new.mozilla.org/pl/docs/HTML/Element/address$edit


Actual results:

I can edit, but there is no "i" button to change the slug or title.


Expected results:

I should have been able to see the button and change the metadata just like on https://developer-new.mozilla.org/en-US/docs/HTML/Element/address$edit
(Reporter)

Updated

5 years ago
Blocks: 756263

Comment 1

5 years ago
There's a "+" in the translation UI next to (the translation of) "Translate Description". Click that to expand the metadata fields.
(Reporter)

Updated

5 years ago
Blocks: 756266
No longer blocks: 756263
What Janet said :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

5 years ago
After discussion, seems like it's a permission issue. Regular users can change the slug and title of documents on en-US/ but not on other languages.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Metadata button absent on non-en documentation → Translation UI should not be restricted
(Reporter)

Comment 4

5 years ago
It only affects the translation UI, and not any edit UI. The "i" button can be seen here: https://developer-new.mozilla.org/fr/docs/fr
Thanks for the report, Frédéric. I will be sure we look further into this soon.
Summary: Translation UI should not be restricted → Unable to edit slug and title of non-English pages
Duplicate of this bug: 773901

Updated

5 years ago
Duplicate of this bug: 774722
Lots of people are reporting this (see the duplicates list). Pretty high priority, I would say.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Duplicate of this bug: 778451
Component: Docs Platform → Localization
Whiteboard: s=2012-08-22
Whiteboard: s=2012-08-22 → s=2012-08-22 p=2
It appears as though users need "wiki.change_document" permissions to edit the title and slug fields on the translation page.  The user cited earlier today by sheppy, Archaeopteryx, does not have this permission.
Hm, he said he just added some text to the page. He didn't mention doing any slug changes.
Plus he was working on the English version of the page, not a translation.
Whiteboard: s=2012-08-22 p=2 → s=2012-08-22 p=2 s=2012-08-29
I'm unclear on what the actual bug is here, if it's not a permission/translate issue.
I don't think any of us completely understand what the underlying problem is.

It could be a permission issue, but it could be an interface issue. If you read the dupes, you'll see that some people may have just not realized that they could click "i" to make these changes.

Comment 15

5 years ago
Created attachment 657071 [details]
Screenshot of Polish translation UI for non-privileged account

Comment 16

5 years ago
The "i" icon is definitely a usability issue, because it's totally not obvious that that should allow you to edit. 

However, that's not the issue here. A non-privileged user doesn't see any icon. I took the attached screenshot from a non-privileged account (not my mozilla.com Persona).
I guess that doesn't explain the "bug" here.  Is the bug that *everyone* should have privs to edit slugs and titles?  Otherwise this is working exactly as it should...
Depends on: 788832
(Assignee)

Updated

5 years ago
Assignee: nobody → lcrouch
(Assignee)

Comment 18

5 years ago
Confirming :davidwalsh comment - this is working as intended. The only way to edit the title & slug of a translation is:

1. At the time of initial translation
2. With the special privilege.

Do we want to change this? Maybe include the original creator of the translation as a person who can edit the title and/or slug?

This would also be affected by the potential refactoring of slugs.
(In reply to Luke Crouch [:groovecoder] from comment #18)
> Confirming :davidwalsh comment - this is working as intended. The only way
> to edit the title & slug of a translation is:
> 
> 1. At the time of initial translation
> 2. With the special privilege.
> 
> Do we want to change this? Maybe include the original creator of the
> translation as a person who can edit the title and/or slug?
> 
> This would also be affected by the potential refactoring of slugs.

Yes, this needs to change. Translators need to be able to correct these translations; if, for example, the English version's title is updated, or there's a translation error in the original version.
(Assignee)

Comment 20

5 years ago
Is the title the only/most important field to change? 

The reason I ask - page-moving isn't hurting as badly as it could because only privileged users have the ability to change slugs. i.e., only the docs team, since we haven't given the permission to many others.

Until the page-moving feature is done - including a specific privilege - could we allow anyone/everyone to change just the *title*? Would the at least help the situation while we wait for page-moving?

Then we'll just make sure that page-moving works for translations too.
It's the most important thing, yeah.

Comment 22

5 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/d811df4c86ac0d647ac267d4f5cd76f91c89f3d9
fix bug 773252; edit title of translations

https://github.com/mozilla/kuma/commit/f31088dc94c89baca8016944c5869e3209b0934c
Merge pull request #591 from groovecoder/edit-translated-title-773252

fix bug 773252; edit title of translations

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Version: Kuma → unspecified
No longer blocks: 756266
You need to log in before you can comment on or make changes to this bug.