Closed Bug 775491 Opened 8 years ago Closed 8 years ago

HTML5 unresponsive script errors on YouTube (unresponsive script name: html5player-vflGWJljH.js)

Categories

(Tech Evangelism Graveyard :: English US, defect, major)

x86_64
Windows 7
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: GATETRAVELER1, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Attempted to watch youtube videos.


Actual results:

Starting on 7/18/12 about 80 -90% of the videos I attempt to view get an unresponsive script error. If I stop the script it takes about 30 seconds for me to start the video. The problem does not occur in internet explorer.


Expected results:

Video should have played.
this is also happening with the latest m-c win32 build 17.0a1 

Turning 'off' HTML5 on Youtube seems to prevent the slow-scirpt warnings

I'm guessing Google broke something in HTML5.
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
Ever confirmed: true
This has nothing to do with tabbed browser.

It may not be a mozilla bug at all but a bug in the youtube script...
Component: Tabbed Browser → General
Product: Firefox → Core
Severity: normal → major
Keywords: qawanted
Also see http://support.mozilla.org/en-US/questions/932553 on this. Looks like those problems started yesterday.
Duplicate of this bug: 775417
Summary: unresponsive script errors on youtube → HTML5 unresponsive script errors on YouTube
Summary: HTML5 unresponsive script errors on YouTube → HTML5 unresponsive script errors on YouTube (unresponsive script name: html5player-vflGWJljH.js)
Opera 12 also hanging/stuttering on youtube HTML5. But Chrome works fine. 
fishy?
Boris: IIRC you have some contact at YouTube, can you point him/her to this bug? This bug is a high visibility issue, so that would be cool! This bug here is quite certainly a YouTube issue, not a Firefox one. Actually they should notice really soon that a lot of users complain about this, but you never know if support people really forward such complaints to the software engineers.
Attached video Video of bug behaviour
Please check attachment for more info:

Trying to find a regression range:

From:
Nightly 2012-07-19  
to: 
Nightly 2011-06-07
http://hg.mozilla.org/mozilla-central/rev/9014863a7e2a

Visible script error window.


Below Nightly 2011-06-06
http://hg.mozilla.org/mozilla-central/rev/caf81a228fff

Script warning window is not visible.
Video don't play until pressing play button.


Must be the recent change in the Youtube Html5 video player code because around 2012-07-01, I watched the html5 video on nightly without noticing any script error.
Attachment #643855 - Attachment mime type: application/octet-stream → video/webm
The first time I hit this I was able to play the video by hitting Continue a few times. The second time that didn't work; I tried to dump the JS stack, but I gave up when the stack dumper got to about 350 frames because by then it was taking about a second to process each stack frame...
Duplicate of this bug: 775574
Google should be pushing out a fix for this today.
Assignee: nobody → english-us
Component: General → English US
Product: Core → Tech Evangelism
Version: 13 Branch → unspecified
Duplicate of this bug: 775644
Duplicate of this bug: 775586
Thanks.

Unrelated to this issue, but how about if Google fixes this too? (The select tag for image size moving around when I try to click it). It's very annoying.

http://dl.dropbox.com/u/6005119/firefox/test.webm
Report the problem to them?  I'll try to as well.  ;)
(In reply to Boris Zbarsky (:bz) from comment #15)
> Report the problem to them?  I'll try to as well.  ;)

I've tried, I sent them comments via their form (in Google images), not sure what other means there are for reporting issues to Google.

But I didn't got a reply from them.

I asked in #firefox and somebody gave me a config option for about:config. People in #firefox said that this was an issue (Google doing something weird with the user-agent string) or something like that.
Sorry for the off-topic.
Keywords: qawanted
Duplicate of this bug: 775721
Duplicate of this bug: 775809
I don't get hangs anymore when viewing YouTube videos in HTML5, anyone else?
Yes, looks like this bug has been fixed.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Now on Aurora 16 html5 youtube videos won't automatically start. You have to click on them to play. Could be something related to this bug? Not reproducible on Beta and Nightly.
(In reply to Paul Silaghi [QA] from comment #23)
> Now on Aurora 16 html5 youtube videos won't automatically start. You have to
> click on them to play. Could be something related to this bug? Not
> reproducible on Beta and Nightly.

This was fixed by Bug 773929
Confirmed. Thanks Alice.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.