Closed Bug 778534 Opened 7 years ago Closed 6 years ago

Use image instead of html:img in instant messaging

Categories

(Thunderbird :: Instant Messaging, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 956579

People

(Reporter: iann_bugzilla, Unassigned)

References

Details

Attachments

(1 file)

Over in bug 774063 it was suggested that html:img could be removed from imbuddytooltip.xml
Simple switch to using xul:image instead of html:img
Attachment #680792 - Flags: review?(mbanner)
Comment on attachment 680792 [details] [diff] [review]
Switch to xul:image

Florian's better to review this code.
Attachment #680792 - Flags: review?(mbanner) → review?(florian)
(In reply to Mark Banner (:standard8) from comment #2)
> Comment on attachment 680792 [details] [diff] [review]
> Switch to xul:image
> 
> Florian's better to review this code.
Flags: needinfo?(florian)
Comment on attachment 680792 [details] [diff] [review]
Switch to xul:image

The HTML img tag keeps the aspect ratio while scaling the image down. The XUL image tag doesn't.

Sorry for the delay. I suspected this, but wanted to actually try the patch to verify that the behavior of the XUL image tag hasn't changed since when I initially wrote that code.

It seems that since bug 585069 got fixed there should be a better way to do the scaling, but my quick attempts to use <xul:image maxheight="48" maxwidth="48" instead of http://hg.mozilla.org/comm-central/annotate/ff643eff7154/mail/components/im/content/imbuddytooltip.xml#l140 weren't successful.
Attachment #680792 - Flags: review?(florian) → review-
Flags: needinfo?(florian)
(In reply to Florian Quèze from comment #4)
> It seems that since bug 585069 got fixed there should be a better way to do
> the scaling, but my quick attempts to use <xul:image maxheight="48"
> maxwidth="48" instead of
> http://hg.mozilla.org/comm-central/annotate/ff643eff7154/mail/components/im/
> content/imbuddytooltip.xml#l140 weren't successful.

Possibly because of the inline style on the parent?
As the code this was patching was rewritten in bug 956579, marking as a dupe of that bug.
Assignee: iann_bugzilla → nobody
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 956579
You need to log in before you can comment on or make changes to this bug.