Closed Bug 779714 Opened 7 years ago Closed 5 years ago

mail.tabs.autoHide=true causes tilebar is too narrow after australis tab design

Categories

(Thunderbird :: Theme, defect)

All
Windows 7
defect
Not set

Tracking

(thunderbird34 fixed, thunderbird35 fixed, thunderbird36 fixed, thunderbird_esr3134+ fixed)

RESOLVED FIXED
Thunderbird 36.0
Tracking Status
thunderbird34 --- fixed
thunderbird35 --- fixed
thunderbird36 --- fixed
thunderbird_esr31 34+ fixed

People

(Reporter: m_kato, Assigned: Paenglab)

References

Details

Attachments

(2 files)

See screenshot.  title bar is too narrow on Windows 7 with the latest Daily.
That's true, but you have gained some pixels for the content ;). When bug 771816 lands you can disable draw in titlebar and you have the standard titlebar back.
Did comment 1 fixed this problem?
Flags: needinfo?(m_kato)
(In reply to Javi Rueda from comment #2)
> Did comment 1 fixed this problem?

No, Although I test on version 33.0, this still occurs.
Flags: needinfo?(m_kato)
Version: unspecified → Trunk
You have set mail.tabs.drawInTitlebar to false and the titlebar is still to narrow? Maybe we should add a logic to disable the draw in titlebar when mail.tabs.autoHide is on true.
Attached patch bug779714.patchSplinter Review
This patch adds the logic to disable the draw in titlebar when mail.tabs.autoHide is true. This means draw in titlebar is only enabled when mail.tabs.drawInTitlebar is true and mail.tabs.autoHide is false. Every other combination disables it.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8514471 - Flags: review?(bwinton)
Comment on attachment 8514471 [details] [diff] [review]
bug779714.patch

Review of attachment 8514471 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, this makes sense to me, although I think we will want to mention it somewhere public-ish (Mozillazine, perhaps?) so that we don't get a lot of complaints that people's Thunderbirds aren't drawing in the titlebar anymore…  ;)
Attachment #8514471 - Flags: review?(bwinton) → review+
(In reply to Blake Winton (:bwinton) from comment #7)
> Yeah, this makes sense to me, although I think we will want to mention it
> somewhere public-ish (Mozillazine, perhaps?) so that we don't get a lot of
> complaints that people's Thunderbirds aren't drawing in the titlebar
> anymore…  ;)

But I think the complaints about the not existing titlebar where more. There where more bugs than this one and his dupe.
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 36.0
Comment on attachment 8514471 [details] [diff] [review]
bug779714.patch

[Approval Request Comment]
User impact if declined: With autohide=true not dragable titlebar
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): small, only a small js change in the draw in titlebar logic.
Attachment #8514471 - Flags: approval-comm-esr31?
Attachment #8514471 - Flags: approval-comm-beta?
Attachment #8514471 - Flags: approval-comm-aurora?
Attachment #8514471 - Flags: approval-comm-beta?
Attachment #8514471 - Flags: approval-comm-beta+
Attachment #8514471 - Flags: approval-comm-aurora?
Attachment #8514471 - Flags: approval-comm-aurora+
Attachment #8514471 - Flags: approval-comm-esr31? → approval-comm-esr31+
Duplicate of this bug: 1043646
Flags: in-moztrap?
Duplicate of this bug: 1077251
Duplicate of this bug: 1127344
I'm not understanding something...

I have a netbook with a very small screen.

I always use TB maximized, with a minimal UI.

When the UI is maximized, there is never, ever a need to have to move/drag the window.

Prior to this change, I had the Menu Bar displayed in the Titlebar, with the tab bar hidden (only comes up if/when I open the calendar to do something there, then close it to reclaim my minimalist UI). This was an extremely minimal UI that really made working on my netbook much more comfortable.

Am I correct that this change was intentional due solely to the fact that the window cannot be moved/dragged when the Menu bar is displayed in the Titlebar?

If so, I'll go open a bug to bring back this ability when the window is maximized.
Done anyway...

Bug 1273199 - Allow both mail.tabs.drawInTitlebar and mail.tabs.autoHide to be True when window is maximized
And opened bug 1336959 to allow moving the window by click-dragging a blank space on the Menu Toolbar.
You need to log in before you can comment on or make changes to this bug.