Facebook always show remote content v. correct From name

RESOLVED WONTFIX

Status

Thunderbird
Folder and Message Lists
RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: Mitra Ardron, Unassigned)

Tracking

16 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: wontfix)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 653412 [details]
Screenshot

If you get Facebook notifications, the From address is set to something like:

"Joe Smith" <notification+a4jjj213sdqwewq@facebookmail.com>

The random string in the email address is always the same for all Facebook notifications (no matter who'se post is being sent), and I think is so that Facebook can recognise replies. 

If this address is NOT in your address book, then TB won't show the remote content on the page,  but there is no way to enable remote content without adding the entry to an addressbook.

But if you click "ALways show remote content from notification.....facebook.com" then it remembers the address with Joe Smith's name, even though other notifications will be from other people. 

I'm not sure what the solution is, the problem I believe is the integration of "Always Show Remote Content" with the AddressBook, which causes other problems as well for example Bug #487479 Bug #482616 Bug #370165 Bug #249191 all talk about problems with either unwritable address books (LADP,OSX) or not being able to set this in filters.
(Reporter)

Comment 1

6 years ago
Sorry - that should have been Bug #486479 Also Bug #465717 and Bug #457296 where a proposal is made for a whitelist of messages that allow it. 

Should I open a meta-bug (or whatever its called for this) since there are numerous individual bugs (as observed by users) all related to a single set of causes.

Comment 2

6 years ago
(In reply to Mitra Ardron from comment #0)
> But if you click "ALways show remote content from
> notification.....facebook.com" then it remembers the address with Joe
> Smith's name, even though other notifications will be from other people. 

If we wanted to fix just this part, we could set PreferDisplayName to false when creating a contact this way.
(Reporter)

Comment 3

6 years ago
I've just confirmed this works for the Facebook case when you do it by hand.

I think it would be a good default, especially this is probably quite a common case for input from mailing lists (all of which is HTML these days). And I doubt most people would figure out this option on their own. 

Allowing a prerence to ALWAYS show images would also be a good one, as the longstanding TB bugs around this are far worse than the risk of getting unpleasant images in mail.
(Reporter)

Comment 4

6 years ago
Actually - looks like it does have a preference:
mailnews.message_display.disable_remote_image    

Geeks can set this to false to get TB to function properly on MacOSX etc - mere mortals of course will never figure this out (and shouldnt be in the config editor).

Comment 5

4 years ago
Given that the address book is no longer a white list for remote images, I think this bug should be closed wontfix.
Whiteboard: wontfix

Comment 6

4 years ago
Yup. You can add the needed domains instead now.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.