Last Comment Bug 784272 - Docked chat boxes should not overlap vertical top-level scrollbars
: Docked chat boxes should not overlap vertical top-level scrollbars
Status: RESOLVED FIXED
[Fx17]
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 17
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
Mentors:
Depends on:
Blocks: 779686 785593
  Show dependency treegraph
 
Reported: 2012-08-21 00:17 PDT by Jared Wein [:jaws] (please needinfo? me)
Modified: 2012-09-03 04:26 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.06 KB, patch)
2012-08-24 22:45 PDT, Jared Wein [:jaws] (please needinfo? me)
no flags Details | Diff | Splinter Review
Patch v2 (2.06 KB, patch)
2012-08-26 16:59 PDT, Jared Wein [:jaws] (please needinfo? me)
mixedpuppy: review+
Details | Diff | Splinter Review
Patch for checkin (2.07 KB, patch)
2012-08-26 17:13 PDT, Jared Wein [:jaws] (please needinfo? me)
jaws: review+
Details | Diff | Splinter Review

Description Jared Wein [:jaws] (please needinfo? me) 2012-08-21 00:17:43 PDT
From bug 779686 comment #22:

> If there is a chat window that is right-most, as in this screenshot, does it
> block access to the bottom part of the scrollbars?
> 
> We should move the chat window over just enough to not block any part of the
> scrollbars (even on pages that lack scrollbars, so as not to jump when
> switching tabs or when dynamic changes to content are made).
Comment 1 Dão Gottwald [:dao] 2012-08-21 00:37:37 PDT
You're saying scrollbars, but it seems like you're only talking about the vertical scrollbar. How would you address horizontal scrollbar being blocked?

Secondly, I don't think it's kosher to special-case the default scrollbar here and disregard any custom UI implemented by content (such as Facebook's custom scrollbars).

See also bug 779686 comment 57.
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2012-08-24 22:45:24 PDT
Created attachment 655273 [details] [diff] [review]
Patch

This patch fixes the vertical scrollbar issue. I don't have a good solution for third-party vertical scrollbars, nested scrollbars, or horizontal scrollbars.

The vertical ones are much more prevalent though, and we should at least fix this first since it's pretty easy.
Comment 3 Jared Wein [:jaws] (please needinfo? me) 2012-08-24 22:47:46 PDT
I spun off the work for horizontal and third-party scrollbars to bug 785591.
Comment 4 Jared Wein [:jaws] (please needinfo? me) 2012-08-26 16:59:38 PDT
Created attachment 655473 [details] [diff] [review]
Patch v2

This patch uses margin instead of padding, which I think is more semantic for the purpose here.
Comment 5 Jared Wein [:jaws] (please needinfo? me) 2012-08-26 17:13:13 PDT
Created attachment 655475 [details] [diff] [review]
Patch for checkin
Comment 7 :Ms2ger (⌚ UTC+1/+2) 2012-08-27 01:59:57 PDT
https://hg.mozilla.org/mozilla-central/rev/469f4e91bb5d

Note You need to log in before you can comment on or make changes to this bug.