Last Comment Bug 786185 - Return "Send link" item to context menu.
: Return "Send link" item to context menu.
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: 17 Branch
: All All
: -- normal with 20 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jared Wein [:jaws] (please needinfo? me)
Mentors:
https://addons.mozilla.org/en-US/fire...
: 800565 804124 804424 805134 805949 (view as bug list)
Depends on:
Blocks: 239307
  Show dependency treegraph
 
Reported: 2012-08-28 02:02 PDT by Sergey
Modified: 2013-03-01 21:30 PST (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Sergey 2012-08-28 02:02:00 PDT
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120826030526

Steps to reproduce:

Opened context menu on a page.


Actual results:

Menu was displayed without "Send link" item.


Expected results:

"Send link" item should present in menu.
Comment 1 Cork 2012-08-28 02:30:59 PDT
Bug 239307 comment 8 and down specify why it was removed.
Comment 2 Sergey 2012-08-31 00:48:46 PDT
Considering message you addressed "Removing" is absolute inadequate measure :(
In context menu we always had all the set of properties and actions avail for current object. And send link/page is one of them. 
There should be another way to deal with problem rose of email client absence.

Going the way of Removing can lead to removing of Context menu as it exists now.
Back/Forw is duplicated in URL bar, Stop/Reload as well.
Bookmarks in Firefox button.
Looks like only the "View background image" is unique.

As a user with 15+ years browser usage I'm strongly disappointed with the way of removing.
Comment 3 f.smulders 2012-08-31 00:53:47 PDT
It sucks monkeyballs that you guys deleted the "send link"-option in the context-menu.
Please return it, at least via an "about:config"-option.
Comment 4 Browsing User 2012-10-10 11:18:54 PDT
As workaround I suggest this:
Email This! :: Add-ons for Firefox
https://addons.mozilla.org/en-us/firefox/addon/email-this/
Comment 5 Sergey 2012-10-10 22:04:54 PDT
I vote for old style.
Comment 6 Cork 2012-10-11 14:53:51 PDT
*** Bug 800565 has been marked as a duplicate of this bug. ***
Comment 7 Ed Hume 2012-10-11 18:55:35 PDT
The extension works, but adds another click to the process.

I suppose this is another example of adapting Firefox for mobile devices. You know: the tail wags the dog.
Comment 8 billrm 2012-10-15 11:01:48 PDT
So - trying to catch up with IE? find a way to fix it. I don't want to install another plugin for something that has been there for years.
Comment 9 Kevin Brosnan [:kbrosnan] 2012-10-20 02:32:28 PDT
*** Bug 803805 has been marked as a duplicate of this bug. ***
Comment 10 hamiglorr 2012-10-20 15:49:56 PDT
(In reply to billrm from comment #8)
> So - trying to catch up with IE? find a way to fix it. I don't want to
> install another plugin for something that has been there for years.

Agree!!
Comment 11 [:Aleksej] 2012-10-23 04:12:19 PDT
*** Bug 804124 has been marked as a duplicate of this bug. ***
Comment 12 [:Aleksej] 2012-10-23 04:14:50 PDT
*** Bug 804424 has been marked as a duplicate of this bug. ***
Comment 13 Loic 2012-10-24 15:22:25 PDT
*** Bug 805134 has been marked as a duplicate of this bug. ***
Comment 14 Loic 2012-10-24 16:19:32 PDT
*** Bug 805134 has been marked as a duplicate of this bug. ***
Comment 15 Alan hennessy 2012-10-24 18:24:18 PDT
Bring it back!!! It is the only thing on right click I ever used. Going to the menu is a pain in the ass.
Comment 16 forthurst 2012-10-25 07:51:15 PDT
The removal of 'Send Link' in the context menu has caused me a lot of timewasting, having to downgrade my browser to a prior version since 'Send link' as an INDISPENSIBLE feature of Firefox. There is NO satisfactory alternative to this neat feature. Of all the stuff that can be modified via config why at least is this not included? People not having an email client is the EXCEPTION which needs to be catered for if at all, not the norm. Does Mozilla want to encourage the use of Firefox or not? Does Mozilla want to encourage the use of Thunderbird or not?

I am a user of Firefox. However, I am also a 30 year professional systems developer and I would not dream of removing a system feature without discussion with users and permission from them which would only be sought if that feature was causing significant maintenance issues. Professionals have absolutely no idea how users use their systems in practice.
Comment 17 Mike 2012-10-25 11:51:24 PDT
I have to concur with others, the send link item is one of the principal reasons I like FF vs IE, Opera, and Chrome.  All of those other browsers are too simple, I've always thought of FF as more of a power users browser, and having the options and features is a big part of that.

Please bring this back, even if we do have to configure it ourselves.

Thanks
Comment 18 [:Aleksej] 2012-10-30 09:32:04 PDT
*** Bug 805949 has been marked as a duplicate of this bug. ***
Comment 19 hamiglorr 2012-11-01 12:17:29 PDT
I've submitted the following two feedback items to Firefox:

Sent to "Firefox Made Me Sad" at http://input.mozilla.org/en-US/feedback#sad:
You still haven't put "send link" back onto the right-click context menu - see bugs 239307, 786185, 800565, 803805, 804124, 804424, 805134, and 805949


Sent to "I Have an Idea for Firefox" at http://input.mozilla.org/en-US/feedback#idea:
Put "send link" back onto the right-click context menu - see bugs 239307, 786185, 800565, 803805, 804124, 804424, 805134, and 805949

Feel free to do the same - you're welcome to cut-and-paste the above messages.

Note You need to log in before you can comment on or make changes to this bug.