Closed Bug 786248 Opened 7 years ago Closed 7 years ago

Video is rendered upside-down at dailymotion.com on Honeycomb

Categories

(Firefox for Android Graveyard :: Plugins, defect, major)

ARM
Android
defect
Not set
major

Tracking

(firefox16+ verified, firefox17+ verified, firefox18 verified, fennec16+)

VERIFIED FIXED
Firefox 18
Tracking Status
firefox16 + verified
firefox17 + verified
firefox18 --- verified
fennec 16+ ---

People

(Reporter: AdrianT, Assigned: snorp)

References

Details

(Keywords: flashplayer)

Attachments

(3 files)

Nightly 18.0a1 2012-08-28
Device: Acer Iconia Tab A500 (Android 3.2)

Steps to reproduce:
1. Go to dailymotion.com
2. Play any video. 

Expected results:
The video starts playing and is correctly displayed.

Actual results:
Video is displayed upside-down

Note:
Please see the video-capture: http://youtu.be/yGAaVgcT3nQ

Issue is not reproducible on other devices tested: Samsung Note (Android 4.0.4), HTC Desire Z (Android 2.3.3)
Issue is also reproducible on Samsung Galaxy Tab running Android 3.1. Suspecting this to be a Honeycomb issue since these tablets have different GPU types.
Summary: Video is rendered upside-down at dailymotion.com on Acer Iconia Tab → Video is rendered upside-down at dailymotion.com on Honeycomb
Blocks: 767794
Blocks: 759945
tracking-fennec: --- → ?
Component: Plugins → Video/Audio
Product: Firefox for Android → Core
Version: Firefox 18 → 18 Branch
This is a Flash video.
Keywords: flashplayer
Sending over to Snorp. Given the tracking-firefox16 nomination from QA, I'm assuming that this also affects 16.
Assignee: nobody → snorp
tracking-fennec: ? → 16+
Component: Video/Audio → Plugins
Product: Core → Firefox for Android
Version: 18 Branch → Trunk
No longer blocks: 759945
mreavy, this bug is a Flash video bug, not H264. I don't think it needs to block bug 755364.
Flash has a way of telling us whether or not the content layer is vertically flipped ("inverted"). It doesn't have any such method for the video layer, so currently we just use the same value that we have for content. This apparently works fine on ICS, but on Honeycomb it looks like it always wants to be inverted, regardless of what value we have for the content layer. Not sure how this got by before, maybe something changed?
Comment on attachment 660411 [details] [diff] [review]
Always invert Flash video on Honeycomb

Review of attachment 660411 [details] [diff] [review]:
-----------------------------------------------------------------

add a comment saying that this change is essentially a guess and get QA lined up to test as many devices as possible after this lands
Attachment #660411 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/b0a40832407b
https://hg.mozilla.org/mozilla-central/rev/729ba40f9a14
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
QA Contact: nicolae.cristian
If low risk, please nominate this fix for Aurora/Beta approval as soon as possible.
Comment on attachment 660411 [details] [diff] [review]
Always invert Flash video on Honeycomb

[Approval Request Comment]
Fixes highly visible plugin bug. Fairly low risk, but would be good to get some testing as I only have one Honeycomb tablet here.
Attachment #660411 - Flags: approval-mozilla-beta?
Attachment #660411 - Flags: approval-mozilla-aurora?
Adding qawanted and verifyme to make sure we pay special attention to Flash video in the next aurora/beta releases.
Keywords: qawanted, verifyme
Attachment #660411 - Flags: approval-mozilla-beta?
Attachment #660411 - Flags: approval-mozilla-beta+
Attachment #660411 - Flags: approval-mozilla-aurora?
Attachment #660411 - Flags: approval-mozilla-aurora+
Attached image Nightly 09/17
The videos are playing as expected now on Honeycomb. However the video quality is poor and pixelated (see attached screenshot). On the stock browser, the image quality is fine.

While I was testing around this bug, 2 crashes occurred: Bug 791949 and Bug 791950.

Sometimes, if I scroll the page when the video starts playing, I see this: http://youtu.be/CEODwkKX0Ms

Also I noticed that sometimes, when I switch to a new video, instead of the expected video content, there is a green image, but the sound still works as expected.

Imo, we shouldn't uplift the patch to m-a and m-b because of all issues mentioned above.

--
Firefox 18.0a1 (2012-09-17)
Device: Galaxy Tab 10.1
OS: Android 3.1
(In reply to Cristian Nicolae (:xti) from comment #14)
> The videos are playing as expected now on Honeycomb. However the video
> quality is poor and pixelated (see attached screenshot). On the stock
> browser, the image quality is fine.

bug 778091

> While I was testing around this bug, 2 crashes occurred: Bug 791949 and Bug
> 791950.
> 
> Sometimes, if I scroll the page when the video starts playing, I see this:
> http://youtu.be/CEODwkKX0Ms
> 
> Also I noticed that sometimes, when I switch to a new video, instead of the
> expected video content, there is a green image, but the sound still works as
> expected.

New bugs.

> Imo, we shouldn't uplift the patch to m-a and m-b because of all issues
> mentioned above.

The patch fixed the original issue for this particular bug didn't it? Can you confirm that the issues you've outlined existed prior towards this landing?
(In reply to Aaron Train [:aaronmt] from comment #17)
> The patch fixed the original issue for this particular bug didn't it? Can
> you confirm that the issues you've outlined existed prior towards this
> landing?

All issues are reproducible on the Nightly from 09/12 since the image was displayed upside-down, so this bug seems to be fixed on the latest Nightly. Closing bug as verified fixed on:

Firefox 18.0a1 (2012-09-18)
Device: Galaxy Tab 10.1
OS: Android 3.1
Status: RESOLVED → VERIFIED
Keywords: qawanted, verifyme
Did this patch land on the latest Beta build? Because I can still reproduce it. 

The issue seems to be fixed on the latest Aurora.

--
Firefox 16.0b4 (2012-09-19)
Device: Galaxy Tab 10.1
OS: Android 3.1
(In reply to Cristian Nicolae (:xti) from comment #19)
> Did this patch land on the latest Beta build?
Yes. It's in 16.0b4: http://hg.mozilla.org/releases/mozilla-beta/graph
(In reply to Scoobidiver from comment #20)
> (In reply to Cristian Nicolae (:xti) from comment #19)
> > Did this patch land on the latest Beta build?
> Yes. It's in 16.0b4: http://hg.mozilla.org/releases/mozilla-beta/graph

Thank you. I double checked this issue on the latest Beta and it's still reproducible. Should I reopen this bug? Meanwhile I will set the firefox 16 flag as affected.
(In reply to Cristian Nicolae (:xti) from comment #21)
> (In reply to Scoobidiver from comment #20)
> > (In reply to Cristian Nicolae (:xti) from comment #19)
> > > Did this patch land on the latest Beta build?
> > Yes. It's in 16.0b4: http://hg.mozilla.org/releases/mozilla-beta/graph
> 
> Thank you. I double checked this issue on the latest Beta and it's still
> reproducible. Should I reopen this bug? Meanwhile I will set the firefox 16
> flag as affected.

What about a tinderbox beta build from today, such as http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-beta-android/1348213569/fennec-16.0.en-US.android-arm.apk ?
(In reply to Cristian Nicolae (:xti) from comment #21)
> (In reply to Scoobidiver from comment #20)
> > (In reply to Cristian Nicolae (:xti) from comment #19)
> > > Did this patch land on the latest Beta build?
> > Yes. It's in 16.0b4: http://hg.mozilla.org/releases/mozilla-beta/graph
> 
> Thank you. I double checked this issue on the latest Beta and it's still
> reproducible. Should I reopen this bug? Meanwhile I will set the firefox 16
> flag as affected.

16.0b4 won't be pushed to the Google Play store until later today.
(In reply to Aaron Train [:aaronmt] from comment #22)
> What about a tinderbox beta build from today, such as
> http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-beta-
> android/1348213569/fennec-16.0.en-US.android-arm.apk ?

I can reproduce this bug on the build that you mentioned and even on the latest tinderbox beta build (http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-beta-android/1348448665/)

--
Device: Galaxy Tab 10.1
OS: Android 3.1
We'd really like this investigated in preparation for a new FF16 uplift before tomorrow's b5 go to build.
So I assume we can still reproduce this problem on Nightly and Aurora too?
(In reply to Mark Finkle (:mfinkle) from comment #26)
> So I assume we can still reproduce this problem on Nightly and Aurora too?

Comment 18 and comment 19 make me think this is really fixed on Nightly and Aurora. So why wouldn't this be fixed on Beta?
(In reply to Mark Finkle (:mfinkle) from comment #27)
> So why wouldn't this be fixed on Beta?
Maybe a dependent patch (not identified) hasn't been uplifted to Beta.
Comment on attachment 664596 [details] [diff] [review]
Fix busted merge

[Approval Request Comment]
This actually fixes the bug on Beta
Attachment #664596 - Flags: review?(mark.finkle)
Attachment #664596 - Flags: approval-mozilla-beta?
Comment on attachment 664596 [details] [diff] [review]
Fix busted merge

Looks like the right merge
Attachment #664596 - Flags: review?(mark.finkle) → review+
Comment on attachment 664596 [details] [diff] [review]
Fix busted merge

[Triage Comment]
Approving assuming this is still a low risk patch - please land as soon as possible. Thanks!
Attachment #664596 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Now the video is displayed correctly on Beta. Marking Firefox 16 as verified.

--
Firefox 16.0b5 (2012-09-26)
Device: Galaxy Tab 10.1
OS: Android 3.1
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.