Show status messages above the toolbox

RESOLVED FIXED in Firefox 26

Status

RESOLVED FIXED
6 years ago
3 months ago

People

(Reporter: azakai, Unassigned)

Tracking

unspecified
Firefox 26

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by bug 821687)

(Reporter)

Description

6 years ago
1. Open the web console
2. Hover the mouse over a link in the page

The URL shown in the status area in the lower left will hide the web console input. You can type but you are effectively blind until you move the mouse.

Would be nice to have the status message with the URL be on the other side, which we do when the mouse is close to the status message. So this would mean doing that behavior also when the web console is open. Or at least when the web console is open + there is at least one letter written in the input field.
(Reporter)

Updated

6 years ago
OS: Linux → All
Hardware: x86 → All

Comment 1

6 years ago
I don't really have time to provide a patch… but this is how I would do it:

In browser/base/content/browser.css:

statuspanel:-moz-locale-dir(ltr)[mirror],
statuspanel:-moz-locale-dir(rtl):not([mirror]) {
   left: auto;
   right: 0;
}

I guess this is what control the position of the statusbar.

We should add a new selector: statuspanel[webconsole-open]

In browser/devtools/webconsole/HUDService.jsm, I guess we should call a `moveStatusBar()` function from `onTabSelect` and `positionConsole`.

`moveStatusBar()` would look like this:

function moveStatusBar() {
    var window = HUDService.currentContext();
    if (!window) {
      return;
    }
    let statusBar = window.XULBrowserWindow.statusTextField;
    let HUD = this.getOpenHUD();
    if (HUD && HUD._currentUIPosition == "below") {
      statusBar.setAttribute("webconsole-open", "true");
    } else {
      statusBar.removeAttribute("webconsole-open");
    }
}
let's just sign you up to mentor this since you've got some code to crib from.
Whiteboard: [good-first-bugs][lang=js][mentor=paul]
I don't see how this would be fixed based on comment 1 and I'd rather not unleash this to a new contributor before that's clear.
Whiteboard: [good-first-bugs][lang=js][mentor=paul]
Basically the problem is that the web console is within the anonymous <notificationbox> containing the current browser, whereas the status panel is outside of it because it doesn't belong to any particular browser.

Comment 5

6 years ago
(In reply to Dão Gottwald [:dao] from comment #4)
> Basically the problem is that the web console is within the anonymous
> <notificationbox> containing the current browser, whereas the status panel
> is outside of it because it doesn't belong to any particular browser.

Right. I guess the Toolbox implementation will solve that.
maybe this should be refiled into Firefox:General?

Updated

6 years ago
Depends on: 821687
Component: Developer Tools: Console → Developer Tools: Framework
Duplicate of this bug: 720186

Comment 8

5 years ago
This is annoying. How can we fix that? Maybe if the toolbox is present the statusbar should not be floating anymore (a solid bar right under the toolbox maybe). And because the statusbar is not per-tab, but at a higher level, we would need to change its state on tab switch.

Comment 9

5 years ago
Apparently, just changing margin-top move the status bar up:

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.css#535

So the idea would be to update margin top:
- on switch tab (is there a toolbox docked at the bottom?
- on toolbox resize
- on toolbox dock / undock

Updated

5 years ago
Summary: Show status messages in lower right when web console is open → Show status messages above the toolbox
(In reply to Paul Rouget [:paul] from comment #9)
> So the idea would be to update margin top:

That's basically the same as what attachment 754223 [details] [diff] [review] tried.
Duplicate of this bug: 912381

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: fixed by bug 821687
Target Milestone: --- → Firefox 26

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.