Status panel should be attached to the content area without overlapping surrounding chrome

VERIFIED FIXED in Firefox 25

Status

()

Firefox
General
VERIFIED FIXED
5 years ago
8 months ago

People

(Reporter: paul, Assigned: dao)

Tracking

(Depends on: 1 bug, {addon-compat, verifyme})

Trunk
Firefox 26
x86
All
addon-compat, verifyme
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox25 verified, firefox26 verified)

Details

(Whiteboard: regression from bug 541656)

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
We want the statusbar to be above the devtools box. That means moving the statusbar inside the tab. That would imply building one statusbar per tab.
(Reporter)

Comment 1

5 years ago
Dao, do you think it's something feasible?
(Assignee)

Comment 2

5 years ago
I don't think one status panel per tab this is very reasonable, given the global nature of the XULBrowserWindow infrastructure.
(Reporter)

Comment 3

5 years ago
Possible workaround: when the toolbox is present in the current tab, we translate (as is transform:translateY()) the statusbar.
Blocks: 720186
Created attachment 754223 [details] [diff] [review]
patch v0.1

Translating the statusbar. This is not the final version and a lot of cases are missed out. But asking for feedback to see if this approach is acceptable.
Assignee: nobody → scrapmachines
Status: NEW → ASSIGNED
Attachment #754223 - Flags: feedback?(dao)
(Assignee)

Comment 5

4 years ago
Comment on attachment 754223 [details] [diff] [review]
patch v0.1

I'd rather not have external code mess with the status panel's position. If multiple actors did that, things would quickly get messy, as you assume you're the only one setting a CSS transform on the status panel.
Attachment #754223 - Flags: feedback?(dao) → feedback-
So any suggestions here , anyone ?
See Also: → bug 885742
See Also: bug 885742
[this is out of my scope now :) ]
Assignee: scrapmachines → nobody
Status: ASSIGNED → NEW
Attachment #754223 - Attachment is obsolete: true
(Reporter)

Comment 8

4 years ago
(In reply to Dão Gottwald [:dao] from comment #5)
> Comment on attachment 754223 [details] [diff] [review]
> patch v0.1
> 
> I'd rather not have external code mess with the status panel's position. If
> multiple actors did that, things would quickly get messy, as you assume
> you're the only one setting a CSS transform on the status panel.

So any idea of what we can do to fix this issue?
(Assignee)

Updated

4 years ago
Blocks: 890613
(Assignee)

Updated

4 years ago
No longer blocks: 720186, 809898, 821512
QA Contact: developer.tools
Summary: Statusbar should be inside the tab (inside the notificationbox) → Status panel should be attached to the content area without overlapping chrome elements
(Assignee)

Comment 9

4 years ago
Created attachment 803704 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #803704 - Flags: review?(mdeboer)
(Assignee)

Updated

4 years ago
Summary: Status panel should be attached to the content area without overlapping chrome elements → Status panel should be attached to the content area without overlapping surrounding chrome
(Assignee)

Comment 10

4 years ago
Created attachment 803707 [details] [diff] [review]
patch

fixed a nit
Attachment #803704 - Attachment is obsolete: true
Attachment #803704 - Flags: review?(mdeboer)
Attachment #803707 - Flags: review?(mdeboer)
(Assignee)

Updated

4 years ago
Blocks: 914180
lgtm, I triggered a try build to see if this breaks any tests:

https://tbpl.mozilla.org/?tree=Try&rev=5acd3a1dbb8d

...which includes the backout patches from bug 914180.
Attachment #803707 - Flags: review?(mdeboer) → review+
Would it be a good idea to add a (regression) unit test for this?
(Assignee)

Comment 13

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/b47e5a0b7704

I have no idea how a useful test for this might look like...
(In reply to Dão Gottwald [:dao] from comment #13)
> I have no idea how a useful test for this might look like...

No idea either. I guess I just wanted to have it mentioned. ;)
https://hg.mozilla.org/mozilla-central/rev/b47e5a0b7704
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
(Assignee)

Updated

4 years ago
No longer blocks: 630079
Duplicate of this bug: 630079
(Assignee)

Updated

4 years ago
Blocks: 630079
Comment on attachment 803707 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 914180
User impact if declined: When the patch in bug 914180 lands on Aurora, the status panel will cover the findbar when it's open. This patch fixes that.
Testing completed (on m-c, etc.): one day on m-c, required for backout.
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #803707 - Flags: approval-mozilla-aurora?

Updated

4 years ago
Attachment #803707 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-aurora/rev/3c4300ef49de
status-firefox25: --- → fixed
status-firefox26: --- → fixed
Flags: in-testsuite-
Keywords: checkin-needed
Keywords: verifyme

Updated

4 years ago
Depends on: 919030
Created attachment 810538 [details]
Screenshot.png

On: XP 32-bit, Ubuntu 12.10 32-bit and Mac OS X 10.7.5 in 32-bit mode, with latest Aurora (build ID: 20130926004003) and 25 beta 2 (build ID: 20130923194050) I can see the status bar above the developer toolbox, in both scenarios:

1) when reloading a page
2) when hovering an URL from the page

Please see the attached screenshot for details. I'm assuming this is the discussed issue here, right?
Flags: needinfo?(paul)
(Reporter)

Comment 20

4 years ago
(In reply to Manuela Muntean [:Manuela] [QA] from comment #19)
> Created attachment 810538 [details]
> Screenshot.png
> 
> On: XP 32-bit, Ubuntu 12.10 32-bit and Mac OS X 10.7.5 in 32-bit mode, with
> latest Aurora (build ID: 20130926004003) and 25 beta 2 (build ID:
> 20130923194050) I can see the status bar above the developer toolbox, in
> both scenarios:
> 
> 1) when reloading a page
> 2) when hovering an URL from the page
> 
> Please see the attached screenshot for details. I'm assuming this is the
> discussed issue here, right?

Indeed. You see the valid behavior (status bar not hovering the tools).
Flags: needinfo?(paul)
Marking this verified, based on comment 19 and comment 20. Thanks Paul!
Status: RESOLVED → VERIFIED
status-firefox25: fixed → verified
status-firefox26: fixed → verified
Keywords: addon-compat
(Assignee)

Updated

4 years ago
No longer blocks: 817695

Updated

2 years ago
Depends on: 1240218

Updated

11 months ago
Blocks: 541656
Whiteboard: regression from bug 541656

Updated

11 months ago
Depends on: 920454

Updated

11 months ago
Duplicate of this bug: 802525

Updated

8 months ago
Depends on: 1325880
You need to log in before you can comment on or make changes to this bug.