Closed Bug 791624 Opened 7 years ago Closed 7 years ago

App button missing

Categories

(Thunderbird :: Theme, defect)

17 Branch
x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 790713

People

(Reporter: TheOne, Unassigned)

References

Details

The current earlybird builds show neither the menu bar nor an app button. To not completely confuse users, we should at least show one of them.
Was this with a new profile or one where TB 17 already was run? I tested it with a new profile and see the AppButton.
(In reply to Richard Marti [:Paenglab] from comment #1)
> Was this with a new profile or one where TB 17 already was run? I tested it
> with a new profile and see the AppButton.

After seeing this in my current profile (upgraded from 16), I tried with a fresh one and had the same behaviour.
Wait, are we talking about the toolbar button that shows just three lines, right beneath the gloda search box?

I'm talking about an app button like Firefox has in the title bar of a window.
Yes, this is the AppButton. Firefox will also change to this in a (hopefully) near future. TB is already there :)

The positive of TB's AppButton is, you can move and position it there you want.
Omg, imho this is a blocker. I'm a power user and it took me hours to even notice that there is a new button.
Average users won't notice or even click on it just out of curiosity.

We should somehow tell the user that this new button is there and what it's good for. Maybe mentioning it on the default mail start page (although I'm afraid this is not enough)?
Maybe overlay picture (on top of TB interface) on first run (like in Android apps) showing exactly what changed, where is new menu button placed, tabs on top etc...

I knew about this change so I didn't have trouble finding it, but I can understand other will have trouble. Also positioning menu button on right side of screen seams un-natural for me, but ok.
So, we have a patch in bug 791311 to re-enable the menu bar for existing users.  Can we agree that this is a duplicate of that bug?  I believe that new users will be more exploratory, and thus more likely to find the new menu button.

(As a side note, in that bug I mention that we might want the menu button on the left instead of the right…)

Thanks,
Blake.
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #7)
> I believe that new users will be more exploratory, and thus more likely to
> find the new menu button.

I have to disagree. Even if it's on the left, I doubt new users will just click it. They are unfamiliar with the whole interface and don't start just clicking on buttons without knowing what they (the buttons) do.

What about at least making a better, more noticeable icon? We could use the Thunderbird logo for that. I know that the current one is the one from the mockups, but hey, they are just mockups :)
But when the user is over the button a tooltip is shown with "Displays the Application Menu". Doesn't this help the user to notice for what the button is?
Well, we could now start a discussion about whether users point to buttons and wait for the tooltip to appear. I say they don't, but that's not the point.

Shouldn't we try to make a good icon that people grasp immediately instead of hoping they point to the button and read the tooltip?
hello
My personal experience
The menu bar is not activated at startup TB17
The menu bar is not visible with the extension ToolBarbuttons.
The menu bar is visible with ToolBarButton "bumpée"
Please enable this toolbar by default.
thank you

hello
My personal experience
The menu bar is not activated at startup TB17
The menu bar is not visible with the extension ToolBarbuttons.
The menu bar is visible with ToolBarButton "bumpée"
Please enable this toolbar by default.
thank you
(Google translation :-( )

***********************
bonjour
Mon experience personelle.
La barre de menus n'est pas activée au démarrage de TB17
La barre de menus n'est pas visible avec l'extension ToolBarbuttons.
La barre de menus est visible avec toolBarButton "bumpée"
SVP activer cette barre par défaut.
merci
(In reply to Andreas Wagner [:TheOne] from comment #10)
> Well, we could now start a discussion about whether users point to buttons
> and wait for the tooltip to appear. I say they don't, but that's not the
> point.
> 
> Shouldn't we try to make a good icon that people grasp immediately instead
> of hoping they point to the button and read the tooltip?

+1

I think the number of bmo users who commented that they'd like to have an iconic AppMenu in the top-left corner of Tab bar is currently on the increase...
Blocks: TB-AppMenu
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 790713
(In reply to Thomas D. from comment #12)
> (In reply to Andreas Wagner [:TheOne] from comment #10)
> I think the number of bmo users who commented that they'd like to have an
> iconic AppMenu in the top-left corner of Tab bar is currently on the
> increase...

Are any of those bmo users willing to do the work to make the version of the AppMenu look the way they want when it's in the top-left corner?

It's exceedingly unlikely that Mozilla will be funding anyone to do this work, so unless the people interested in this change can find some developers willing to make the change, I would suggest that the number of comments is fairly meaningless.  :(  (And if they can find people who will do the work, then the number of comments is also fairly meaningless…  ;)

For my part, to help this bug move forward, if someone can write a blog post detailing what they want in a positive manner (i.e. no "The new button sucks!"-type comments), hopefully with screenshots even, I would be happy to link to it from the Thunderbird UI Tumblr, which is how we got Paenglab to write the Australis theme in the first place…  No guarantees, of course, but it would give your best shot at convincing people a reasonably wide distribution.

Later,
Blake.
All I proposed was a more meaningful icon for the currently existing toolbar button. What about the Tb icon?
Ah, sorry about that.  I think sticking with the standard menu icon is a better idea, since nothing about the Thunderbird logo particularly says "Menu"…

Thanks,
Blake.
You need to log in before you can comment on or make changes to this bug.