Closed Bug 791775 Opened 7 years ago Closed 7 years ago

Update to Breakpad SVN r1047

Categories

(Toolkit :: Crash Reporting, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: ted, Assigned: ted)

References

Details

Attachments

(1 file, 1 obsolete file)

Our Breakpad snapshot is way out of date. The main reason for this is that we have a few large local patches that I never got upstream, so updating was hard. I spent most of last week rebasing those patches and getting them up for review, so now it's time to update.

Attached is just the changes to Mozilla code and makefiles necessary to sync up with Breakpad SVN. Probably the largest change in terms of code churn is that on Linux the ExceptionHandler class was changed to work with a "MindiumpDescriptor" which takes either a file path or a file descriptor instead of file paths directly. This ripples through the minidump callbacks etc.

The actual Breakpad update patch is pretty huge:
http://hg.mozilla.org/users/tmielczarek_mozilla.com/mq/file/fa7420f186bb/update-breakpad-r1039
563 files changed, 144662 insertions(+), 38985 deletions(-)

As per usual I'm not putting that patch up for review.

I haven't managed to fully upstream all of our patches yet, we still have three local patches, but they're all up for review upstream:
http://hg.mozilla.org/users/tmielczarek_mozilla.com/mq/file/fa7420f186bb/windows-dump-generation
http://hg.mozilla.org/users/tmielczarek_mozilla.com/mq/file/fa7420f186bb/linux-dump-generation
http://hg.mozilla.org/users/tmielczarek_mozilla.com/mq/file/fa7420f186bb/app-memory-win-lin

I'm hopeful that I might be able to get them all upstreamed before I land this.
Depends on: 792391
This patch contains the local fixes to build against Breakpad SVN r1044. I managed to upstream or get rid of all of our local patches.
Attachment #662523 - Flags: review?(mh+mozilla)
Attachment #661860 - Attachment is obsolete: true
Try push:
https://tbpl.mozilla.org/?tree=Try&rev=32a1f6c22385
Summary: Update to Breakpad SVN r1039 → Update to Breakpad SVN r1044
Comment on attachment 662523 [details] [diff] [review]
Fixup for updating to Breakpad SVN r1044

Review of attachment 662523 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/crashreporter/Makefile.in
@@ +69,5 @@
>  # NDK5 workarounds
>  DEFINES += -D_STLP_CONST_CONSTRUCTOR_BUG -D_STLP_NO_MEMBER_TEMPLATES
> +LOCAL_INCLUDES = \
> +  -I$(topsrcdir)/toolkit/crashreporter/google-breakpad/src/common/android/include/ \
> +  $(NULL)

Why not use TARGET_LOCAL_INCLUDES here, too?
Note bug 792685 would be handy with these definitions.
Attachment #662523 - Flags: review?(mh+mozilla) → review+
Followup try push to fix a Linux debug issue, all green here:
https://tbpl.mozilla.org/?tree=Try&rev=8a4f84cc4ff8

The only other issue on my try push was a hang on test_crash_oom.js on Windows debug, I've got some details on that in bug 733501.
(In reply to Mike Hommey [:glandium] from comment #4)
> Why not use TARGET_LOCAL_INCLUDES here, too?
> Note bug 792685 would be handy with these definitions.

Probably just laziness, since we're not building host code here. I'll change that.
Blocks: 792850
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/c1e97e2838a7 for WinXP M3 hangs in test_hanging.xul and shutdown hangs, WinXP Moth hangs in test_busy_hang.xul (and maybe test_npruntime.xul, not sure if those were you), and suspicion that this was the cause of the lack of stack in https://tbpl.mozilla.org/php/getParsedLog.php?id=15389127&tree=Mozilla-Inbound
And once my retrigger finally ran, an M3 timeout in test_newstreamondestroy.html.
Blocks: 779291
Ugh, I made a really stupid error while updating and landing one of our local patches. I wrote a test app and could reproduce the failure we were getting on Windows XP. I landed a fix upstream:
http://code.google.com/p/google-breakpad/source/detail?r=1047

I'm going to push this to try again for WinXP tests to sanity-check, but I'm almost 100% sure that was the issue.
Summary: Update to Breakpad SVN r1044 → Update to Breakpad SVN r1047
The Try run was all-green (including the few WinXP test-runs that philor re-triggered), so I re-landed this:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c54522d3e3f4
Followup fix because I lost that 1-line fix that fixed Linux debug builds:
https://hg.mozilla.org/integration/mozilla-inbound/rev/eae123c9c884
Depends on: 794122
https://hg.mozilla.org/mozilla-central/rev/c54522d3e3f4
https://hg.mozilla.org/mozilla-central/rev/eae123c9c884
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Blocks: 729714
Blocks: 693451
Duplicate of this bug: 603683
Regressions: 1542581
You need to log in before you can comment on or make changes to this bug.