The default bug view has changed. See this FAQ.

No special icon for secure connection in folder pane on linux

VERIFIED FIXED in Thunderbird 19.0

Status

Thunderbird
Folder and Message Lists
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Martin Schuster, Assigned: andreasn)

Tracking

17 Branch
Thunderbird 19.0
x86_64
Linux
Bug Flags:
in-testsuite -

Thunderbird Tracking Flags

(thunderbird17+ fixed, thunderbird18 fixed)

Details

(Whiteboard: duptome)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 662524 [details]
Screenshot of secure icon on Mac

I've set up an IMAP/SSL connection. This should result in a "secure connection" icon in the folder pane (like in the first attachment, screenshot by Ludovic Hirlimann), but doesn't (see second attachment)

TB 17.0a2 running on RHEL5/x86-64

Mozilla/5.0 (X11; Linux i686 on x86_64; rv:17.0) Gecko/17.0 Thunderbird/17.0a2
ID:20120918042014
(Reporter)

Comment 1

5 years ago
Created attachment 662525 [details]
Screenshot of no secure icon on Linux
(Reporter)

Updated

5 years ago
Blocks: 789883

Comment 2

5 years ago
Works for me on Win7.
Is there any other linux user which could confirm the issue on Linux?
(Reporter)

Comment 3

5 years ago
I tried this on a completely different machine (running Debian wheezy, LXDE) and another IMAP-server (running on localhost), still no special icon. I've restarted TB, and also made sure that SSL is used:

$ netstat -tpn | grep thunder
tcp6       0      0 ::1:33802               ::1:993                 ESTABLISHED 9521/thunderbird
tcp6       0      0 ::1:33803               ::1:993                 ESTABLISHED 9521/thunderbird
(Reporter)

Comment 4

5 years ago
Could someone tell me the filename of the icon that's supposed to show up?

I just tried to start TB via strace,
$ strace -efile -o st.log -f -a 60 ./thunderbird
and then looked for the missing icon,
$ grep ENOENT st.log | grep -i icon | egrep -i '(secu|ssl|enc|lock|prot)'
but nothing came up.
Andreas can you confirm ?
(Assignee)

Comment 6

5 years ago
Yes, if I recall correctly we don't have a specific security folder on Linux. Taking a step back, what function does the icon serve exactly and is a tiny padlock the best way to indicate the security of an account? Are there other ways we can indicate this?

Comment 7

5 years ago
as Firefox also use a padlock for secure website, it makes sens to use the same convention.
(Assignee)

Comment 8

5 years ago
This is also the case on Windows it seems and the graphics is pretty much there already, so patch coming shortly.
tracking-thunderbird17: --- → +
next step is bug 448723 :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: No special icon for secure connection in folder pane → No special icon for secure connection in folder pane on linux
(In reply to Andreas Nilsson (:andreasn) from comment #8)
> This is also the case on Windows it seems and the graphics is pretty much
> there already, so patch coming shortly.

I'm going to assign you to this so you don't forget :-)
Assignee: nobody → nisses.mail
(Assignee)

Comment 11

5 years ago
:)
(Assignee)

Comment 12

5 years ago
Created attachment 669223 [details] [diff] [review]
patch to fix the issue
(Assignee)

Comment 13

5 years ago
Created attachment 669227 [details] [diff] [review]
patch to fix the issue (v2)
Attachment #669223 - Attachment is obsolete: true
Attachment #669227 - Flags: ui-review?(richard.marti)
Attachment #669227 - Flags: review?(mconley)
Comment on attachment 669227 [details] [diff] [review]
patch to fix the issue (v2)

This looks good.

Only one note
Why add new icons on folder-pane.png when they already exist in server.png? I know they are looking different but you could update this file and change the rules to this file. For me it would be make more sense when the rule is: [IsServer="true"] then use server.png, like it's already for nntp.

This is only my opinion and the patch is doing what it should, so ui-r+
Attachment #669227 - Flags: ui-review?(richard.marti) → ui-review+
Comment on attachment 669227 [details] [diff] [review]
patch to fix the issue (v2)

Review of attachment 669227 [details] [diff] [review]:
-----------------------------------------------------------------

Code looks good. Thanks Andreas!
Attachment #669227 - Flags: review?(mconley) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/81c5757e2e54
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 19.0
Whiteboard: duptome
Comment on attachment 669227 [details] [diff] [review]
patch to fix the issue (v2)

[Triage Comment]
We should take this forward to 17, as it is an issue there currently.
Attachment #669227 - Flags: approval-comm-beta+
Attachment #669227 - Flags: approval-comm-aurora+

Comment 18

5 years ago
Before you land this on TB17, please check this out:
For me on TB19 (trunk) all mail account icons changed to the new icon with lock. All my accounts are NOT secure: Connection security = None, Authentication = Password, transmitted insecurely.

Comment 19

5 years ago
Please tell me what to test to determine if the problem is in the patch on my profile.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 20

5 years ago
... or my profile.
(Assignee)

Comment 21

5 years ago
Switching the security from SSH/SSL to None does indeed not change the icon, so I think you're right.
Does this work as expected on Windows and OSX?
On Win7 this changes the icon.

Comment 23

5 years ago
Yes, it works for me fine on Win XP (TB trunk).
Comment on attachment 669227 [details] [diff] [review]
patch to fix the issue (v2)

Removing approvals until we get this fixed. I would like to get it fixed asap so that it'll work properly in TB 17.
Attachment #669227 - Flags: approval-comm-beta-
Attachment #669227 - Flags: approval-comm-beta+
Attachment #669227 - Flags: approval-comm-aurora-
Attachment #669227 - Flags: approval-comm-aurora+
Created attachment 675153 [details] [diff] [review]
Fix the issue

This patch fixes the issue there also insecure connections are shown as secure.
Attachment #675153 - Flags: review?(mconley)
Comment on attachment 675153 [details] [diff] [review]
Fix the issue

Yes, this is right, thank you!
Attachment #675153 - Flags: review?(mconley) → review+
Keywords: checkin-needed
Comment on attachment 675153 [details] [diff] [review]
Fix the issue

[Approval Request Comment]
Regarding comment 24 the patch and this fix are desired for TB 17
Attachment #675153 - Flags: approval-comm-beta?
Attachment #675153 - Flags: approval-comm-aurora?
https://hg.mozilla.org/comm-central/rev/b738597de59f

(Assuming this gets branch approval, I can qfold these two patches into one for checkin)
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Comment on attachment 669227 [details] [diff] [review]
patch to fix the issue (v2)

a=me for both patches now that the issue is fixed.
Attachment #669227 - Flags: approval-comm-beta-
Attachment #669227 - Flags: approval-comm-beta+
Attachment #669227 - Flags: approval-comm-aurora-
Attachment #669227 - Flags: approval-comm-aurora+
Attachment #675153 - Flags: approval-comm-beta?
Attachment #675153 - Flags: approval-comm-beta+
Attachment #675153 - Flags: approval-comm-aurora?
Attachment #675153 - Flags: approval-comm-aurora+

Comment 30

5 years ago
Confirming this works correctly on Linux in todays trunk.
Status: RESOLVED → VERIFIED
https://hg.mozilla.org/releases/comm-aurora/rev/538400c8b97d
https://hg.mozilla.org/releases/comm-aurora/rev/a8c4624b6a1d
https://hg.mozilla.org/releases/comm-beta/rev/ea9fc6bc25ab
https://hg.mozilla.org/releases/comm-beta/rev/a8fbe8ea2566
status-thunderbird17: --- → fixed
status-thunderbird18: --- → fixed
You need to log in before you can comment on or make changes to this bug.