Closed Bug 795972 Opened 7 years ago Closed 7 years ago

Upgrade NSS to 3.14 BETA1

Categories

(Core :: Security: PSM, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: briansmith, Assigned: briansmith)

References

Details

(Keywords: APIchange, compat)

NSS 3.14 is needed for WebRTC support.

NSS 3.14 contains a change wherein all MD5 signatures will fail to validate by default. This may affect Thunderbird and Firefox because the it may cause security.enable_md5_signatures=true to stop working.
OS: Windows 7 → All
Priority: -- → P1
Hardware: x86_64 → All
Target Milestone: --- → mozilla18
https://hg.mozilla.org/mozilla-central/rev/699db88b5ea0

Some NSS files were moved and others were refactored. Also, the MPL 2.0 transition was done in this version, so the patch is massive.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Blocks: 802365
You need to log in before you can comment on or make changes to this bug.