Last Comment Bug 797296 - B2G STK: write marionette tests for STK proactive commands
: B2G STK: write marionette tests for STK proactive commands
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla22
Assigned To: John Shih
:
Mentors:
Depends on: 809284 847256
Blocks: b2g-stk 843455
  Show dependency treegraph
 
Reported: 2012-10-03 02:19 PDT by Hsin-Yi Tsai [:hsinyi]
Modified: 2013-03-13 05:36 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part 1: Test STK Refresh. (1.90 KB, patch)
2013-02-03 21:34 PST, John Shih
allstars.chh: review-
Details | Diff | Review
Part 2: Test STK Poll Off. (1.76 KB, patch)
2013-02-03 21:34 PST, John Shih
no flags Details | Diff | Review
Part 3: Test STK Setup Event List. (2.59 KB, patch)
2013-02-03 21:35 PST, John Shih
no flags Details | Diff | Review
Part 4: Test STK Setup Call. (13.13 KB, patch)
2013-02-03 21:35 PST, John Shih
no flags Details | Diff | Review
Part 5: Test STK Send SS. (10.91 KB, patch)
2013-02-03 21:36 PST, John Shih
no flags Details | Diff | Review
Part 6: Test STK Send USSD. (14.37 KB, patch)
2013-02-03 21:36 PST, John Shih
no flags Details | Diff | Review
Part 7: Test STK Send SMS. (13.78 KB, patch)
2013-02-03 21:37 PST, John Shih
no flags Details | Diff | Review
Part 8: Test STK Send DTMF. (8.74 KB, patch)
2013-02-03 21:37 PST, John Shih
no flags Details | Diff | Review
Part 9: Test STK Launch Browser. (9.61 KB, patch)
2013-02-03 21:37 PST, John Shih
no flags Details | Diff | Review
Part 10: Test STK Display Text. (3.93 KB, patch)
2013-02-03 21:38 PST, John Shih
no flags Details | Diff | Review
Part 11: Test STK Get Inkey. (4.93 KB, patch)
2013-02-03 21:38 PST, John Shih
no flags Details | Diff | Review
Part 12: Test STK Get Input. (7.95 KB, patch)
2013-02-03 21:38 PST, John Shih
no flags Details | Diff | Review
Part 13: Test STK Select Item. (17.25 KB, patch)
2013-02-03 21:39 PST, John Shih
no flags Details | Diff | Review
Part 14: Test STK Setup Menu. (13.04 KB, patch)
2013-02-03 21:39 PST, John Shih
no flags Details | Diff | Review
Part 15: Test STK Setup Idle Mode Text. (10.61 KB, patch)
2013-02-03 21:40 PST, John Shih
no flags Details | Diff | Review
Part 1: Test STK Refresh. (2.21 KB, patch)
2013-02-04 00:45 PST, John Shih
allstars.chh: review-
Details | Diff | Review
Part 1: Test STK Refresh. (2.22 KB, patch)
2013-02-04 01:10 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 2: Test STK Poll Off. (2.11 KB, patch)
2013-02-04 01:16 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 1: Test STK Refresh. (2.27 KB, patch)
2013-02-06 23:56 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 2: Test STK Poll Off. (2.15 KB, patch)
2013-02-07 00:05 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 3: Test STK Setup Event List. (3.05 KB, patch)
2013-02-07 00:15 PST, John Shih
no flags Details | Diff | Review
Part 4: Test STK Setup Call. (14.09 KB, patch)
2013-02-07 00:31 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 4: Test STK Setup Call. (14.07 KB, patch)
2013-02-07 01:35 PST, John Shih
no flags Details | Diff | Review
Part 4: Test STK Setup Call. (14.02 KB, patch)
2013-02-07 01:38 PST, John Shih
no flags Details | Diff | Review
Part 4: Test STK Setup Call. (14.01 KB, patch)
2013-02-07 01:39 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 3: Test STK Setup Event List. (3.32 KB, patch)
2013-02-07 19:08 PST, John Shih
no flags Details | Diff | Review
Part 3: Test STK Setup Event List. (3.30 KB, patch)
2013-02-07 19:11 PST, John Shih
no flags Details | Diff | Review
Part 3: Test STK Setup Event List. (3.30 KB, patch)
2013-02-07 19:13 PST, John Shih
no flags Details | Diff | Review
Part 5: Test STK Send SS. (11.59 KB, patch)
2013-02-07 19:16 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 6: Test STK Send USSD. (14.75 KB, patch)
2013-02-07 19:17 PST, John Shih
no flags Details | Diff | Review
Part 6: Test STK Send USSD. (14.74 KB, patch)
2013-02-07 19:19 PST, John Shih
no flags Details | Diff | Review
Part 7: Test STK Send SMS. (14.55 KB, patch)
2013-02-07 19:40 PST, John Shih
no flags Details | Diff | Review
Part 7: Test STK Send SMS. (14.55 KB, patch)
2013-02-07 19:41 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 6: Test STK Send USSD. (14.74 KB, patch)
2013-02-07 19:43 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 8: Test STK Send DTMF. (9.48 KB, patch)
2013-02-07 20:05 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 9: Test STK Launch Browser (10.58 KB, patch)
2013-02-07 22:35 PST, John Shih
no flags Details | Diff | Review
Part 10: Test STK Display Text. (4.53 KB, patch)
2013-02-07 22:42 PST, John Shih
no flags Details | Diff | Review
Part 11: Test STK Get Inkey. (5.57 KB, patch)
2013-02-07 22:53 PST, John Shih
no flags Details | Diff | Review
Part 9: Test STK Launch Browser (10.56 KB, patch)
2013-02-07 22:59 PST, John Shih
no flags Details | Diff | Review
Part 12: Test STK Get Input. (8.54 KB, patch)
2013-02-07 23:10 PST, John Shih
no flags Details | Diff | Review
Part 13: Test STK Select Item. (18.45 KB, patch)
2013-02-07 23:23 PST, John Shih
no flags Details | Diff | Review
Part 14: Test STK Setup Menu. (14.11 KB, patch)
2013-02-07 23:43 PST, John Shih
no flags Details | Diff | Review
Part 15: Test STK Setup Idle Mode Text. (11.18 KB, patch)
2013-02-08 00:05 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 10: Test STK Display Text. (5.00 KB, patch)
2013-02-08 00:39 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 9: Test STK Launch Browser (11.45 KB, patch)
2013-02-08 00:52 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 3: Test STK Setup Event List. (3.33 KB, patch)
2013-02-18 21:50 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 11: Test STK Get Inkey. (6.09 KB, patch)
2013-02-18 22:04 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 12: Test STK Get Input. (9.22 KB, patch)
2013-02-18 22:13 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 13: Test STK Select Item. (23.69 KB, patch)
2013-02-18 22:50 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 14: Test STK Setup Menu. (17.49 KB, patch)
2013-02-18 23:07 PST, John Shih
allstars.chh: review+
Details | Diff | Review
Part 3: Test STK Setup Event List. (3.33 KB, patch)
2013-02-18 23:11 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 4: Test STK Setup Call. (14.01 KB, patch)
2013-02-18 23:13 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 5: Test STK Send SS. (11.59 KB, patch)
2013-02-18 23:14 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 6: Test STK Send USSD. (14.74 KB, patch)
2013-02-18 23:16 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 7: Test STK Send SMS. (14.55 KB, patch)
2013-02-18 23:18 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 8: Test STK Send DTMF. (9.48 KB, patch)
2013-02-18 23:20 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 3: Test STK Setup Event List. (3.33 KB, patch)
2013-02-18 23:26 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 11: Test STK Get Inkey. (6.10 KB, patch)
2013-02-18 23:29 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 11: Test STK Get Inkey. (6.09 KB, patch)
2013-02-18 23:30 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 13: Test STK Select Item. (23.69 KB, patch)
2013-02-18 23:33 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 14: Test STK Setup Menu. (17.49 KB, patch)
2013-02-18 23:36 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review
Part 7: Test STK Send SMS. (14.55 KB, patch)
2013-02-18 23:44 PST, John Shih
johnshih.bugs: review+
Details | Diff | Review

Description Hsin-Yi Tsai [:hsinyi] 2012-10-03 02:19:37 PDT
We should have high-level API tests for STK features, such as sending STK responses and sending STK menu selection. Even more, setting up a call by STK or setting up an event list.
Comment 1 Yoshi Huang[:allstars.chh] 2012-11-15 02:54:33 PST
CCing Al
As Bug 809294 supports STK proactive command.

This bug should include following STK features:
- send STK response.
- send STK envelope and envelope with status
- send "REPORT_STK_SERVICE_IS_RUNNGING'
- set/get STK Profile
- send 'session end' from icc

The remaining requests are more complicated
- call setup
- RIL_REQUEST_STK_HANDLE_CALL_SETUP_REQUESTED_FROM_SIM
Comment 2 Vicamo Yang [:vicamo][:vyang] 2012-11-15 20:53:20 PST
(In reply to Yoshi Huang[:yoshi][:allstars.chh] from comment #1)
> As Bug 809294 supports STK proactive command.

wrong bug id?
Comment 3 John Shih 2013-02-03 21:34:06 PST
Created attachment 709568 [details] [diff] [review]
Part 1: Test STK Refresh.
Comment 4 John Shih 2013-02-03 21:34:58 PST
Created attachment 709569 [details] [diff] [review]
Part 2: Test STK Poll Off.
Comment 5 John Shih 2013-02-03 21:35:29 PST
Created attachment 709570 [details] [diff] [review]
Part 3: Test STK Setup Event List.
Comment 6 John Shih 2013-02-03 21:35:53 PST
Created attachment 709571 [details] [diff] [review]
Part 4: Test STK Setup Call.
Comment 7 John Shih 2013-02-03 21:36:16 PST
Created attachment 709572 [details] [diff] [review]
Part 5: Test STK Send SS.
Comment 8 John Shih 2013-02-03 21:36:41 PST
Created attachment 709573 [details] [diff] [review]
Part 6: Test STK Send USSD.
Comment 9 John Shih 2013-02-03 21:37:03 PST
Created attachment 709574 [details] [diff] [review]
Part 7: Test STK Send SMS.
Comment 10 John Shih 2013-02-03 21:37:26 PST
Created attachment 709575 [details] [diff] [review]
Part 8: Test STK Send DTMF.
Comment 11 John Shih 2013-02-03 21:37:47 PST
Created attachment 709576 [details] [diff] [review]
Part 9: Test STK Launch Browser.
Comment 12 John Shih 2013-02-03 21:38:10 PST
Created attachment 709577 [details] [diff] [review]
Part 10: Test STK Display Text.
Comment 13 John Shih 2013-02-03 21:38:33 PST
Created attachment 709578 [details] [diff] [review]
Part 11: Test STK Get Inkey.
Comment 14 John Shih 2013-02-03 21:38:53 PST
Created attachment 709579 [details] [diff] [review]
Part 12: Test STK Get Input.
Comment 15 John Shih 2013-02-03 21:39:13 PST
Created attachment 709580 [details] [diff] [review]
Part 13: Test STK Select Item.
Comment 16 John Shih 2013-02-03 21:39:35 PST
Created attachment 709581 [details] [diff] [review]
Part 14: Test STK Setup Menu.
Comment 17 John Shih 2013-02-03 21:40:32 PST
Created attachment 709582 [details] [diff] [review]
Part 15: Test STK Setup Idle Mode Text.
Comment 18 Yoshi Huang[:allstars.chh] 2013-02-03 21:59:53 PST
Comment on attachment 709568 [details] [diff] [review]
Part 1: Test STK Refresh.

Please update the description for that patch, i.e. "Part 1: Test STK Refresh".
And you should send r? to me, allstars.chh@mozilla.

And in the bug title, please use Capital case, 
i.e.
"Bug 797296 - Part 1: Test STK Refresh"
Comment 19 Yoshi Huang[:allstars.chh] 2013-02-03 22:06:00 PST
Comment on attachment 709568 [details] [diff] [review]
Part 1: Test STK Refresh.

Review of attachment 709568 [details] [diff] [review]:
-----------------------------------------------------------------

I think you also need to update the manifest.ini as well.

::: dom/icc/tests/marionette/test_stk_refresh.js
@@ +7,5 @@
> +
> +let icc = navigator.mozMobileConnection.icc;
> +ok(icc instanceof MozIccManager, "icc is instanceof " + icc.constructor);
> +
> +function testRefresh(cmd, exp) {

Is exp short for 'expect' ?
'exp' is too ambitious please use a better name here.

@@ +16,5 @@
> +  runNextTest();
> +}
> +
> +let tests = [
> +  

nit, extra line.

@@ +19,5 @@
> +let tests = [
> +  
> +  {command: "d0108103010101820281829205013f002fe2",
> +   func: testRefresh,
> +   exp: {name: "pull_off_112",

Why the name is pull off here?
I though this test is for Refresh.

And what does 112 mean here?

@@ +23,5 @@
> +   exp: {name: "pull_off_112",
> +         commandQualifier: 0x01}},
> +  {command: "d009810301010482028182",
> +   func: testRefresh,
> +   exp: {name: "pull_off_151",

same here.
Comment 20 Yoshi Huang[:allstars.chh] 2013-02-03 22:06:46 PST
Since John is working on this, assign this bug to him.
Comment 21 Yoshi Huang[:allstars.chh] 2013-02-03 22:57:50 PST
I'll file another bug for other STK features mentioned in comment 1.
Comment 22 Yoshi Huang[:allstars.chh] 2013-02-04 00:02:31 PST
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #2)
> (In reply to Yoshi Huang[:yoshi][:allstars.chh] from comment #1)
> > As Bug 809294 supports STK proactive command.
> 
> wrong bug id?

Sorry I notice this until now, the bug should be 809284.
Comment 23 Yoshi Huang[:allstars.chh] 2013-02-04 00:20:44 PST
I suggest you finish Part 1 first otherwise you need to do the same thing for all your patches.
Comment 24 Yoshi Huang[:allstars.chh] 2013-02-04 00:25:17 PST
Comment on attachment 709568 [details] [diff] [review]
Part 1: Test STK Refresh.

Review of attachment 709568 [details] [diff] [review]:
-----------------------------------------------------------------

Please address my previous comments first before sending r?
Comment 25 Yoshi Huang[:allstars.chh] 2013-02-04 00:29:35 PST
These patches share some code for sending STK PDU. When Bug 805838 is landed, we could reuse those code instead of repeating it in each test script.
Comment 26 John Shih 2013-02-04 00:38:38 PST
(In reply to Yoshi Huang[:yoshi][:allstars.chh] from comment #19)
> Comment on attachment 709568 [details] [diff] [review]
> Part 1: Test STK Refresh.
> 
> Review of attachment 709568 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I think you also need to update the manifest.ini as well.
> 
> ::: dom/icc/tests/marionette/test_stk_refresh.js
> @@ +7,5 @@
> > +
> > +let icc = navigator.mozMobileConnection.icc;
> > +ok(icc instanceof MozIccManager, "icc is instanceof " + icc.constructor);
> > +
> > +function testRefresh(cmd, exp) {
> 
> Is exp short for 'expect' ?
> 'exp' is too ambitious please use a better name here.
> 
> @@ +16,5 @@
> > +  runNextTest();
> > +}
> > +
> > +let tests = [
> > +  
> 
> nit, extra line.
> 
> @@ +19,5 @@
> > +let tests = [
> > +  
> > +  {command: "d0108103010101820281829205013f002fe2",
> > +   func: testRefresh,
> > +   exp: {name: "pull_off_112",
> 
> Why the name is pull off here?
> I though this test is for Refresh.
> 
> And what does 112 mean here?

I just followed the naming in the existing test cases (test-stkutil.c)
so I'm not sure what the correct naming/number for each event. 

> 
> @@ +23,5 @@
> > +   exp: {name: "pull_off_112",
> > +         commandQualifier: 0x01}},
> > +  {command: "d009810301010482028182",
> > +   func: testRefresh,
> > +   exp: {name: "pull_off_151",
> 
> same here.
Comment 27 John Shih 2013-02-04 00:45:53 PST
Created attachment 709626 [details] [diff] [review]
Part 1: Test STK Refresh.
Comment 28 Yoshi Huang[:allstars.chh] 2013-02-04 00:47:20 PST
(In reply to John Shih from comment #26)
> 
> I just followed the naming in the existing test cases (test-stkutil.c)
> so I'm not sure what the correct naming/number for each event. 
> 

Seems it's just a name for the test, can you rename it to simpler or meaningful one?
Comment 29 John Shih 2013-02-04 00:52:43 PST
(In reply to Yoshi Huang[:yoshi][:allstars.chh] from comment #28)
> (In reply to John Shih from comment #26)
> > 
> > I just followed the naming in the existing test cases (test-stkutil.c)
> > so I'm not sure what the correct naming/number for each event. 
> > 
> 
> Seems it's just a name for the test, can you rename it to simpler or
> meaningful one?

So can I just order by number (e.g, xxx_1. xxx_2, xxx_3 ...) ?
Comment 30 Yoshi Huang[:allstars.chh] 2013-02-04 00:52:45 PST
Comment on attachment 709626 [details] [diff] [review]
Part 1: Test STK Refresh.

Review of attachment 709626 [details] [diff] [review]:
-----------------------------------------------------------------

Please address comment 18 and comment 19 first before sending r?
This is for the second time I said this.
Comment 31 Yoshi Huang[:allstars.chh] 2013-02-04 00:59:19 PST
(In reply to John Shih from comment #29)
> So can I just order by number (e.g, xxx_1. xxx_2, xxx_3 ...) ?
Sound okay.
Please do this.
Comment 32 Yoshi Huang[:allstars.chh] 2013-02-04 01:00:45 PST
Comment on attachment 709626 [details] [diff] [review]
Part 1: Test STK Refresh.

Review of attachment 709626 [details] [diff] [review]:
-----------------------------------------------------------------

Please address comment 18 and comment 19 first before sending r?
This is for the second time I said this.

::: dom/icc/tests/marionette/test_stk_refresh.js
@@ +10,5 @@
> +
> +function testRefresh(cmd, expect) {
> +  log("STK CMD " + JSON.stringify(cmd));
> +  is(cmd.typeOfCommand, icc.STK_CMD_REFRESH, expect.name);
> +  is(cmd.commandQualifier, exp.commandQualifier, expect.name);

TEST-UNEXPECTED-FAIL | test_stk_refresh.js | JavascriptException: ReferenceError: exp is not defined.

Please make sure you run the tests before sending r?
Comment 33 John Shih 2013-02-04 01:10:08 PST
Created attachment 709630 [details] [diff] [review]
Part 1: Test STK Refresh.

I've changed the naming to xxx_cmd_# and fixed the typo
but sadly I cannot pass this case

got
 
raise ScriptTimeoutException(message=message, status=status, stacktrace=stacktrace)
TEST-UNEXPECTED-FAIL | test_stk_refresh.js | ScriptTimeoutException: timed out
Comment 34 John Shih 2013-02-04 01:16:57 PST
Created attachment 709634 [details] [diff] [review]
Part 2: Test STK Poll Off.
Comment 35 John Shih 2013-02-04 01:18:47 PST
Comment on attachment 709634 [details] [diff] [review]
Part 2: Test STK Poll Off.

Since I can't pass STK Refresh, please review this one first
thanks
Comment 36 Yoshi Huang[:allstars.chh] 2013-02-04 01:40:48 PST
Comment on attachment 709630 [details] [diff] [review]
Part 1: Test STK Refresh.

Review of attachment 709630 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_refresh.js
@@ +19,5 @@
> +let tests = [
> +  {command: "d0108103010101820281829205013f002fe2",
> +   func: testRefresh,
> +   expect: {name: "refresh_cmd_1",
> +         commandQualifier: 0x01}},

nit, align this line.

@@ +23,5 @@
> +         commandQualifier: 0x01}},
> +  {command: "d009810301010482028182",
> +   func: testRefresh,
> +   expect: {name: "refresh_cmd_2",
> +         commandQualifier: 0x04}}

ditto
Comment 37 Yoshi Huang[:allstars.chh] 2013-02-04 01:52:51 PST
Comment on attachment 709634 [details] [diff] [review]
Part 2: Test STK Poll Off.

Review of attachment 709634 [details] [diff] [review]:
-----------------------------------------------------------------

This patch is much better now.

Please update bug comment, "Bug 797296", not "bug 797296"
There's a rule for this.
https://developer.mozilla.org/en-US/docs/Developer_Guide/Committing_Rules_and_Responsibilities

Please address nits below, and add r=me.

thanks

::: dom/icc/tests/marionette/test_stk_poll_off.js
@@ +7,5 @@
> +
> +let icc = navigator.mozMobileConnection.icc;
> +ok(icc instanceof MozIccManager, "icc is instanceof " + icc.constructor);
> +
> +function testPollOff(cmd, expect) {

For consistency, please rename cmd to command,
and all occurrences below.

@@ +19,5 @@
> +let tests = [
> +  {command: "d009810301040082028182",
> +   func: testPollOff,
> +   expect: {name: "pull_off_cmd_1",
> +         commandQualifier: 0x00}}

nit, align this.
Comment 38 Yoshi Huang[:allstars.chh] 2013-02-04 01:54:53 PST
Comment on attachment 709630 [details] [diff] [review]
Part 1: Test STK Refresh.

Review of attachment 709630 [details] [diff] [review]:
-----------------------------------------------------------------

Please update patch comment and add r=me.

::: dom/icc/tests/marionette/test_stk_refresh.js
@@ +7,5 @@
> +
> +let icc = navigator.mozMobileConnection.icc;
> +ok(icc instanceof MozIccManager, "icc is instanceof " + icc.constructor);
> +
> +function testRefresh(cmd, expect) {

For consistency please rename cmd to command, and all occurrences below.
Comment 39 John Shih 2013-02-06 23:56:56 PST
Created attachment 711184 [details] [diff] [review]
Part 1: Test STK Refresh.

update
Comment 40 John Shih 2013-02-07 00:05:09 PST
Created attachment 711187 [details] [diff] [review]
Part 2: Test STK Poll Off.

update
Comment 41 Yoshi Huang[:allstars.chh] 2013-02-07 00:06:00 PST
Comment on attachment 711184 [details] [diff] [review]
Part 1: Test STK Refresh.

Review of attachment 711184 [details] [diff] [review]:
-----------------------------------------------------------------

I already gave you r+ so you don't have to r? again.
BTW, my bugzilla email is allstars.chh@mozilla.com, gmail.com is my personal mail
Comment 42 John Shih 2013-02-07 00:15:03 PST
Created attachment 711190 [details] [diff] [review]
Part 3: Test STK Setup Event List.

update. (with test pass)
Comment 43 John Shih 2013-02-07 00:31:01 PST
Created attachment 711192 [details] [diff] [review]
Part 4: Test STK Setup Call.

update (with test pass)
Comment 44 Yoshi Huang[:allstars.chh] 2013-02-07 01:02:36 PST
Comment on attachment 711190 [details] [diff] [review]
Part 3: Test STK Setup Event List.

Review of attachment 711190 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_setup_event_list.js
@@ +11,5 @@
> +function testSetupEventList(command, expect) {
> +  log("STK CMD " + JSON.stringify(command));
> +  is(command.typeOfCommand, icc.STK_CMD_SET_UP_EVENT_LIST, expect.name);
> +  is(command.commandQualifier, expect.commandQualifier, expect.name);
> +

We should also test command.options.eventList here

@@ +39,5 @@
> +            commandQualifier: 0x00}},
> +  {command: "d00c810301050082028182990107",
> +   func: testSetupEventList,
> +   expect: {name: "setup_event_list_cmd_6",
> +            commandQualifier: 0x00}}                      

nit, trailing ws.
Comment 45 Yoshi Huang[:allstars.chh] 2013-02-07 01:07:07 PST
Comment on attachment 711192 [details] [diff] [review]
Part 4: Test STK Setup Call.

Review of attachment 711192 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_setup_call.js
@@ +11,5 @@
> +function testSetupCall(command, expect) {
> +  log("STK CMD " + JSON.stringify(command));
> +  is(command.typeOfCommand, icc.STK_CMD_SET_UP_CALL, expect.name);
> +  is(command.commandQualifier, expect.commandQualifier, expect.name);
> +  if(typeof command.options.confirmMessage != "undefined") {

if (command.options.confirmMessage) seems enough.

@@ +82,5 @@
> +  {command: "d04c81030110008202818385165365742075702063616c6c2049636f6e20332e342e318609911032042143651c2c9e02000185165365742075702063616c6c2049636f6e20332e342e329e020001",
> +   func: testSetupCall,
> +   expect: {name: "setup_call_cmd_13",
> +            commandQualifier: 0x00,
> +            text: "Set up call Icon 3.4.1"}},   

nit, trailing space.

@@ +112,5 @@
> +  {command: "d02c810301100082028183850e434f4e4649524d4154494f4e20328609911032042143651c2c850643414c4c2032",
> +   func: testSetupCall,
> +   expect: {name: "setup_call_cmd_19",
> +            commandQualifier: 0x00,
> +            text: "CONFIRMATION 2"}},    

ditto.

@@ +242,5 @@
> +  {command: "d02081030110008202818385058030eb003186079110320421436585058030eb0032",
> +   func: testSetupCall,
> +   expect: {name: "setup_call_cmd_45",
> +            commandQualifier: 0x00,
> +            text: "ル1"}},                                               

ditto.
Comment 46 John Shih 2013-02-07 01:35:18 PST
Created attachment 711206 [details] [diff] [review]
Part 4: Test STK Setup Call.

update
Comment 47 John Shih 2013-02-07 01:38:16 PST
Created attachment 711209 [details] [diff] [review]
Part 4: Test STK Setup Call.

update
Comment 48 John Shih 2013-02-07 01:39:31 PST
Created attachment 711210 [details] [diff] [review]
Part 4: Test STK Setup Call.
Comment 49 Yoshi Huang[:allstars.chh] 2013-02-07 01:42:34 PST
Comment on attachment 709572 [details] [diff] [review]
Part 5: Test STK Send SS.

Review of attachment 709572 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_send_ss.js
@@ +58,5 @@
> +         title: "Basic Icon"}},
> +  {command: "d01d810301110082028183890e91aa120a214365870921436587b99e020101",
> +   func: testSendSS,
> +   exp: {name: "send_ss_241",
> +         commandQualifier: 0x00}},

This test doesn't have title,
however title is required in SEND_SS.
Can you remove this test?

@@ +153,5 @@
> +  {command: "d02d810301110082028183851054657874204174747269627574652033891091aa120a214365870921436587a901fb",
> +   func: testSendSS,
> +   exp: {name: "send_ss_473",
> +         commandQualifier: 0x00,
> +         title: "Toolkit Select 3"}},

The title seems wrong here.
Comment 50 Yoshi Huang[:allstars.chh] 2013-02-07 02:01:53 PST
Comment on attachment 709573 [details] [diff] [review]
Part 6: Test STK Send USSD.

Review of attachment 709573 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_send_ussd.js
@@ +43,5 @@
> +         title: "once a RELEASE COMPLETE message containing the USSD Return Result message not containing an error has been received from the network, the ME shall inform the SIM that the command has"}},
> +  {command: "d0448103011200820281838a39f041e19058341e9149e592d9743ea151e9945ab55eb1596d2b2c1e93cbe6333aad5eb3dbee373c2e9fd3ebf63b3eaf6fc564335acd76c3e560",
> +   func: testSendUSSD,
> +   exp: {name: "send_ussd_171",
> +         commandQualifier: 0x00}},

No title.

@@ +67,5 @@
> +         title: "Basic Icon"}},
> +  {command: "d0488103011200820281838a39f041e19058341e9149e592d9743ea151e9945ab55eb1596d2b2c1e93cbe6333aad5eb3dbee373c2e9fd3ebf63b3eaf6fc564335acd76c3e5609e020101",
> +   func: testSendUSSD,
> +   exp: {name: "send_ussd_241",
> +         commandQualifier: 0x00}},

No title here.

@@ +152,5 @@
> +  {command: "d05c8103011200820281838510546578742041747472696275746520318a39f041e19058341e9149e592d9743ea151e9945ab55eb1596d2b2c1e93cbe6333aad5eb3dbee373c2e9fd3ebf63b3eaf6fc564335acd76c3e560d004001020b4",
> +   func: testSendUSSD,
> +   exp: {name: "send_ussd_471",
> +         commandQualifier: 0x00,
> +         title: "Toolkit Select 1"}},

The title seems wrong here.
Comment 51 John Shih 2013-02-07 19:08:33 PST
Created attachment 711645 [details] [diff] [review]
Part 3: Test STK Setup Event List.

add check of command.options.eventList
Comment 52 John Shih 2013-02-07 19:11:18 PST
Created attachment 711646 [details] [diff] [review]
Part 3: Test STK Setup Event List.

update
Comment 53 John Shih 2013-02-07 19:13:01 PST
Created attachment 711647 [details] [diff] [review]
Part 3: Test STK Setup Event List.

update
Comment 54 John Shih 2013-02-07 19:16:13 PST
Created attachment 711648 [details] [diff] [review]
Part 5: Test STK Send SS.

update (with test pass)
Comment 55 John Shih 2013-02-07 19:17:34 PST
Created attachment 711649 [details] [diff] [review]
Part 6: Test STK Send USSD.

update (with test pass)
Comment 56 John Shih 2013-02-07 19:19:40 PST
Created attachment 711650 [details] [diff] [review]
Part 6: Test STK Send USSD.

update
Comment 57 John Shih 2013-02-07 19:40:01 PST
Created attachment 711662 [details] [diff] [review]
Part 7: Test STK Send SMS.

update (with test pass)
Comment 58 John Shih 2013-02-07 19:41:18 PST
Created attachment 711663 [details] [diff] [review]
Part 7: Test STK Send SMS.
Comment 59 John Shih 2013-02-07 19:43:03 PST
Created attachment 711665 [details] [diff] [review]
Part 6: Test STK Send USSD.
Comment 60 John Shih 2013-02-07 20:05:45 PST
Created attachment 711669 [details] [diff] [review]
Part 8: Test STK Send DTMF.

update (with test pass)
Comment 61 Yoshi Huang[:allstars.chh] 2013-02-07 22:03:30 PST
Comment on attachment 711647 [details] [diff] [review]
Part 3: Test STK Setup Event List.

Review of attachment 711647 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_setup_event_list.js
@@ +28,5 @@
> +  {command: "d00d81030105008202818299020507",
> +   func: testSetupEventList,
> +   expect: {name: "setup_event_list_cmd_2",
> +            commandQualifier: 0x00,
> +            eventList: 5}},

eventList is an array,
and in this case the array has two elements [5, 7],
so the test in testSetupEventLust should test with the contents of eventList.
Comment 62 Yoshi Huang[:allstars.chh] 2013-02-07 22:08:19 PST
Comment on attachment 709576 [details] [diff] [review]
Part 9: Test STK Launch Browser.

Review of attachment 709576 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_launch_browser.js
@@ +7,5 @@
> +
> +let icc = navigator.mozMobileConnection.icc;
> +ok(icc instanceof MozIccManager, "icc is instanceof " + icc.constructor);
> +
> +function testLaunchBrowser(cmd, exp) {

please rename these parameters.

@@ +17,5 @@
> +  runNextTest();
> +}
> +
> +let tests = [
> +  

nit, spaces.
also many of them below.
Comment 63 Yoshi Huang[:allstars.chh] 2013-02-07 22:08:47 PST
Comment on attachment 709576 [details] [diff] [review]
Part 9: Test STK Launch Browser.

Review of attachment 709576 [details] [diff] [review]:
-----------------------------------------------------------------

what about manifest.ini?
Comment 64 Yoshi Huang[:allstars.chh] 2013-02-07 22:09:22 PST
Comment on attachment 709577 [details] [diff] [review]
Part 10: Test STK Display Text.

Review of attachment 709577 [details] [diff] [review]:
-----------------------------------------------------------------

Same problem here.
Comment 65 Yoshi Huang[:allstars.chh] 2013-02-07 22:09:47 PST
Comment on attachment 709578 [details] [diff] [review]
Part 11: Test STK Get Inkey.

Review of attachment 709578 [details] [diff] [review]:
-----------------------------------------------------------------

Same
Comment 66 John Shih 2013-02-07 22:35:20 PST
Created attachment 711700 [details] [diff] [review]
Part 9: Test STK Launch Browser

update
Comment 67 John Shih 2013-02-07 22:42:02 PST
Created attachment 711702 [details] [diff] [review]
Part 10: Test STK Display Text.

update
Comment 68 John Shih 2013-02-07 22:53:37 PST
Created attachment 711705 [details] [diff] [review]
Part 11: Test STK Get Inkey.

update
Comment 69 John Shih 2013-02-07 22:59:11 PST
Created attachment 711706 [details] [diff] [review]
Part 9: Test STK Launch Browser
Comment 70 John Shih 2013-02-07 23:10:26 PST
Created attachment 711709 [details] [diff] [review]
Part 12: Test STK Get Input.

update
Comment 71 John Shih 2013-02-07 23:23:32 PST
Created attachment 711714 [details] [diff] [review]
Part 13: Test STK Select Item.

update
Comment 72 John Shih 2013-02-07 23:43:45 PST
Created attachment 711718 [details] [diff] [review]
Part 14: Test STK Setup Menu.

update
Comment 73 Yoshi Huang[:allstars.chh] 2013-02-07 23:55:53 PST
Comment on attachment 711706 [details] [diff] [review]
Part 9: Test STK Launch Browser

Review of attachment 711706 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_launch_browser.js
@@ +14,5 @@
> +  is(command.commandQualifier, expect.commandQualifier, expect.name);
> +  if (command.options.confirmMessage) {
> +    is(command.options.confirmMessage, expect.text, expect.name);
> +  }
> +

Can you also the command.options.url?
Comment 74 John Shih 2013-02-08 00:05:49 PST
Created attachment 711722 [details] [diff] [review]
Part 15: Test STK Setup Idle Mode Text.

update
Comment 75 Yoshi Huang[:allstars.chh] 2013-02-08 00:09:03 PST
Comment on attachment 711705 [details] [diff] [review]
Part 11: Test STK Get Inkey.

Review of attachment 711705 [details] [diff] [review]:
-----------------------------------------------------------------

Cancel the r+, as I found out we'd test more properties here.

::: dom/icc/tests/marionette/test_stk_get_inkey.js
@@ +12,5 @@
> +  log("STK CMD " + JSON.stringify(command));
> +  is(command.typeOfCommand, icc.STK_CMD_GET_INKEY, expect.name);
> +  is(command.commandQualifier, expect.commandQualifier, expect.name);
> +  is(command.options.text, expect.text, expect.name);
> +

For GET_INKEY
we should also check command.options.{isAlphabet, isUCS2, and isYesNoRequired};
Comment 76 Yoshi Huang[:allstars.chh] 2013-02-08 00:10:32 PST
Comment on attachment 711709 [details] [diff] [review]
Part 12: Test STK Get Input.

Review of attachment 711709 [details] [diff] [review]:
-----------------------------------------------------------------

The same with GET_INKEY, we should test those isAlpha, isUCS2,.. properties.
(Those properties are extracted from Command Qualifier).
Comment 77 Yoshi Huang[:allstars.chh] 2013-02-08 00:11:17 PST
Comment on attachment 711714 [details] [diff] [review]
Part 13: Test STK Select Item.

Review of attachment 711714 [details] [diff] [review]:
-----------------------------------------------------------------

Can we also test item[] ?
Comment 78 Yoshi Huang[:allstars.chh] 2013-02-08 00:11:50 PST
Comment on attachment 711718 [details] [diff] [review]
Part 14: Test STK Setup Menu.

Review of attachment 711718 [details] [diff] [review]:
-----------------------------------------------------------------

Same with SELECT_ITEM
Comment 79 Yoshi Huang[:allstars.chh] 2013-02-08 00:13:54 PST
Comment on attachment 711722 [details] [diff] [review]
Part 15: Test STK Setup Idle Mode Text.

Review of attachment 711722 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_setup_idle_mode_text.js
@@ +12,5 @@
> +  log("STK CMD " + JSON.stringify(command));
> +  is(command.typeOfCommand, icc.STK_CMD_SET_UP_IDLE_MODE_TEXT, expect.name);
> +  is(command.commandQualifier, expect.commandQualifier, expect.name);
> +  is(command.options.text, expect.text, expect.name);
> +

Can we also test isHighPriority, userClear and responseNeeded?
Comment 80 Yoshi Huang[:allstars.chh] 2013-02-08 00:15:08 PST
Comment on attachment 711702 [details] [diff] [review]
Part 10: Test STK Display Text.

Review of attachment 711702 [details] [diff] [review]:
-----------------------------------------------------------------

Cancel the r+ as we'd also test other properties in DISPLAY_TEXT.

::: dom/icc/tests/marionette/test_stk_display_text.js
@@ +12,5 @@
> +  log("STK CMD " + JSON.stringify(command));
> +  is(command.typeOfCommand, icc.STK_CMD_DISPLAY_TEXT, expect.name);
> +  is(command.options.text, expect.text, expect.name);
> +  is(command.commandQualifier, expect.commandQualifier, expect.name);
> +

We should also test isHighPriority, userClear and responseNeed here.
Comment 81 John Shih 2013-02-08 00:21:52 PST
(In reply to Yoshi Huang[:yoshi][:allstars.chh] from comment #79)
> Comment on attachment 711722 [details] [diff] [review]
> Part 15: Test STK Setup Idle Mode Text.
> 
> Review of attachment 711722 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: dom/icc/tests/marionette/test_stk_setup_idle_mode_text.js
> @@ +12,5 @@
> > +  log("STK CMD " + JSON.stringify(command));
> > +  is(command.typeOfCommand, icc.STK_CMD_SET_UP_IDLE_MODE_TEXT, expect.name);
> > +  is(command.commandQualifier, expect.commandQualifier, expect.name);
> > +  is(command.options.text, expect.text, expect.name);
> > +
> 
> Can we also test isHighPriority, userClear and responseNeeded?

I got response in the form below:
INFO STK CMD {"commandNumber":1,"typeOfCommand":40,"commandQualifier":0,"rilMessageType":"stkcommand","options":{"text":"Idle Mode Text 2"}} Fri Feb 08 2013 08:17:13 GMT+0000 (GMT)

how can I get the fields you mention?
Comment 82 John Shih 2013-02-08 00:39:41 PST
Created attachment 711734 [details] [diff] [review]
Part 10: Test STK Display Text.

add the check of userClear, isHighPriority
Comment 83 John Shih 2013-02-08 00:52:54 PST
Created attachment 711738 [details] [diff] [review]
Part 9: Test STK Launch Browser

add check of url
Comment 84 John Shih 2013-02-08 01:13:02 PST
(In reply to Yoshi Huang[:yoshi][:allstars.chh] from comment #61)
> Comment on attachment 711647 [details] [diff] [review]
> Part 3: Test STK Setup Event List.
> 
> Review of attachment 711647 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: dom/icc/tests/marionette/test_stk_setup_event_list.js
> @@ +28,5 @@
> > +  {command: "d00d81030105008202818299020507",
> > +   func: testSetupEventList,
> > +   expect: {name: "setup_event_list_cmd_2",
> > +            commandQualifier: 0x00,
> > +            eventList: 5}},
> 
> eventList is an array,
> and in this case the array has two elements [5, 7],
> so the test in testSetupEventLust should test with the contents of eventList.

Can you provide a proper way to test the contents of array? (I wonder if for loop is valid for test cases)
or can I just compare their length?
thanks
Comment 85 John Shih 2013-02-18 21:50:47 PST
Created attachment 715331 [details] [diff] [review]
Part 3: Test STK Setup Event List.

Check array instead of single element
Comment 86 John Shih 2013-02-18 22:04:32 PST
Created attachment 715333 [details] [diff] [review]
Part 11: Test STK Get Inkey.

add check of isAlphabet, isUSC2, isYesNoRequested.
Comment 87 John Shih 2013-02-18 22:13:52 PST
Created attachment 715335 [details] [diff] [review]
Part 12: Test STK Get Input.

add check of isAlphabet, isUCS2, isPacked, hideInput.
Comment 88 Yoshi Huang[:allstars.chh] 2013-02-18 22:29:23 PST
Comment on attachment 715331 [details] [diff] [review]
Part 3: Test STK Setup Event List.

Review of attachment 715331 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_setup_event_list.js
@@ +11,5 @@
> +function testSetupEventList(command, expect) {
> +  log("STK CMD " + JSON.stringify(command));
> +  is(command.typeOfCommand, icc.STK_CMD_SET_UP_EVENT_LIST, expect.name);
> +  is(command.commandQualifier, expect.commandQualifier, expect.name);
> +  for(index in command.options.eventList) {

nit, space after for
Comment 89 John Shih 2013-02-18 22:50:25 PST
Created attachment 715344 [details] [diff] [review]
Part 13: Test STK Select Item.

add check of items[].
Comment 90 John Shih 2013-02-18 23:07:12 PST
Created attachment 715352 [details] [diff] [review]
Part 14: Test STK Setup Menu.

add check of items[].
Comment 91 John Shih 2013-02-18 23:11:31 PST
Created attachment 715354 [details] [diff] [review]
Part 3: Test STK Setup Event List.

fix nit
Comment 92 Yoshi Huang[:allstars.chh] 2013-02-18 23:12:39 PST
Comment on attachment 715333 [details] [diff] [review]
Part 11: Test STK Get Inkey.

Review of attachment 715333 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_get_inkey.js
@@ +20,5 @@
> +    is(command.options.isUCS2, expect.isUCS2, expect.name);
> +  }
> +  if (command.options.isYesNoRequested) {
> +    is(command.options.isYesNoRequested, expect.isYesNoRequested, expect.name);
> +  }

nit, add an extra line before runNextTest
Comment 93 John Shih 2013-02-18 23:13:23 PST
Created attachment 715356 [details] [diff] [review]
Part 4: Test STK Setup Call.

fix nit
Comment 94 John Shih 2013-02-18 23:14:57 PST
Created attachment 715359 [details] [diff] [review]
Part 5: Test STK Send SS.

fix nit.
Comment 95 John Shih 2013-02-18 23:16:32 PST
Created attachment 715361 [details] [diff] [review]
Part 6: Test STK Send USSD.

fix nit.
Comment 96 John Shih 2013-02-18 23:18:31 PST
Created attachment 715362 [details] [diff] [review]
Part 7: Test STK Send SMS.

fix nit.
Comment 97 Yoshi Huang[:allstars.chh] 2013-02-18 23:19:35 PST
Comment on attachment 715344 [details] [diff] [review]
Part 13: Test STK Select Item.

Review of attachment 715344 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_select_item.js
@@ +12,5 @@
> +  log("STK CMD " + JSON.stringify(command));
> +  is(command.typeOfCommand, icc.STK_CMD_SELECT_ITEM, expect.name);
> +  is(command.commandQualifier, expect.commandQualifier, expect.name);
> +  is(command.options.title, expect.title, expect.name);
> +  for (index in command.options.items) {

let index ..
Comment 98 John Shih 2013-02-18 23:20:07 PST
Created attachment 715364 [details] [diff] [review]
Part 8: Test STK Send DTMF.

fix nit.
Comment 99 Yoshi Huang[:allstars.chh] 2013-02-18 23:20:57 PST
Comment on attachment 715352 [details] [diff] [review]
Part 14: Test STK Setup Menu.

Review of attachment 715352 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_setup_menu.js
@@ +12,5 @@
> +  log("STK CMD " + JSON.stringify(command));
> +  is(command.typeOfCommand, icc.STK_CMD_SET_UP_MENU, expect.name);
> +  is(command.commandQualifier, expect.commandQualifier, expect.name);
> +  is(command.options.title, expect.title, expect.name);
> +  for (index in command.options.items) {

let index
Comment 100 Yoshi Huang[:allstars.chh] 2013-02-18 23:23:04 PST
Hi John,
Could you run try server on B2G platform?

thanks
Comment 101 John Shih 2013-02-18 23:26:54 PST
Created attachment 715365 [details] [diff] [review]
Part 3: Test STK Setup Event List.

update.
Comment 102 John Shih 2013-02-18 23:29:28 PST
Created attachment 715367 [details] [diff] [review]
Part 11: Test STK Get Inkey.

update.
Comment 103 John Shih 2013-02-18 23:30:19 PST
Created attachment 715369 [details] [diff] [review]
Part 11: Test STK Get Inkey.
Comment 104 John Shih 2013-02-18 23:33:48 PST
Created attachment 715371 [details] [diff] [review]
Part 13: Test STK Select Item.

update.
Comment 105 John Shih 2013-02-18 23:36:34 PST
Created attachment 715374 [details] [diff] [review]
Part 14: Test STK Setup Menu.

update.
Comment 106 John Shih 2013-02-18 23:44:26 PST
Created attachment 715377 [details] [diff] [review]
Part 7: Test STK Send SMS.
Comment 108 Yoshi Huang[:allstars.chh] 2013-02-20 20:23:36 PST
Cool, I'll help to push them when the test is finished,
also next time you'd run try only on B2G platform.
Otherwise sheriff would complain.
Comment 109 Yoshi Huang[:allstars.chh] 2013-02-20 20:29:51 PST
Import script for common code I filed Bug 843455 to address it.
Comment 110 John Shih 2013-02-20 20:59:36 PST
little error on previous test,
so I push another test. (rename the part 15 patch to correct one)

https://tbpl.mozilla.org/?tree=Try&rev=59f25c918d58
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jshih@mozilla.com-59f25c918d58
Comment 111 Yoshi Huang[:allstars.chh] 2013-02-22 02:27:50 PST
John, your 'try' result is failed, although I don't know what went wrong,
Can you run it again on 'B2G only' platform?
Comment 112 John Shih 2013-02-25 20:08:53 PST
ok, I'll check it and do another test
Comment 113 John Shih 2013-02-25 23:29:59 PST
New test run.
https://tbpl.mozilla.org/?tree=Try&rev=15684a551bbc
Comment 114 Yoshi Huang[:allstars.chh] 2013-03-01 00:12:19 PST
CCing Griffin on this,
Hi, Griffin
In the Part 4 patch, there are some Chinese and Japanese characters in that test, we ran it well on our local PCs, but when we run try server, it fails with error message "UnicodeEncodeError: 'ascii' codec can't encode character u'\u30eb' in position 131: ordinal not in range(128)", (see comment 113)

Is this a known issue for marionette ?
Comment 115 Yoshi Huang[:allstars.chh] 2013-03-03 18:56:51 PST
Filed Bug 847256 for the TBPL failure,

John Can you comment out those failed tests and add comments on it?

Like


/*
 TBPL UnicodeEncodeError, See Bug 847256.
 {command:...
  func:...
  expect:...
 }
*/

thanks
Comment 116 Yoshi Huang[:allstars.chh] 2013-03-04 18:11:44 PST
Hi, John
Can you try the patch from Bug 847256 with your patches and run the try server again?
thanks
Comment 117 John Shih 2013-03-04 20:29:37 PST
Hi, 
the test is here.
https://tbpl.mozilla.org/?tree=Try&rev=7c2034aa9aa5
Comment 118 Yoshi Huang[:allstars.chh] 2013-03-04 23:00:10 PST
Please also apply patch from Bug 847683 for the uploadssymbols error.
Comment 119 Mozilla RelEng Bot 2013-03-04 23:00:39 PST
Try run for acedca11d51c is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=acedca11d51c
Results (out of 1 total builds):
    failure: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/yhuang@mozilla.com-acedca11d51c
Comment 120 John Shih 2013-03-04 23:43:02 PST
The patch in Bug 847683 seems strange..
I can't find the file "b2g_config.py" in the path "mozilla/" 
This makes the import fail
Comment 121 Mozilla RelEng Bot 2013-03-05 00:00:44 PST
Try run for b6aa786f5bbb is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=b6aa786f5bbb
Results (out of 1 total builds):
    failure: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/yhuang@mozilla.com-b6aa786f5bbb
Comment 122 John Shih 2013-03-06 21:39:27 PST
Hi, I've push a test again and seems all pass
please see
https://tbpl.mozilla.org/?tree=Try&rev=42ea5b7953b6

p.s. there is a fail unrelated to my patch
Comment 123 Yoshi Huang[:allstars.chh] 2013-03-06 22:13:45 PST
Hi, John 
Thanks.
Once Bug 847256 is landed I'll commit your patches.
Comment 124 Yoshi Huang[:allstars.chh] 2013-03-12 20:01:53 PDT
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=0b9505f9af26

Thanks for your hard work, John.

Note You need to log in before you can comment on or make changes to this bug.