Trying to change the date and Time for an event in succession does not save values

RESOLVED DUPLICATE of bug 804827

Status

Firefox OS
Gaia::Calendar
P3
normal
RESOLVED DUPLICATE of bug 804827
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: lightsofapollo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Device: Otoro
Build Date: 10/3/2012

Steps:

1. Select to create an event
2. Select and change the start date to tomorrow's date
3. Select and change the end date to a date two days from now

Expected:

The start date should change to today + 1, end date should change to today + 2.

Actual:

The start date changes to today + 1, but the end date does not change.

Additional Notes:

I've generally noticed this behavior of occasional failures to change a date through the date picker, so there definitely probably other STR that can be used to reproduce this. This is just one consistent, easy STR that can be used.
(Reporter)

Updated

5 years ago
blocking-basecamp: --- → ?
(Assignee)

Comment 1

5 years ago
I believe this is the same keyboard issues we have seen with date pickers. 
I will try to find/file a bug for that. I believe there is a fix soon.

Comment 2

5 years ago
CC'ing some keyboard folks and blocking+ since the user isn't able to make a pretty trivial date change in calendar.
blocking-basecamp: ? → +
Priority: -- → P2
(Assignee)

Updated

5 years ago
Depends on: 796756
(Reporter)

Updated

5 years ago
Duplicate of this bug: 802499

Comment 4

5 years ago
i filed bug 802499, which sounds like a dupe, but has more data there.   IN summary:

* this also affects the time picker, not just date
* screencast: http://youtu.be/xGVWqk-VwV0 
* Logcat: 
10-16 23:35:41.009: E/GeckoConsole(3049): [JavaScript Error: "can't access dead object" {file: "chrome://browser/content/forms.js" line: 49}]

Updated

5 years ago
Summary: Trying to change the date for an event for start/end date in succession - can change start date, but end date does not change → Trying to change the date and Time for an event in succession does not save values
(Assignee)

Comment 5

5 years ago
Seems to work on today's unagi/gaia? Can You verify?
(Reporter)

Updated

5 years ago
Keywords: qawanted
QA Contact: jsmith
(Reporter)

Comment 6

5 years ago
(In reply to James Lal [:lightsofapollo] from comment #5)
> Seems to work on today's unagi/gaia? Can You verify?

Harder to reproduce now, but still possible. In going in order of editing start date, start time, end date, end time, and then repeating, I saw this happen on the 6th time with the time value. I tried to change the value from 0:00 am to 5:00am, but nothing happened. Saw this in the logcat:

10-18 16:38:16.873: E/GeckoConsole(512): [JavaScript Error: "DataError: Data provided to an operation does not meet requirements." {file: "app://calendar.gaiamobile.org/js/store/abstract.js" line: 229}]
10-18 16:38:16.953: E/GeckoConsole(428): [JavaScript Error: "DataError: Data provided to an operation does not meet requirements." {file: "app://calendar.gaiamobile.org/js/store/abstract.js" line: 229}]
(Reporter)

Updated

5 years ago
Keywords: qawanted
(Assignee)

Comment 7

5 years ago
OK the keyboard part here is fixed I think.

Those errors related to the database though so this is after saving the event where you see this error? Or was the calendar syncing at the time?
(Reporter)

Updated

5 years ago
Keywords: qawanted
(Reporter)

Comment 8

5 years ago
(In reply to James Lal [:lightsofapollo] from comment #7)
> OK the keyboard part here is fixed I think.
> 
> Those errors related to the database though so this is after saving the
> event where you see this error? Or was the calendar syncing at the time?

Hmm, I actually wasn't doing either of those behaviors, which gets the feeling I give you the incorrect logcat. I just tried again and got a reproduction with this logcat:

10-19 12:58:49.234: E/GeckoConsole(621): [JavaScript Warning: "Unknown property 'user-select'.  Declaration dropped." {file: "app://calendar.gaiamobile.org/style/week_view.css" line: 4}]
10-19 12:58:49.234: E/GeckoConsole(621): [JavaScript Warning: "Expected end of value but found 'overflow'.  Error in parsing value for 'padding'.  Declaration dropped." {file: "app://calendar.gaiamobile.org/style/week_view.css" line: 58}]
10-19 12:58:49.234: E/GeckoConsole(621): [JavaScript Warning: "Unknown property 'user-select'.  Declaration dropped." {file: "app://calendar.gaiamobile.org/style/settings.css" line: 80}]
10-19 12:58:49.384: E/GeckoConsole(105): [JavaScript Warning: "Unknown property 'user-select'.  Declaration dropped." {file: "app://calendar.gaiamobile.org/style/week_view.css" line: 4}]
10-19 12:58:49.384: E/GeckoConsole(105): [JavaScript Warning: "Expected end of value but found 'overflow'.  Error in parsing value for 'padding'.  Declaration dropped." {file: "app://calendar.gaiamobile.org/style/week_view.css" line: 58}]
10-19 12:58:49.394: E/GeckoConsole(105): [JavaScript Warning: "Unknown property 'user-select'.  Declaration dropped." {file: "app://calendar.gaiamobile.org/style/settings.css" line: 80}]
10-19 12:58:50.135: E/profiler(1625): Registering start signal
10-19 12:58:50.385: E/GeckoConsole(621): [JavaScript Warning: "CSP WARN:  Directive script-src app://calendar.gaiamobile.org violated by http://gaiamobile.org/webapps.js
10-19 12:58:50.385: E/GeckoConsole(621): "]
10-19 12:58:50.896: E/GeckoConsole(105): [JavaScript Warning: "CSP WARN:  Directive script-src app://calendar.gaiamobile.org violated by http://gaiamobile.org/webapps.js
10-19 12:58:50.896: E/GeckoConsole(105): "]
Keywords: qawanted
(Reporter)

Comment 9

5 years ago
Oh and I'm renoming this for a minus - the frequency of occurrence has dropped significantly here (it's at the point of "edge case" level). It's still possible to reproduce, but given the need to crack down on priorities, we can probably live with what we have here for v1.
blocking-basecamp: + → ?
(Assignee)

Comment 10

5 years ago
Its worth noting that the root cause of this problem is likely to be in the keyboard, app I will see if we can link the bugs here.
Reproduced in today build
blocking-basecamp: ? → +

Updated

5 years ago
Priority: P2 → --

Updated

5 years ago
Priority: -- → P3
Duplicate of this bug: 806018
I could not reproduce this issue as of today.
This should have been resolved with Bug 804827.
(Reporter)

Updated

5 years ago
Keywords: qawanted
(Reporter)

Comment 14

5 years ago
(In reply to Rudy Lu [:rudyl] from comment #13)
> I could not reproduce this issue as of today.
> This should have been resolved with Bug 804827.

Can't reproduce either. I'll dup on that bug and close this.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 804827
blocking-basecamp: + → ---
You need to log in before you can comment on or make changes to this bug.