Last Comment Bug 801514 - 'next' button icon points up
: 'next' button icon points up
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: 16 Branch
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
https://bugs.launchpad.net/ubuntu/+so...
: 878720 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 21:12 PDT by Max Waterman
Modified: 2013-08-22 06:52 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
shows the rhs button (next) pointing up when no mouse-over (2.09 KB, image/jpeg)
2012-10-14 21:12 PDT, Max Waterman
no flags Details
shows the rhs button (next) correctly pointing down when mouse-over (1.22 KB, image/jpeg)
2012-10-14 21:15 PDT, Max Waterman
no flags Details
diff for Ubuntu (3.73 KB, patch)
2012-11-10 01:05 PST, Richard Marti (:Paenglab)
no flags Details | Diff | Review

Description Max Waterman 2012-10-14 21:12:40 PDT
Created attachment 671313 [details]
shows the rhs button (next) pointing up when no mouse-over

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010234852

Steps to reproduce:

upgraded to 16.0.1 via ubuntu software updater application.


Actual results:

the buttons that were pointing left/right for previous/next changed their icons as per Bug 243480, however the icon on the button for next, which should point down, actually points up. That is, until the mouse is placed over the button, at which point the icon points down.


Expected results:

The next button, should have a 'next' button with an icon that points down.

It is possible this is an upgrading issue, but I think it's just that the icon is wrong.
Comment 1 Max Waterman 2012-10-14 21:15:36 PDT
Created attachment 671315 [details]
shows the rhs button (next) correctly pointing down when mouse-over
Comment 2 Wayne Mery (:wsmwk, NI for questions) 2012-10-15 04:26:40 PDT
looks fine to me in vista with current trunk. but I didn't check linux
Comment 3 :aceman 2012-10-15 05:26:15 PDT
There was a similar problem to this, where the css for these buttons was mistakenly broken in an unrelated bug. Now only how to find it...
Comment 4 Richard Marti (:Paenglab) 2012-10-15 05:41:07 PDT
The monochrome icons are looking as the special ones for Ubuntu. Who is responsible for the Ubuntu integration? Maybe this bug should be given to Ubuntu.
Comment 5 Magnus Melin 2012-10-15 11:29:04 PDT
Probably Chris.
FWIW, i don't see the problem.
Comment 6 Richard Marti (:Paenglab) 2012-11-10 01:05:46 PST
Created attachment 680334 [details] [diff] [review]
diff for Ubuntu

Now I can confirm this issue. It only appears with small icons. This is a bug on Ubuntu's implementation.

Chris, I attached a diff for this issue. Please can you look to check-in this in Ubuntu's repository?
Comment 7 Richard Marti (:Paenglab) 2013-01-17 08:39:55 PST
Concerning the Launchpad bug the fix is committed in Ubuntu.

I close this bug as fixed. It wasn't a bug in c-c code but in Ubuntu integration code.
Comment 8 Richard Marti (:Paenglab) 2013-06-03 03:30:21 PDT
*** Bug 878720 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.