If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Feedback form does not work when user is logged out

VERIFIED FIXED in 2012-10-18

Status

Marketplace
Consumer Pages
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Cristian Boldan, Assigned: basta)

Tracking

2012-10-18
x86_64
All
Points:
---

Details

(Whiteboard: [janus])

(Reporter)

Description

5 years ago
Steps to reproduce:
1. Load MP homepage logged out https://marketplace-dev.allizom.org/
2. Click the settings icon to load the feedback page
3. Enter feedback text and click Send

Expected results:
Feedback is sent and success message is displayed.

Actual results:
The Send button in grayed out and nothing happens.

Notes/Issues:
Verified in FF19 (Win 7)
Screencast for this issue http://screencast.com/t/pD8iBK44Mo

Comment 1

5 years ago
Reproducible also on Android 4.0.4, latest FF Nightly installed
OS: Windows 7 → All
(Reporter)

Updated

5 years ago
Target Milestone: --- → 2012-10-18
Assignee: nobody → mattbasta
As far as I know, the feedback form should be for logged in users only. I can dig up the bug/comment where this was requested if need be. But I'd say the expected result should be that a log in prompt is shown.

Comment 3

5 years ago
(In reply to Rob Hudson [:robhudson] from comment #2)
> As far as I know, the feedback form should be for logged in users only. I
> can dig up the bug/comment where this was requested if need be. But I'd say
> the expected result should be that a log in prompt is shown.

Maybe this bug will help you : https://bugzilla.mozilla.org/show_bug.cgi?id=800648
This:
https://marketplace-dev.allizom.org/admin/addon/manage/app-390719/

And this:
https://bugzilla.mozilla.org/show_bug.cgi?id=800648#c3

Seem to be in conflict. Should /settings/feedback be only available to logged in users or not?
copy/paste fail...

https://bugzilla.mozilla.org/show_bug.cgi?id=788253#c10
vs
https://bugzilla.mozilla.org/show_bug.cgi?id=800648#c3
(Assignee)

Comment 6

5 years ago
I would say yes, it should be available. If a frustrated user is having trouble with any part of the site, we shouldn't stop them from telling us about it just because they haven't signed up. If there's an issue with login, for instance, we don't want to prevent the user from telling us about it because they're not signed in. Bear in mind, also, that a very significant number of our users are *not* going to be logged in. If our site was targeted towards logged-in users only (i.e.: we didn't let you view detail pages without logging in), I think it might be more appropriate to have feedback allowed for logged-in users only.

As far as spam goes, I doubt we'll see much of it (and it's an easy tweak to make in the future if ne need arises), so I don't consider that to be a real issue.
It should be available to anonymous users with captcha, same as our abuse reporting on AMO.  This isn't a blocker for today though.
(Assignee)

Comment 8

5 years ago
Fixed, thanks to robhudson :)

https://github.com/mozilla/zamboni/commit/a99c497df2650c63b5ffdb65c2576e5f4076ef92
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

5 years ago
Verified as fixed in https://marketplace-dev.allizom.org/settings/feedback on FF19(Win 7)
Postfix screencast http://screencast.com/t/w5zReOsL
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.