If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Settings] Need call forwarding settings UI.

VERIFIED FIXED in B2G C2 (20nov-10dec)

Status

Firefox OS
Gaia::Settings
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: jaoo, Assigned: jaoo)

Tracking

({feature, late-l10n})

unspecified
B2G C2 (20nov-10dec)
ARM
Gonk (Firefox OS)
feature, late-l10n
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [UCID:SET-235][ETA:12/4/12])

Attachments

(4 attachments, 3 obsolete attachments)

Need call forwarding settings UI. It allows the user to set rules for forwarding calls. Basically there are several reasons for forwarding a call such as 'unconditional forwarding', 'mobile busy', 'not reply' and 'not reachable'. We need a UI for dealing with those settings. I guess some UX guys should be involved.
(Assignee)

Updated

5 years ago
blocking-basecamp: --- → ?
Depends on: 793208

Comment 1

5 years ago
Isn't this very closely related to the following issue?
https://bugzilla.mozilla.org/show_bug.cgi?id=796824
(Assignee)

Comment 2

5 years ago
(In reply to Rafael Rebolleda [:rafaelrebolleda] from comment #1)
> Isn't this very closely related to the following issue?
> https://bugzilla.mozilla.org/show_bug.cgi?id=796824

No, it isn't. That bug is related to call waiting which is a different telephony capability.

Comment 3

5 years ago
After some face to face talk, I think these two issues are indeed related, at least as far as UI and error management is concerned. I think Larissa is in charge.
(Assignee)

Comment 4

5 years ago
(In reply to Rafael Rebolleda [:rafaelrebolleda] from comment #3)
> After some face to face talk, I think these two issues are indeed related,
> at least as far as UI and error management is concerned. I think Larissa is
> in charge.

So adding Larissa to the discussion.
Need Dietrich approval for this feature
There is exactly zero record of this feature anywhere in the user stories, UX specifications or visual design mockups. Blocking-.
blocking-basecamp: ? → -
(In reply to Dietrich Ayala (:dietrich) from comment #6)
> There is exactly zero record of this feature anywhere in the user stories,
> UX specifications or visual design mockups. Blocking-.

It is the UX part required for using https://bugzilla.mozilla.org/show_bug.cgi?id=793208, without this I am afraid device certification won't be possible but I will double check.

Comment 8

5 years ago
Daniel, I recall that we are not supporting this for v1.  Has something changed?

We should probably minus this bug 793208 as well.  Can you confirm?
I recall we were supporting this for V1. It is in the spreadsheet we agreed for V1 features (I'll send you offline) so the change will be not supporting it. Furthermore, it is part of the RIL features for certification in the MVP.

So I think this should be blocking. 793208 should be blocking basecamp independently of this one as this functionality can be also activated through MMI.

Updated

5 years ago
Component: Gaia → Gaia::Settings
It was agreed at product level this should be added as it is high risk for certification. Nominating again.
blocking-basecamp: - → ?
blocking-basecamp+ since this is believed to be a certification requirement. Assigning to Kaze (to reassign as necessary) and including Larissa to help with a UX. Also marking this as a requirement for C2, since this will definitely not be completed by Monday.
Assignee: nobody → kaze
blocking-basecamp: ? → +
Flags: needinfo?(lco)
Keywords: feature
Priority: -- → P1
Target Milestone: --- → B2G C2 (20nov-10dec)
Whiteboard: [UCID:SET-235]
Larissa, do you have some specs for this? This is getting late for the C2 miletsone, and as I have no clue on this feature I need a spec to know if some additional platform support is required to implement it…
(In reply to Fabien Cazenave [:kaze] from comment #12)
> Larissa, do you have some specs for this? This is getting late for the C2
> miletsone, and as I have no clue on this feature I need a spec to know if
> some additional platform support is required to implement it…

For any doubt/question about platform support please feel free to contact me. The call forwarding stuff live in mozMobileConnection API. You should be able to implement the UI for it but I agree with you about seeing the specs for being sure.

Comment 14

5 years ago
No, I don't have any specs for this, nor did I know that this was a requirement.

Why is it a Settings app requirement as opposed to one that lives in the dialer?

Also, I need clarification on exactly what features are required for basecamp / device certification if you want this spec done quickly. Is it enough to have a switch for forwarding or not forwarding?

I still have other things to do and honestly won't get to this until next week.
Flags: needinfo?(lco)
(In reply to Larissa Co from comment #14) 
> Also, I need clarification on exactly what features are required for
> basecamp / device certification if you want this spec done quickly. Is it
> enough to have a switch for forwarding or not forwarding?
> 
I am sorry, but this is not enough because you must specify the phone number to which calls shall be forwarded and the situation when you want your calls to be forwarded.

let me try to summarize here the needs for this feature:
-CFU (Call Forwarding Unconditional) --> All your incoming calls will be forwarded.
-CFB (Call Forwarding on Mobile Subscriber Busy) -> calls will be forwarded only when user is busy.
-CFNRy (Call Forwarding on No Reply)--> calls are forwared when there is no answer.
-CFNRc (Call Forwarding on Mobile Subscriber Not Reachable) -->calls are forwarded when phone off or no coverage

Rafa, please feel free to add/modify anything here.
Rafa and/or Marco, would you have time to propose me some wireframes in the next two or three days so we could implement a UI for this while we’re all in the Madrid office?
Assignee: kaze → josea.olivera
Any update on when this will be fixed?
(In reply to Dietrich Ayala (:dietrich) from comment #17)
> Any update on when this will be fixed?

Yep, TEF UX team and I are working on it. I expect to have some WIP code early-mid next week.
Whiteboard: [UCID:SET-235] → [UCID:SET-235][ETA:12/4/12]

Updated

5 years ago
Keywords: late-l10n

Comment 19

5 years ago
Peter, we're going to need an icon for the entry in the main settings menu.
Flags: needinfo?(pla)

Comment 20

5 years ago
And... we also need an icon to display call forwarding state (if in use) in the status bar :)
Peter is out until 12/8. Is there anyone else who can do the icons?
Flags: needinfo?(pla)
Can we land this with MockUp icons for now and open a followup to use the right icons? I don't think those icons should block a C2 bug if the rest is perfect. (The followup can still be a blocking-basecamp+)
(In reply to Vivien Nicolas (:vingtetun) from comment #22)
> Can we land this with MockUp icons for now and open a followup to use the
> right icons? I don't think those icons should block a C2 bug if the rest is
> perfect. (The followup can still be a blocking-basecamp+)

Hi Vivien, I agree with you,
Jose Antonio is working on landing a first version today
Created attachment 688335 [details]
Pointer to Github WIP branch: https://github.com/jaoo/gaia/tree/803533

Adding call entry to setting app and getting CF info in call settings sub-menus. Also adding sub-panels for setting up CF rules. Remaining work is to apply those rules and display an icon in the status bar.
Thanks jaoo. What's the new ETA for the finished change?
Adding Steve, Victoria and Patryck so they can help us with the missing icons. Contact Rafa to clarify.
Created attachment 688818 [details]
Icons

Sent these to Rafa yesterday, I believe he forwarded them to the dev.
Created attachment 688928 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/6837

Requesting review at kaze for the whole patch and timdream for taking a look at the code for showing the icon in the status bar.
Attachment #688335 - Attachment is obsolete: true
Attachment #688928 - Flags: review?(timdream+bugs)
Attachment #688928 - Flags: review?(kaze)
(In reply to Patryk Adamczyk [:patryk] UX from comment #27)
> Created attachment 688818 [details]
> Icons
> 
> Sent these to Rafa yesterday, I believe he forwarded them to the dev.

Got it but I still need an icon for the call entry in setting app.
(In reply to Dietrich Ayala (:dietrich) from comment #25)
> Thanks jaoo. What's the new ETA for the finished change?

We already have a working version, I've just requested review. There are still some esthetic to be done but as vingtetun said in comment #22 we can open a followup to deal with them.
Comment on attachment 688928 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/6837

status bar code looks good with s/cf/call-forwarding/.
Attachment #688928 - Flags: review?(timdream+bugs) → review+
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #31)
> Comment on attachment 688928 [details]
> Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/6837
> 
> status bar code looks good with s/cf/call-forwarding/.

Done. Thanks Tim!
Comment on attachment 688928 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/6837

Impressive work, well done and nicely integrated in the existing code.
Please merge your commits so we can land it.
Attachment #688928 - Flags: review?(kaze) → review+
Created attachment 689207 [details]
screenshot — Settings panel

UX-wise, I’m a bit worried that this “Call forwarding” item is at the root level in the Settings app and very high in the list. Larissa, what’s your recommendation for this?

We will have to open a UX-follow-up bug anyway, as several strings are too long (overlapping) in some sub-panels.

José-Antonio, please make sure you include the main icon in the CSS sprite with your PR — unless Larissa recommends to move the whole “Call forwarding” item to a sub-panel.
Attachment #689207 - Flags: feedback?(lco)
Flags: needinfo?(lco)
Created attachment 689308 [details] [diff] [review]
final patch

carrying r=kaze r=timdream
Attachment #688928 - Attachment is obsolete: true
https://github.com/mozilla-b2g/gaia/commit/9cc083a6cd4a90823ec9fd7a07e7b0b008b7ff48

need a follow up for the icon
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 37

5 years ago
(In reply to Fabien Cazenave [:kaze] from comment #34)
> Created attachment 689207 [details]
> screenshot — Settings panel
> 
> UX-wise, I’m a bit worried that this “Call forwarding” item is at the root
> level in the Settings app and very high in the list. Larissa, what’s your
> recommendation for this?

Because I wasn't designing this, I will trust Rafa and/or Marco to decide whether they feel it's important enough to be in the top level settings. A couple of suggestions if we go that route though:

- As a label, "Call" is a bit too similar to "Cellular and Data". It looks as if the intent is to add things other than Call Forwarding to this page. What are those things, and are there settings that can be moved from "Cellular & Data" in this case. (Call Waiting?)
- Related to this, we need to clearly distinguish which features go under "Call" and which features go under "Cellular and Data" for the future.
- In terms of order, I would probably put Cellular and Data before it. Depending on what it contains, I'm even tempted to move "Call" into Personalization because it's not really tied to any Network or Connectivity category.
- I think it's not useful to have a subheader with the service provider's name since it's the same as what "Cellular and Data" contains. Especially since the two settings are right next to each other.


> 
> We will have to open a UX-follow-up bug anyway, as several strings are too
> long (overlapping) in some sub-panels.

Ok, please cc me on that bug.
Flags: needinfo?(lco)
(In reply to Julien Wajsberg [:julienw] from comment #35)
> Created attachment 689308 [details] [diff] [review]
> final patch
> 
> carrying r=kaze r=timdream
Hey Julien, thanks for going ahead with it but sadly what you have pushed is not working properly. I'm still not sure what change you have made. Have you tested the functionality before pushing?. Code in https://github.com/jaoo/gaia/tree/803533 is working well.
jaoo> I've only rebased from master, there was no conflict.

I tested slightly, at least that it didn't break anything visible and that the setting was present, but that's right that I didn't test the complete feature.

The follow-up bug is Bug 819009 (for the icon and other UX things) but feel free to reopen this bug if you think this is necessary. I must admit I don't know much about this, Vivien and Kaze push me to push this patch...
I think we should backout this so that Jose Antonio can apply a clean patch
reverted my early commit : https://github.com/mozilla-b2g/gaia/commit/ffa71f69808cdf3b1bf7ef4770ded1321395ceca

Have fun ;)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
BTW you can apply my patch locally using |git am| because it was produced with |git format-patch|.
(In reply to Julien Wajsberg [:julienw] from comment #42)
> BTW you can apply my patch locally using |git am| because it was produced
> with |git format-patch|.

There is something fishy around the settings app in general (e.g. see bug 818834).
https://github.com/mozilla-b2g/gaia/commit/f5dfc27b1add62108b3cdee4efcb67393f1f1183
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Created attachment 689696 [details] [diff] [review]
l10n fix

Just a quick l10n follow-up, as the “call” entity was conflicting with an obsolete one (which was used for the sound settings).
Attachment #689696 - Flags: review?(felash)
Created attachment 689698 [details] [diff] [review]
l10n fix

Just a quick l10n follow-up, as the “call” entity was conflicting with an obsolete one (which was used for the sound settings).
Attachment #689698 - Flags: review?(felash)
Attachment #689698 - Attachment is obsolete: true
Attachment #689698 - Flags: review?(felash)
Attachment #689696 - Flags: review?(felash) → review+
https://github.com/mozilla-b2g/gaia/commit/88d92a619dce496818406e859a656b87dcd9c152
Blocks: 819528

Updated

5 years ago
Blocks: 821455

Updated

5 years ago
Duplicate of this bug: 802684

Updated

5 years ago
Blocks: 822922
Attachment #689207 - Flags: feedback?(lco)

Comment 49

5 years ago
Call forwarding UI are present on Settings. verified on unagi build id:  20130103070201. Also, See https://bugzilla.mozilla.org/show_bug.cgi?id=826477
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.