Closed Bug 804622 Opened 12 years ago Closed 12 years ago

Sidebar asks me to Log In, even though I'm logged in.

Categories

(Firefox Graveyard :: SocialAPI: Providers, defect)

19 Branch
x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mconley, Unassigned)

Details

Using Nightly (Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:19.0) Gecko/19.0 Firefox/19.0).

Observed behaviour:

1. The sidebar asks me to log in
2. I click "Log In"
3. A Facebook tab opens, and I'm already logged in.
4. Sidebar does not update.

Not sure how I got into that state. Let me know if there's any debugging info I should provide.
Version: 10 Branch → 19 Branch
Please try this again tomorrow, access to the facebook provider was blocked today, you likely ran into that and can close this once you verify.  It should be reenabled tonight (the 23rd).
Actually, I'm going to dupe these to a single bug, and if the issue is not resolved in a day, reopen.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0

Issue reported in comment #0 is still reproducible and it is not a duplicate of bug #804560.

Steps:
1. Login to facebook and enable the messenger sidebar
2. Log out from Facebook
3. Click the Log In button on the social api sidebar
4. Enter credentials and log in

Actual result:
You get logged in on facebook, but social api sidebar doesn't get updated (appears as if you are logged out) . 
On Mac OS X 10.8, the social api buttons appear as if you were logged in.
On Win 7 32bit, the button appears as if you are logged out
Status: RESOLVED → REOPENED
OS: Windows 7 → All
Resolution: DUPLICATE → ---
This generally is due to problems on the provider's side - they need to handle state changes on their end.
Component: SocialAPI → SocialAPI: Providers
From the meeting today there should be a fix ready for this waiting for an upcoming push
Keywords: push-needed
I am still experiencing the same problem. Has the fixed been pushed already?
This was fixed long ago. The more recent problems (in the past day or two) are tracked by bug 825264.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Keywords: push-needed
Resolution: --- → FIXED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.