The default bug view has changed. See this FAQ.

Add back Growl support for TB / SM Aurora

RESOLVED FIXED in Thunderbird 18.0

Status

MailNews Core
Backend
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Nomis101, Assigned: Nomis101)

Tracking

Thunderbird 18.0
x86
Mac OS X
Dependency tree / graph

SeaMonkey Tracking Flags

(thunderbird18 fixed, thunderbird19 unaffected, seamonkey2.15 fixed, seamonkey2.16 unaffected)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
If Bug 805837 adds back Growl support to Gecko 18, we should also reverse the changes we have done in Bug 792793 for comm-aurora.
(Assignee)

Comment 1

5 years ago
Growl support is now back in Gecko 18 in http://hg.mozilla.org/releases/mozilla-aurora/rev/8bc339726865
I can make a patch for adding support back to comm-aurora. Or would it simply be better to just hg backout http://hg.mozilla.org/releases/comm-aurora/rev/30465284129e ?
(Assignee)

Comment 2

4 years ago
Created attachment 678410 [details] [diff] [review]
Add growl back to comm-aurora

This patch simply adds back Growl support to comm-aurora (like it was before it was removed), as followup to Bug 805837. We instead could also just hg backout 30465284129e. 
Bug 805837 not only added Growl support back, it also disabled the 10.8 notification center support (because it is not ready for a release yet). So currently we have no notification support at all on OS X.




[Approval Request Comment]
Regression caused by (bug #): Bug 805837
User impact if declined: No notification support at all on OS X
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky): No risk
Attachment #678410 - Flags: review?(mbanner)
Attachment #678410 - Flags: approval-comm-aurora?
Blocks: 792793
Comment on attachment 678410 [details] [diff] [review]
Add growl back to comm-aurora

Ok, I think we'll have to go for this, but please can you post an apology to mozilla.dev.l10n with the reasons why we are doing this (i.e. the core changes got backed out).

I'm also going to roll the dice and say that I think we should add growlNotification back into comm-central for the next couple of cycles - basically until the Mac Notifications actually ship. That way, if it gets delayed further we're not going to upset L10n again (this could also be mentioned in the email to mozilla.dev.l10n).
Attachment #678410 - Flags: review?(mbanner)
Attachment #678410 - Flags: review+
Attachment #678410 - Flags: approval-comm-aurora?
Attachment #678410 - Flags: approval-comm-aurora+
Oh, also in that email, we should state it is a backout, i.e. locales will have already translated these strings previously.
(Assignee)

Comment 5

4 years ago
(In reply to Mark Banner (:standard8) from comment #3)
> Ok, I think we'll have to go for this, but please can you post an apology to
> mozilla.dev.l10n with the reasons why we are doing this (i.e. the core
> changes got backed out).
https://groups.google.com/forum/#!topic/mozilla.dev.l10n/0NZPDd1vx6I

(In reply to Mark Banner (:standard8) from comment #3) 
> I'm also going to roll the dice and say that I think we should add
> growlNotification back into comm-central for the next couple of cycles -
> basically until the Mac Notifications actually ship.
But than it need also to be added back for comm-central. But as I have read, they want to make the new W3C notifications the default (Bug 782211, Bug 629280, Bug 594543).
Keywords: checkin-needed
(In reply to Mark Banner (:standard8) from comment #3)
> Comment on attachment 678410 [details] [diff] [review]
> Add growl back to comm-aurora
> 

Just to be explicit for tracking purposes, I agree and approve this for SeaMonkey-Aurora [Gecko 18] as well.
https://hg.mozilla.org/releases/comm-aurora/rev/92762a5802d4
Assignee: nobody → Nomis101
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-seamonkey2.15: --- → fixed
status-seamonkey2.16: --- → unaffected
status-thunderbird18: --- → fixed
status-thunderbird19: --- → unaffected
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 18.0
Depends on: 827979

Comment 8

4 years ago
Should Growl be working in Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:19.0) Gecko/20100101 Firefox/19.0 SeaMonkey/2.16 ?  I'm no longer getting any Growl notifications in mailnews (or browser.)
(Assignee)

Comment 9

4 years ago
(In reply to Rich Gray (:rbgray) from comment #8)
> Should Growl be working in Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6;
> rv:19.0) Gecko/20100101 Firefox/19.0 SeaMonkey/2.16 ?  I'm no longer getting
> any Growl notifications in mailnews (or browser.)

There is no growl support in Gecko 19 and above. See Bug 827979 for putting it back. This Bug was only for TB/SM based on Gecko 18.

Updated

4 years ago
Blocks: 835002
You need to log in before you can comment on or make changes to this bug.