Add back Growl support for TB19/20/21 and SM 2.16/2.17/2.18

RESOLVED FIXED in Thunderbird 21.0

Status

MailNews Core
Backend
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Philip Chee, Assigned: Nomis101)

Tracking

Thunderbird 21.0
x86
Mac OS X
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird19- wontfix, thunderbird20+ fixed, seamonkey2.15 fixed, seamonkey2.16? fixed, seamonkey2.17 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
We should add back GROWL support to TB19/20 and SM 2.16/2.17 since Firefox is doing it in Bug 827979.

+++ This bug was initially created as a clone of Bug #806254 +++
> If Bug 805837 adds back Growl support to Gecko 18, we should also reverse
> the changes we have done in Bug 792793 for comm-aurora.

Bug 827979 - add Growl support back for Firefox 19 (Beta) and Firefox 20 (Aurora)

From Bug 827979 Comment 0:

> My understanding is that XUL notifications will come from bug 782211 but
> that has still not been completed. I think we should add growl back to 19
> and 20 for the same reason as we did for 18.
(Assignee)

Comment 1

4 years ago
Created attachment 706828 [details] [diff] [review]
Patch for TB19 / SM2.16
(Assignee)

Comment 2

4 years ago
Created attachment 706829 [details] [diff] [review]
Patch for TB20 / SM2.17
(Assignee)

Comment 3

4 years ago
Comment on attachment 706828 [details] [diff] [review]
Patch for TB19 / SM2.16

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 827979
User impact if declined: No notification support at all on OS X 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): No risk, same patch as in Bug 806254
Attachment #706828 - Flags: review?(mbanner)
Attachment #706828 - Flags: approval-mozilla-beta?
(Assignee)

Comment 4

4 years ago
Comment on attachment 706829 [details] [diff] [review]
Patch for TB20 / SM2.17

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 827979
User impact if declined: No notification support at all on OS X 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): No risk, same patch as in Bug 806254
Attachment #706829 - Flags: review?(mbanner)
Attachment #706829 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 5

4 years ago
By the way, both patches are the same and the same as the patch for Bug 806254. But made from different branches.
Comment on attachment 706828 [details] [diff] [review]
Patch for TB19 / SM2.16

wrong flags, resetting.
Attachment #706828 - Flags: approval-mozilla-beta? → approval-comm-beta?
Attachment #706829 - Flags: approval-mozilla-aurora? → approval-comm-aurora?

Comment 7

4 years ago
Yay!  WFM now.  Hadn't realized how much I'd miss Growl.   Thanks!

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:19.0) Gecko/20100101 Firefox/19.0 SeaMonkey/2.16
    Build identifier: 20130130211905
Comment on attachment 706828 [details] [diff] [review]
Patch for TB19 / SM2.16

If the SM team want to take this or not, that's up to them. We're not going to be releasing another beta of TB in this cycle.
Attachment #706828 - Flags: review?(mbanner) → review?(bugspam.Callek)
status-thunderbird19: affected → wontfix
tracking-thunderbird19: ? → -
tracking-thunderbird20: ? → +
tracking-thunderbird21: ? → +
Bumping versions in title, since bug 827979 also landed growl support back on mozilla-central.
Summary: Add back Growl support for TB19/20 and SM 2.16/2.17 → Add back Growl support for TB19/20/21 and SM 2.16/2.17/2.18
Comment on attachment 706829 [details] [diff] [review]
Patch for TB20 / SM2.17

Looks good to me.
https://hg.mozilla.org/comm-central/rev/48831ce7db7d
Assignee: nobody → Nomis101
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 21.0
status-thunderbird21: affected → ---
tracking-thunderbird21: + → ---
Attachment #706829 - Flags: review?(mbanner)
Attachment #706829 - Flags: review+
Attachment #706829 - Flags: approval-comm-aurora?
Attachment #706829 - Flags: approval-comm-aurora+

Comment 12

4 years ago
Comment on attachment 706828 [details] [diff] [review]
Patch for TB19 / SM2.16

Probably worth asking stefanh for feedback too.
Attachment #706828 - Flags: feedback?(stefanh)
(In reply to Ian Neal from comment #12)
> Comment on attachment 706828 [details] [diff] [review]
> Patch for TB19 / SM2.16
> 
> Probably worth asking stefanh for feedback too.

I was more thinking of the late l10n string perspective than the viability of the patch.

Comment 14

4 years ago
Comment on attachment 706828 [details] [diff] [review]
Patch for TB19 / SM2.16

f+ for attachment #706829 [details] [diff] [review] too since it's the same patch ;-)
Attachment #706828 - Flags: feedback?(stefanh) → feedback+
Comment on attachment 706829 [details] [diff] [review]
Patch for TB20 / SM2.17

https://hg.mozilla.org/releases/comm-aurora/rev/3c479c9f8c57
status-seamonkey2.17: affected → fixed
status-seamonkey2.18: affected → ---
status-thunderbird20: affected → fixed
tracking-seamonkey2.18: ? → ---
tracking-seamonkey2.17: ? → ---
Comment on attachment 706828 [details] [diff] [review]
Patch for TB19 / SM2.16

r+ and a+ (though it is late) its had plenty of bake, I can't set a+ though in this component. :(
Attachment #706828 - Flags: review?(bugspam.Callek) → review+
Mark, can you rubber-stamp this for me (I know it has late-l10n, but I think its worth it given the growl re-add, for SeaMonkey) -- for TB theres no more betas anyway.  I want this landed by the time the migrations start.
Flags: needinfo?(mbanner)
(Reporter)

Comment 18

4 years ago
Pushed to comm-beta r+a=Callek:
http://hg.mozilla.org/releases/comm-beta/rev/c32f17244f9a
status-seamonkey2.16: affected → fixed
Attachment #706828 - Flags: approval-comm-beta? → approval-comm-beta+
Flags: needinfo?(mbanner)
You need to log in before you can comment on or make changes to this bug.