Closed Bug 807125 Opened 7 years ago Closed 7 years ago

roll out mozharness b2g emulator tests to mozilla-central + project branches when ready

Categories

(Release Engineering :: Applications: MozharnessCore, defect)

All
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aki, Assigned: aki)

References

Details

(Whiteboard: [mozharness][unittest])

Attachments

(3 files, 3 obsolete files)

Mochitests are almost ready; reftests are coming soon and webapi needs to be orange.
Depends on: 807698
Depends on: 807771
Depends on: 808085
Depends on: 808739
Depends on: 808780
Attached patch fix wait times report (obsolete) — Splinter Review
Attachment #678791 - Flags: review?(nthomas)
Depends on: 797153
Depends on: 809233
Comment on attachment 678791 [details] [diff] [review]
fix wait times report

This works for the b2g tests, but the ics/unagi/panda builds lose their attribution to 'linux-mock' and get 'other' instead. It does put b2g_*_win32_gecko nightly into win2k3 properly though.
Attachment #678791 - Flags: review?(nthomas) → review-
Attached file list of builders
Distinct builder names from the last ~100000 jobs to help with testing.
Attachment #678791 - Attachment is obsolete: true
Attachment #679368 - Flags: review?(nthomas)
Attached file test script used (obsolete) —
Attachment #679368 - Flags: review?(nthomas) → review+
Depends on: 809951
Duplicate of this bug: 769820
Attachment #679370 - Attachment is obsolete: true
Attachment #679372 - Attachment is obsolete: true
Attachment #691130 - Flags: review?(bhearsum)
Attachment #691130 - Flags: review?(bhearsum) → review+
The above patch should be ready to land. Note that since we are using mozilla-b2g18 instead of mozilla-beta, beta is missing a few changes to make this run green. I think in general we should hide all b2g builds and tests on beta temporarily until the next uplift.
Come to think of it, inbound will also fail until the next time m-c gets merged back in :/
This is in production.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Depends on: 834390
Depends on: 839225
Product: mozilla.org → Release Engineering
Component: General Automation → Mozharness
You need to log in before you can comment on or make changes to this bug.