Printing tables over a page

VERIFIED FIXED in mozilla0.9.7

Status

()

P2
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: ste_ve, Assigned: karnaze)

Tracking

Trunk
mozilla0.9.7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PATCH CANDIDATE_094, URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
When Mozilla encounters a table to print that's bigger than the rest of the page
it treats it like an image? and will print on the next page and if the table is
bigger than a page then it won't print the rest of it.

See attachment taken from cisco web page 

<!doctype html public "-//w3c//dtd html 4.0 transitional//en">
<html>
<head>
   <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
   <meta name="Repository" content="CCEWP">
   <meta name="author" content="llgilber">
   <meta name="SearchPublicationDate" content="Mon, 23 Apr 2001 19:47:00 GMT">
   <meta name="FileOwner" content="llgilber">
   <meta name="FileName" content="bri-back-dp.html">
   <meta name="Folder" content="/warp/customer/129">
   <meta name="Object_ID" content="5145770">
   <meta name="Chronicle ID" content="5129194">
   <meta name="Revision" content="/main/CCO/2">
   <meta name="CCOCategoryType" content="Support">
   <meta name="PubDate" content="Wed, 25 Apr 2001 13:14:17 GMT">
   <meta name="PushDate" content="Wed, 25 Apr 2001 13:14:55 GMT">
   <meta name="ParentTree" content="/warp/customer/129">
   <meta name="Parents" content="/warp/customer/129">
   <meta name="Language" content="US_en">
   <meta http-equiv="Expires" content="4/23/02">
   <meta name="Glob97" content="Internetworking:ISDN:Sample_Configs,">
   <meta name="Keywords" content="BRI ddr dialer profile backup interface">
   <meta http-equiv="Owner" content="llgilber@cisco.com">
   <meta http-equiv="Reply-to" content="access-feedback@cisco.com">
   <meta name="Subject97" content="Internetworking:ISDN:Sample_Configs">
   <meta name="DocType" content="SampleConfig">
   <meta name="GENERATOR" content="Mozilla/4.76 [en] (Win98; U) [Netscape]">
   <title>Cisco - Configuring BRI Backup Interface with Dialer Profiles</title>
<!-- source by npanicke -->
<!-- reviewed by burgess,revieweruserid (no spaces after commas) -->
<!-- posted to CCO by llgilber on 04/23/2001 -->
<!-- updated per SMEuserid by TWuserid on MM/DD/YYYY -->
<!-- re-certified by SMEuserid and TWuserid on MM/DD/YYYY -->
</head>
<body bgcolor="#FFFFFF">
&nbsp;
<br>This configuration uses a BRI circuit to backup a serial link. It also
uses the Open Shortest Path First (OSPF) routing protocol between the two
routers. Once the backup connection is activated, you must ensure that
the routing table is updated to use the new backup link. Only one side
(maui-soho-01) is configured to dial out. The other side (maui-nas-05)
is configured to accept the call.
<p>In this configuration we have a Cisco 1604 router connected to a Cisco
3640 router using a serial connection. Both routers are also equipped with
BRI interfaces that will be used for the backup link. The Cisco 1604 is
running Cisco IOS<sup>&reg;</sup> Software Release 12.1(5)T and the Cisco
3640 is using Cisco IOS 12.1(2).
<p><b>Note</b>: Configure and verify that the DDR connection (dialer 1
with BRI0) is working properly before you configure the <b>backup interface</b>
and <b>backup delay</b> commands. This will allow you to effectively manage
troubleshooting dialer profiles, ISDN, Point-to-Point Protocol (PPP) and
authentication issues before you configure the backup.
<br>&nbsp;
<table BORDER CELLPADDING=3 WIDTH="80%" BGCOLOR="#FFFFFF" valign="TOP" >
<tr BGCOLOR="#CCCCFF">
<th><b>maui-soho-01 (1600)</b></th>
</tr>

<tr>
<td HEIGHT="1486">
<pre>maui-soho-01#<b>show running-config&nbsp;
</b>Building configuration...

Current configuration : 1687 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local
<i><font color="#3333FF">!--- basic AAA configuration for ppp calls
</font></i>enable secret 5 &lt;deleted>
!
username maui-nas-05 password 0 cisco
<i><font color="#3333FF">!--- username for remote router (maui-nas-05) and
shared secret
!---(used for CHAP authentication)
!--- shared secret must be the same on both sides
</font></i>ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
&nbsp;ip address 172.17.1.1 255.255.255.0
<i><font color="#3333FF">!--- The loopback address will be used by OSPF for the
router ID.
</font></i>!
interface Ethernet0
&nbsp;ip address 172.16.1.1 255.255.255.0
!
interface Serial0
<i><font color="#3333FF">!--- Primary Interface
</font></i>&nbsp;backup delay 10 30
<i><font color="#3333FF">!--- Backup link will be activated 10 seconds after
primary link
&nbsp;goes down.
!--- Backup link will be deactivated 30 seconds after primary
&nbsp;link
&nbsp;is restored.
</font></i>&nbsp;backup interface Dialer1
<i><font color="#3333FF">!--- Interface Dialer 1 will provide backup.
</font></i>&nbsp;ip address 192.168.10.2 255.255.255.252
&nbsp;encapsulation ppp
&nbsp;no fair-queue
&nbsp;clockrate 64000
&nbsp;ppp authentication chap
!
interface BRI0
&nbsp;ip unnumbered Loopback0
<i><font color="#3333FF">!--- unnumbered to the Loopback 0 address
</font></i>&nbsp;encapsulation ppp
&nbsp;dialer pool-member 10
<i><font color="#3333FF">!--- Assign BRI0 as member of dialer pool 10.
!--- Dialer pool 10 is specified in interface Dialer 1.
</font></i>&nbsp;isdn switch-type basic-ni
&nbsp;isdn spid1 51255511110101 5551111
&nbsp;isdn spid2 51255511120101 5551112
&nbsp;ppp authentication chap
<i><font color="#3333FF">!--- Use ppp chap authentication.
</font></i>&nbsp;ppp multilink
!
interface Dialer1
<i><font color="#3333FF">!--- Dialer 1 provides backup for the serial link.
</font></i>&nbsp;ip address 172.20.10.2 255.255.255.0
<i><font color="#3333FF">!--- Address for the dialer interface.&nbsp;
!--- The remote side dialer interface is in the same subnet.
</font></i>&nbsp;encapsulation ppp
&nbsp;dialer pool 10
<i><font color="#3333FF">!--- defines Dialer pool 10
!--- BRI 0 is a member of this pool.
</font></i>&nbsp;dialer remote-name maui-nas-05
<i><font color="#3333FF">!--- specifies remote router name&nbsp;
!--- This name must match that used by the remote router to
&nbsp;authenticate itself.
</font></i>&nbsp;dialer idle-timeout 900
<i><font color="#3333FF">!--- Idle timeout is set to 900 seconds (15 minutes).
!--- The link will be disconnected if there is no interesting
&nbsp;traffic for 900 secs.
!--- Since OSPF hellos are interesting traffic, this will reset
&nbsp;the idle timeout and
!--- cause the link to stay up until the primary link is
!--- restored.
</font></i>&nbsp;dialer string 5552222
<i><font color="#3333FF">!--- defines the destination routers phone number
</font></i>&nbsp;dialer load-threshold 80 outbound
<i><font color="#3333FF">!--- This sets the outbound load level for traffic at
which&nbsp;
!---additional connections will be added to the MP bundle load level.
!--- Values range from 1 (unloaded) to 255 (fully loaded). The threshold
!--- in this case is 80/255=32%.
</font></i>&nbsp;dialer-group 1
<i><font color="#3333FF">!--- apply interesting traffic definition from
dialer-list 1
</font></i>&nbsp;ppp authentication chap
<i><font color="#3333FF">!--- use ppp chap authentication
</font></i>&nbsp;ppp multilink
!
router ospf 5
&nbsp;log-adjacency-changes
&nbsp;network 172.16.1.0 0.0.0.255 area 0
&nbsp;network 172.17.1.0 0.0.0.255 area 0
&nbsp;network 172.20.10.0 0.0.0.255 area 0
&nbsp;network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
<i><font color="#3333FF">!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.
!--- OSPF hello packets will trigger the dial.
</font></i>!
line con 0
&nbsp;exec-timeout 0 0
&nbsp;login authentication NO_AUTHEN
&nbsp;transport input none
line vty 0 4
!
end</pre>
</td>
</tr>
</table>

<table BORDER CELLPADDING=3 WIDTH="80%" BGCOLOR="#FFFFFF" valign="TOP" >
<tr BGCOLOR="#CCCCFF">
<th><b>maui-nas-05 (3640)</b></th>
</tr>

<tr>
<td>
<pre>maui-nas-05#<b>show running-config&nbsp;
</b>Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local
<i><font color="#0000FF">!--- basic AAA configuration for ppp calls
</font></i>enable secret 5 &lt;deleted>
!
username maui-soho-01 password 0 cisco
<i><font color="#3333FF">!--- username for remote router (maui-soho-01) and
shared secret
!---(used for CHAP authentication)
!--- shared secret must be the same on both sides
</font></i>ip subnet-zero
!&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
isdn switch-type basic-ni
!
interface Loopback0
&nbsp;ip address 172.22.1.1 255.255.255.0
<i><font color="#0000FF">!--- The loopback address will be used by OSPF for the
router ID.
</font></i>!
interface Ethernet0/0
&nbsp;ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
&nbsp;no ip address
&nbsp;shutdown
!
interface BRI1/0
&nbsp;ip unnumbered Loopback0
<i><font color="#0000FF">!--- unnumbered to the Loopback 0 address
</font></i>&nbsp;encapsulation ppp
&nbsp;dialer pool-member 20
<i><font color="#0000FF">!--- Assign BRI0 as member of dialer pool 20.
!--- Dialer pool 20 is specified in interface Dialer 1.
</font></i>&nbsp;isdn switch-type basic-ni
&nbsp;isdn spid1 51255522220101 5552222
&nbsp;isdn spid2 51255522230101 5552223
&nbsp;ppp authentication chap
<i><font color="#0000FF">!--- Use ppp chap authentication.
</font></i>&nbsp;ppp multilink
!
<i><font color="#0000FF">! &lt;&lt;-- Unused interface configurations have been
removed.
</font></i>!
interface Serial2/0
<i><font color="#0000FF">!--- primary interface
</font></i>&nbsp;ip address 192.168.10.1 255.255.255.252
&nbsp;encapsulation ppp
&nbsp;no fair-queue
&nbsp;ppp authentication chap
!
<i><font color="#0000FF">! &lt;&lt;--Unused interface configurations have been
removed.
</font></i>!
interface Dialer1
<i><font color="#0000FF">!--- Dialer 1 provides backup for the serial link.
</font></i>&nbsp;ip address 172.20.10.1 255.255.255.0
<i><font color="#0000FF">!--- address for the dialer interface&nbsp;
!--- The remote side dialer interface is in the same subnet.
</font></i>&nbsp;encapsulation ppp
&nbsp;dialer remote-name maui-soho-01
<i><font color="#0000FF">!--- specifies remote router name&nbsp;
!--- This name must match that used by the remote router to
&nbsp;authenticate itself.
</font></i>&nbsp;dialer pool 20
<i><font color="#0000FF">!--- defines dialer pool 20
</font></i>&nbsp;dialer idle-timeout 900
<i><font color="#0000FF">!--- Idle timeout is set to 900 seconds (15 minutes).
!--- This is equal to the idle timeout set on maui-soho-01.
</font></i>&nbsp;Dialer max-call 4096
&nbsp;dialer-group 1
<i><font color="#0000FF">!--- apply interesting traffic definition from
dialer-list 1
</font></i>&nbsp;ppp authentication chap
<i><font color="#0000FF">!--- Use ppp chap authentication.
</font></i>&nbsp;ppp multilink
!
router ospf 5
&nbsp;network 172.20.10.0 0.0.0.255 area 0
&nbsp;network 172.22.1.0 0.0.0.255 area 0
&nbsp;network 172.22.53.0 0.0.0.255 area 0
&nbsp;network 192.168.10.0 0.0.0.3 area 0
&nbsp;default-information originate
<i><font color="#0000FF">!--- transmit ospf default information&nbsp;
!--- This may be required for remote router to use the BRI DDR
&nbsp;link.
</font></i>!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit
<i><font color="#0000FF">!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group
&nbsp;1.
</font></i>!
line con 0
&nbsp;login authentication NO_AUTHEN
&nbsp;transport input none
line 97 102
line aux 0
line vty 0 4
!
end

</pre>
</td>
</tr>
</table>

<h2>
<a NAME="debug"></a>Debug and Show Commands</h2>
Before issuing <b>debug</b> commands, please see <a
href="http://www.cisco.com/warp/customer/793/access_dial/debug.html">Important
Information on Debug Commands</a>.
<ul><b>show isdn status</b> - Ensure that the router is properly communicating
with the ISDN switch. In the output, verify that Layer 1 Status is ACTIVE,
and that the Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED appears.
This command also displays the number of active calls.
<p><b>show ip interface brief</b> - This will show dialer 1(on maui-soho-01)
in standby mode. Using dialer 1 as the backup interface means the physical
interface (BRI0) is not dedicated to the backup. Therefor, BRI 0 can be
used for normal DDR while the primary link is up
<p><b>debug dialer</b> - This is used to display DDR information about
the packets received on the dialer interface.
<p><b>debug isdn events</b> - This is used to see ISDN activity occurring
on the user side of the ISDN interface.
<p><b>debug isdn q931</b> - Shows call setup and tear down of the ISDN
network connection (Layer 3) between the router and the ISDN switch.
<p><b>debug ppp negotiation</b> - Displays information on PPP traffic and
exchanges while negotiating the PPP components including Link Control Protocol
(LCP), Authentication, and NCP. A successful PPP negotiation will first
open the LCP state, then Authenticate, and finally negotiate NCP.
<p><b>debug ppp authentication</b> - Displays the PPP authentication protocol
messages, including Challenge Authentication Protocol (CHAP) packet exchanges
and Password Authentication Protocol (PAP) exchanges. If you observe a
failure verify that the chap username and password are configured correctly.
<p><b>debug ppp error</b> - This is used to display protocol errors and
error statistics associated with PPP connection negotiation and operation.</ul>
<font size=-1></font>
</body>
</html>
over to tables.  This is a duplicate....
Assignee: dcone → karnaze
Component: Printing → HTMLTables
OS: Windows 98 → All
QA Contact: sujay → amar
Hardware: PC → All
Whiteboard: DUPEME

Comment 2

18 years ago

*** This bug has been marked as a duplicate of 66804 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

18 years ago
Problem still in 2001052904 so maybe not a dupe of bug 66804 that is supposed to 
be fixed now.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

18 years ago
*** Bug 85390 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
This is either a dup of bug 66804 or of bug 83683, or both.
(Reporter)

Comment 6

18 years ago
The point I was trying to make with this bug is that the print process is 
treating this table (maybe all tables) like an image - in so far as it seems to 
try and fit the table on the current page and if it doesn't fit then it starts a 
new page. This behaviour is imho incorrect and it should start printing the 
table even if it won't fit on the current page and continue on the next page 
which is how ie and netscape 4 do it. 

I don't know if this is a dupe of 66804 as the symptons don't seem to match and 
66804 has fluctuated from being fixed and not fixed.

Comment 7

18 years ago
Going to go ahead and mark NEW and let the printing people decide if its the
exact same bug or not.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: DUPEME

Comment 8

18 years ago
marking DUP of 90732 because that bug has several URL's that need to
be tested whne that bug is fixed. I'll add everyone on this bug
report to that one so you can all track it...

*** This bug has been marked as a duplicate of 90732 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 10

18 years ago
Amar, can you take a look at this? thanks..
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 11

18 years ago
Amar, this could be DUP of 66804....
 Yeah this is a dupe of Bug # 66804..

Comment 13

17 years ago
comments from Steve..

"Downloaded trunk 2001111303 and tested with html scipt as posted on bug 80966 
(my original post for this bug). The script is taken from a cisco web page. It 
does not print the table correctly. It should print the table following the text 
as does ie and netscape 4.76 and not start a new page. Also on the new page it 
prints the table header then leaves a gap which is done on the following page as 
well. This bug is not fixed in this build."

Steve, lets keep this discussion in "this" bug report. That other bug 105166 is
fixed and verified.

Comment 14

17 years ago
Amar, Steve insists this problem is still happening..It is not a DUP
of bug 66804 or bug 105166...this is an independent problem of those
bugs...and its definitely table related..

can you test this out and add your comments here Amar? thanks...

Steve, lets keep the discussion to this bug report....and not
in bug 105166


thanks.

Comment 15

17 years ago

should we mark this bug a DUP of 105166 ?
(Assignee)

Updated

17 years ago
Status: REOPENED → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 16

17 years ago
Created attachment 57819 [details] [diff] [review]
patch to fix the bug
(Assignee)

Updated

17 years ago
Whiteboard: PATCH

Comment 17

17 years ago
Comment on attachment 57819 [details] [diff] [review]
patch to fix the bug

r= alexsavulov
Attachment #57819 - Flags: review+

Comment 18

17 years ago
Comment on attachment 57819 [details] [diff] [review]
patch to fix the bug

sr=attinasi
Attachment #57819 - Flags: superreview+
(Assignee)

Comment 19

17 years ago
The patch is in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
Whiteboard: PATCH → PATCH CANDIDATE_094

Comment 20

17 years ago
Okay looks like the fix is in...

Amar, can you verify this bug ? I will verify the other URLs
in bug 110336.

Steve, if you get a chance, download the latest build and
see if it works for you now...thanks.

looks like this one is fixed and the changes are shown in Build ID: 2001111603
Marking verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 22

17 years ago
Tested w. 2001111503 & problem fixed. My thanks to everyone who worked on this 
bug.
*** Bug 111203 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.