Last Comment Bug 811770 - Use a different wordmark and possibly other branding changes for Thunderbird 17 ESR
: Use a different wordmark and possibly other branding changes for Thunderbird ...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 21.0
Assigned To: Mark Banner (:standard8)
:
Mentors:
: 815607 815613 (view as bug list)
Depends on: 721661 836041
Blocks: 796975 815302 836036 838794
  Show dependency treegraph
 
Reported: 2012-11-14 09:51 PST by Mark Banner (:standard8)
Modified: 2013-02-06 12:56 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
18+
fixed


Attachments
Initial ESR fix (7.35 KB, patch)
2012-11-16 03:51 PST, Mark Banner (:standard8)
mconley: review+
standard8: approval‑comm‑esr17+
Details | Diff | Review
Main rework for the branding (4.91 KB, patch)
2012-12-31 13:11 PST, Mark Banner (:standard8)
no flags Details | Diff | Review
Revert the about dialog wordmark for release versions (4.89 KB, patch)
2012-12-31 13:12 PST, Mark Banner (:standard8)
mconley: review+
standard8: approval‑comm‑esr17+
Details | Diff | Review
Copy release mozconfigs for esr (2.15 KB, patch)
2012-12-31 13:14 PST, Mark Banner (:standard8)
no flags Details | Diff | Review
Copy mozconfigs for esr v2 (2.18 KB, patch)
2013-01-02 12:31 PST, Mark Banner (:standard8)
mconley: review+
standard8: approval‑comm‑esr17+
Details | Diff | Review
Main rework for the branding v2 (4.73 KB, patch)
2013-01-02 12:39 PST, Mark Banner (:standard8)
mconley: review+
standard8: approval‑comm‑esr17+
Details | Diff | Review
Fix ESR branding (982 bytes, patch)
2013-01-29 15:26 PST, Mark Banner (:standard8)
jhopkins: review+
standard8: approval‑comm‑esr17+
Details | Diff | Review

Description Mark Banner (:standard8) 2012-11-14 09:51:09 PST
+++ This bug was initially created as a clone of Bug #721661 +++

We're going to adopt a wordmark for Thunderbird for the ESR releases - we need to port the work onto TB 17 ESR.
Comment 1 Mark Banner (:standard8) 2012-11-16 03:51:01 PST
Created attachment 682411 [details] [diff] [review]
Initial ESR fix

Okay, initially we're going to do this the same way as we do normal releases - use the existing mozconfigs and hence use the "offical" branding.

Once we get past the initial esr release, we'll switch to a separate branding directory which will deal with having ESR and mainstream on the same branch.

I'll do the patch for that later.
Comment 2 Mark Banner (:standard8) 2012-11-16 03:52:34 PST
Oh, the preference changes are because we need to distinguish between ESR & non-ESR for the what's new and release notes and we can't do that via the version numbers now.
Comment 3 Mike Conley (:mconley) - (needinfo me!) 2012-11-16 07:50:19 PST
Comment on attachment 682411 [details] [diff] [review]
Initial ESR fix

Looks good to me.
Comment 4 Mark Banner (:standard8) 2012-11-16 08:21:04 PST
Comment on attachment 682411 [details] [diff] [review]
Initial ESR fix

[Triage Comment]
a=me for comm-esr17.
Comment 5 Mark Banner (:standard8) 2012-11-16 08:22:13 PST
Checked in: https://hg.mozilla.org/releases/comm-esr17/rev/1fb7584b4064

Leaving open to remember to do the follow-up changes.
Comment 6 Mark Banner (:standard8) 2012-12-31 13:11:15 PST
Created attachment 696794 [details] [diff] [review]
Main rework for the branding

This patch adds the capability for an environment variable to modify the official branding options so that we're branding as ESR.

Doing it this way avoids the need for a separate directory which would adversely affect l10n (who would need to have two lots of the branded locale files).

This is a solution to land on esr17-only at the moment. I'm planning on revising some of the branding that we currently use before ESR 24.

Two more patches coming.
Comment 7 Mark Banner (:standard8) 2012-12-31 13:12:48 PST
Created attachment 696795 [details] [diff] [review]
Revert the about dialog wordmark for release versions

This patch reverts the about-wordmark.png to what was there before attachment 682411 [details] [diff] [review] on this bug landed. This means we get that as the release wordmark. The esr one was created in the previous patch by copying this, and is called about-esr-wordmark.png.
Comment 8 Mark Banner (:standard8) 2012-12-31 13:14:32 PST
Created attachment 696796 [details] [diff] [review]
Copy release mozconfigs for esr

This is the final patch we need - it copies the 'release' mozconfigs to 'esr' and adds the necessary environment variable for building as ESR.

I've tested the builds on my machine for both release and esr built from the same source with the different mozconfigs and it worked fine.
Comment 9 Mike Conley (:mconley) - (needinfo me!) 2013-01-02 12:20:33 PST
Comment on attachment 696794 [details] [diff] [review]
Main rework for the branding

Review of attachment 696794 [details] [diff] [review]:
-----------------------------------------------------------------

Just two notes.

::: mail/confvars.sh
@@ +43,5 @@
> +  ACCEPTED_MAR_CHANNEL_IDS=thunderbird-comm-esr
> +  # The MAR_CHANNEL_ID must not contain the following 3 characters: ",\t "
> +  MAR_CHANNEL_ID=thunderbird-comm-esr
> +else
> +  MOZ_OFFICIAL_BRANDING_DIRECTORY=other-licenses/branding/thunderbird

Lines 39 and 47 execute regardless of $MOZ_ESR, so should be put outside of the conditional.

::: other-licenses/branding/thunderbird/Makefile.in
@@ +14,5 @@
>  	locales \
>  	$(NULL)
>  
> +ifdef MOZ_ESR
> +PREF_JS_EXPORTS = $(srcdir)/thunderbird-esr-branding.js

Where is thunderbird-esr-branding.js? I don't see it in any of your patches.
Comment 10 Mike Conley (:mconley) - (needinfo me!) 2013-01-02 12:23:06 PST
Comment on attachment 696796 [details] [diff] [review]
Copy release mozconfigs for esr

Review of attachment 696796 [details] [diff] [review]:
-----------------------------------------------------------------

Why do we need export for MOZ_DEBUG_SYMBOLS, but not for MOZ_ESR?
Comment 11 Mark Banner (:standard8) 2013-01-02 12:31:53 PST
Created attachment 697144 [details] [diff] [review]
Copy mozconfigs for esr v2

Add the export.
Comment 12 Mike Conley (:mconley) - (needinfo me!) 2013-01-02 12:32:43 PST
Comment on attachment 697144 [details] [diff] [review]
Copy mozconfigs for esr v2

Review of attachment 697144 [details] [diff] [review]:
-----------------------------------------------------------------

Great, thanks!
Comment 13 Mark Banner (:standard8) 2013-01-02 12:35:42 PST
(In reply to Mike Conley (:mconley) from comment #9)
> ::: other-licenses/branding/thunderbird/Makefile.in
> @@ +14,5 @@
> >  	locales \
> >  	$(NULL)
> >  
> > +ifdef MOZ_ESR
> > +PREF_JS_EXPORTS = $(srcdir)/thunderbird-esr-branding.js
> 
> Where is thunderbird-esr-branding.js? I don't see it in any of your patches.

It is a hg copy... might not show up in splinter.
Comment 14 Mike Conley (:mconley) - (needinfo me!) 2013-01-02 12:37:09 PST
(In reply to Mark Banner (:standard8) from comment #13)
> (In reply to Mike Conley (:mconley) from comment #9)
> > ::: other-licenses/branding/thunderbird/Makefile.in
> > @@ +14,5 @@
> > >  	locales \
> > >  	$(NULL)
> > >  
> > > +ifdef MOZ_ESR
> > > +PREF_JS_EXPORTS = $(srcdir)/thunderbird-esr-branding.js
> > 
> > Where is thunderbird-esr-branding.js? I don't see it in any of your patches.
> 
> It is a hg copy... might not show up in splinter.

Ah, you're right - I see the copy in the diff.
Comment 15 Mark Banner (:standard8) 2013-01-02 12:39:01 PST
Created attachment 697149 [details] [diff] [review]
Main rework for the branding v2

Updated confvars.sh. Note the thunderbird-esr-branding.js as per my previous comment.
Comment 16 Mike Conley (:mconley) - (needinfo me!) 2013-01-02 12:41:15 PST
Comment on attachment 697149 [details] [diff] [review]
Main rework for the branding v2

Review of attachment 697149 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great. Thanks Mark!
Comment 17 Mark Banner (:standard8) 2013-01-02 13:11:49 PST
Comment on attachment 696795 [details] [diff] [review]
Revert the about dialog wordmark for release versions

[Triage Comment]
a=me for all of these simple build fixes.
Comment 19 Mark Banner (:standard8) 2013-01-02 13:16:43 PST
*** Bug 815607 has been marked as a duplicate of this bug. ***
Comment 20 Mark Banner (:standard8) 2013-01-02 13:17:13 PST
*** Bug 815613 has been marked as a duplicate of this bug. ***
Comment 21 Ben Hearsum (:bhearsum) 2013-01-04 13:05:08 PST
The mozconfig changes here caused us to fail some pre-release checks. In order to fix them, I added MOZ_ESR=1 to the comm-esr17 nightly mozconfigs, too. I don't know if that's the correct fix, so this may need changing later. https://hg.mozilla.org/releases/comm-esr17/rev/2afbc44b8134
Comment 22 Mark Banner (:standard8) 2013-01-29 15:26:53 PST
Created attachment 707850 [details] [diff] [review]
Fix ESR branding

This fixes the branding packaging so that we'll package the appropriate thunderbird-(esr-)branding.js depending on if we're ok or not.

I've tested this on local builds & packaging and it worked fine.

This should at least allow us to build esr off the new mozconfigs for the new branding.

The non-esr part is reliant on other bugs at the moment.
Comment 23 Mark Banner (:standard8) 2013-01-30 00:41:22 PST
Comment on attachment 707850 [details] [diff] [review]
Fix ESR branding

[Triage Comment]
Need this for ESR 17 packaging.
Comment 24 Mark Banner (:standard8) 2013-01-30 00:42:39 PST
Comment on attachment 707850 [details] [diff] [review]
Fix ESR branding

Checked in:

https://hg.mozilla.org/releases/comm-esr17/rev/56b85911cf0b
Comment 25 Mark Banner (:standard8) 2013-01-30 05:30:40 PST
(In reply to Mark Banner (:standard8) from comment #24)
> Comment on attachment 707850 [details] [diff] [review]
> Fix ESR branding
> 
> Checked in:
> 
> https://hg.mozilla.org/releases/comm-esr17/rev/56b85911cf0b

I also had to backout the patch mentioned in comment 21 as unit tests were failing due to mis-matached mozconfigs & branding - we'll need to fix it properly in bug 836036.

https://hg.mozilla.org/releases/comm-esr17/rev/830f2f1e3a36
Comment 26 Mark Banner (:standard8) 2013-02-06 12:56:43 PST
This is fixed now, porting to trunk is going to be handled in bug 838794.

Note You need to log in before you can comment on or make changes to this bug.